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1 Get started with structural
analysis

This section explains some basic concepts and procedures you need to know
to get started with structural analysis in Tekla Structures.

Click the links below to find out more:

What is an analysis model (page 7)

About analysis applications (page 12)

Link Tekla Structures with an analysis application (page 12)

Structural analysis workflow in Tekla Structures (page 13)

1.1 What is an analysis model
When you use Tekla Structures to model, analyze, and design structures, you
will become familiar with the following concepts:

A physical model is a structural 3D model that includes the parts you create
using Tekla Structures, and information related to them. Each part in the
physical model will exist in the completed structure.
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The physical model also contains information about the loads and load groups
that act on the physical model parts, and information about the building code
that Tekla Structures uses in the load combination process.

An analysis model is a structural model that is created from a physical model. It
is used for analyzing structural behavior and load bearing, and for design.
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When you create an analysis model, Tekla Structures generates the following
analysis objects and includes them in the analysis model:

• Analysis parts, bars, members, and areas of the physical parts

• Analysis nodes

• Support conditions for nodes

• Rigid links between the analysis parts and nodes

• Loads to analysis parts

The analysis model also includes load combinations.

See also

Analysis model objects (page 9)

Create loads (page 22)

Create analysis models (page 47)

Analysis model objects
Analysis model objects are model objects that Tekla Structures creates from
physical model objects or on the basis of analysis part connectivity into an
analysis model.
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Object Description
Analysis part A representation of a physical part in an analysis

model.

In different analysis models, a physical part is
represented by different analysis parts.

Analysis bar An analysis object that Tekla Structures creates
from a physical part (beam, column, or brace) or
from a part segment.

Tekla Structures creates more than one analysis
bar from a physical part if:

• The part is a polybeam

• The part cross section changes non-linearly

An analysis bar consists of one or more analysis
members.

Analysis member An analysis object that Tekla Structures creates
between two nodes.

Tekla Structures creates more than one analysis
member from an analysis bar if the bar intersects
with other bars and needs to be split.

Every physical part that you include in an analysis
model produces one or more analysis members.
A single physical part produces several analysis
members if the physical part intersects with other
physical parts. Tekla Structures splits the physical
part at the intersection points of the analysis
axes. For example, a physical model beam that
supports two other beams is split into three
analysis members between nodes.

Analysis area An analysis object that represents a plate, slab, or
panel in an analysis model.

Analysis element An analysis object that the analysis application
creates from an analysis area.

The analysis application creates an element mesh
that includes several analysis elements.
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Object Description
Analysis node An analysis object that Tekla Structures creates at a

defined point in an analysis model on the basis of
analysis part connectivity.

Tekla Structures creates analysis nodes at:

• The ends of members

• The intersection points of analysis axes

• The corners of elements

You can also manually add analysis nodes
(page 61) and merge them (page 63).

Rigid link An analysis object that connects two analysis
nodes so that they do not move in relation to each
other.

Rigid links have the following properties in Tekla
Structures analysis models:

• Profile = PL300.0*300.0

• Material = RigidlinkMaterial

• Density = 0.0

• Modulus of elasticity = 100*109 N/m2

• Poisson’s ratio = 0.30

• Thermal dilatation coefficient = 0.0 1/K

The analysis application that you use may model
rigid links by dedicated rigid link objects.

You can also manually add rigid links (page 62).
Rigid diaphragm An analysis object that connects more than two

analysis nodes that move with exactly the same
rotation and translation.

Some analysis applications work on analysis members whereas others work
on analysis bars. This also affects how analysis models are shown in Tekla
Structures model views. Either member numbers or bar numbers are shown.

The dark blue circles close to the analysis part ends represent pinned part
ends.

See also

Modify analysis parts (page 65)
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Objects included in analysis models (page 47)

Show analysis bar, member, and node numbers (page 100)

1.2 About analysis applications
An analysis application is an external analysis and design software that you use
with Tekla Structures to analyze and design structures.

The analysis application calculates the forces, moments, and stresses on the
structures. It also calculates the displacements, deflections, rotations, and
warping of objects under various loading conditions.

Tekla Structures links with a number of analysis applications and also supports
export with them in several formats. The analysis application in which you
run structural analysis uses data from the Tekla Structures analysis models to
generate analysis results.

To analyze Tekla Structures analysis models with an analysis application,
you need to install a direct link between Tekla Structures and the analysis
application.

See also

Link Tekla Structures with an analysis application (page 12)

1.3 Link Tekla Structures with an analysis application
To use an external analysis application with Tekla Structures analysis models,
you need to install a direct link between Tekla Structures and the analysis
application.

1. Sign in to your computer as an administrator.

2. Install Tekla Structures if you do not already have it installed.

3. Install the analysis application if you do not already have it installed.

4. Download the link installer for the analysis application. 

Many direct links are available for downloading in Tekla Warehouse. For
the analysis applications whose direct links are not available in Tekla
Warehouse, the links can be downloaded from the vendor web sites or
by contacting the vendor.

5. Install the link between Tekla Structures and the analysis application.

6. If needed, install the IFC and CIS/2 formats.
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NOTE If you need to uninstall and reinstall Tekla Structures and/or the analysis
application for some reason, you will also need to reinstall the link after
installing Tekla Structures and/or the analysis application.

See also

About analysis applications (page 12)

1.4 Structural analysis workflow in Tekla Structures
Here is one example of the steps you may need to take when you analyze
structures using Tekla Structures and an analysis application. Depending on
your project and the analysis application you use, some of the steps may not
be needed, some may be repeated or carried out in a different order.

Before you start, create the main load-bearing parts that you need to analyze.
There is no need to detail or create connections at this stage. If you have a
detailed model, or more parts in the physical model than you need to analyze,
you can exclude these parts from the analysis.

1. Set the load modeling code (page 16).

2. Create load groups (page 18).

3. Create loads (page 22).

4. Create filters (page 48) for selecting and adding objects to the analysis
model, and for defining secondary analysis parts and braces.

5. If you do not want to create an analysis model of the entire physical
and load models, define which objects to include in the analysis model
(page 47).

We recommend that you first only include columns in the analysis model
to ensure that the columns are aligned.

6. Create a new analysis model (page 49) of the selected parts and loads
using the filters you created.

7. Check the analysis model and analysis parts (page 52) in a Tekla
Structures model view, and make modifications if needed.

8. Add (page 60) the primary beams and other needed objects to the same
analysis model.

9. If needed, modify the analysis model (page 52) or analysis parts
(page 65) or their properties. For example, you can:

• Define the end releases and support conditions (page 68) for analysis
parts, and for connections if you have them.

• Define other analysis properties for individual analysis parts.
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• Define design properties.

• Add (page 61), move, and merge (page 63) analysis nodes.

• Create rigid links (page 62).

• Add (page 60) or remove (page 60) parts and/or loads.

10. If needed, create alternative or sub-analysis models.

11. Create load combinations (page 80).

12. Export the analysis model (page 89) to the analysis application and run
the analysis.

13. If needed, add special loads and other required settings in the analysis
application.

14. If needed, use the analysis application to postprocess the analysis model
or analysis results. For example, you can change part profiles.

After the changes, re-run the analysis.

15. Import the analysis results to Tekla Structures, examine (page 99) them,
and use them in connection design, for example.

16. If the analysis results required changes to the model in the analysis
application, import the changes to Tekla Structures.

See also

Save analysis results (page 98)
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2 Create and group loads

This section introduces the different types of loads available in Tekla
Structures and explains how to create and group them.

Tekla Structures includes the following load types:

Load type Description
Point load (page 25) A concentrated force or bending moment that

can be attached to a part.

Line load (page 25) A linearly-distributed force or torsion. By
default it runs from a point to another point.
You can also create a line load with offsets
from the points. A line load can be attached
to a part. Its magnitude can vary linearly
across the loaded length.
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Load type Description
Area load (page 26) A linearly-distributed force bounded by a

triangle or quadrangle. You do not have to
bind the boundary of the area to parts.

Uniform load (page 26) A uniformly-distributed force bounded by a
polygon. You do not have to bind the polygon
to parts. Uniform loads can have openings.

Wind load (page 28) Area loads defined by pressure factors, along
the height of and on all sides of a building.

Temperature load (page 27) • A uniform change in temperature that is
applied to specified parts and that causes
axial elongation in parts.

• A temperature difference between two
surfaces of a part that causes the part to
bend.

Strain (page 27) An initial axial elongation or shrinkage of a
part.

To ensure that load analysis is correct, use area and uniform loads for loads
on floors. For example, when the layout of beams changes, Tekla Structures
recalculates the loads to the beams. It will not do this if you use point or line
loads on individual beams. Tekla Structures also distributes area and uniform
loads automatically if they act on parts that have openings.

See also

Set the load modeling code (page 16)

Group loads together (page 18)

Create loads (page 22)

Load properties (page 105)
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2.1 Set the load modeling code
Load modeling code settings determine the building code, safety factors, and
load group types that Tekla Structures uses in the load combination process.

NOTE You should not need to change these settings during the project. If
you change the settings, you will also need to change the load group
types and check the load combinations.

To set the load modeling code and to use the standard building code specific
load combination factors:

1. On the File menu, click Settings --> Options , and go to the Load
modeling settings.

2. On the Current code tab, select a code from the Load modeling code
list.

3. Check the load combination factors on the appropriate tab.

4. If you use the Eurocode, enter the reliability class factor and select the
formula to be used on the Eurocode tab.

5. Click OK.

See also

Load modeling code options (page 112)

Load combination factors (page 113)

Use non-standard load combination factors (page 17)

Use non-standard load combination factors
If necessary, you can change the values of building code specific load
combination factors and create your own settings to be used in the load
combination process.

NOTE You should not need to change these settings during the project. If
you change the settings, you will also need to change the load group
types and check the load combinations.

1. On the File menu, click Settings --> Options , and go to the Load
modeling settings.

2. On the Current code tab, select a code from the Load modeling code list
that is the most appropriate to your needs.

3. Change the load combination factors on the appropriate tab.

4. Save the settings using a new name.

a. Enter a name in the box next to the Save as button.
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b. Click Save as. 

Tekla Structures saves the settings in the \attributes folder under
the current model folder with the file name extension .opt.

To later use the saved settings, select the name of the settings file from
the Load list, and then click Load.

5. Click OK.

See also

Load combination factors (page 113)

Set the load modeling code (page 16)

2.2 Group loads together
Each load in a Tekla Structures model has to belong to a load group. A load
group is a set of loads and loadings that are caused by the same action and to
which you want to refer collectively. Loads that belong to the same load group
are treated alike during the load combination process.

Tekla Structures assumes that all loads in a load group:

• Have the same partial safety and other combination factors

• Have the same action direction

• Occur at the same time and all together

You can include as many loads as you like in a load group, of any load type.

You need to create load groups because Tekla Structures creates load
combinations on the basis of load groups. We recommend that you define
the load groups before you create loads. You can define up to 99 load groups
in an analysis model.

See also

Create or modify a load group (page 18)

Set the current load group (page 19)

Load group compatibility (page 20)

Delete a load group (page 21)

Load group properties (page 103)

Work with loads and load groups (page 41)

Combine loads (page 80)
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Create or modify a load group
You can create a load group by adding a new group or by modifying the default
load group. You can modify any existing load group in the same way as the
default load group.

Before you start, ensure that you have the appropriate load modeling code
(page 16) selected in File menu --> Settings --> Options --> Load modeling
--> Current code.

1. On the Analysis & design tab, click Load groups.

2. In the Load Groups dialog, do one of the following: 

• Click Add to create a new load group.

• Select the default load group from the list to modify it.

• Select an existing load group from the list to modify it.

3. Click the load group name to modify it.

4. Click the load group type and select a type from the list.

5. Click the load group direction to modify it.

6. To indicate compatibility with existing load groups:

a. In the Compatible column, enter the number you have used for the
load groups that are compatible with this load group.

b. In the Incompatible column, enter the number you have used for the
load groups that are incompatible with this load group.

7. Click the load group color and select a color from the list. 

Tekla Structures uses this color when it shows the loads of this load group
in the model views.

8. Click OK to close the dialog.

See also

Load group properties (page 103)

Set the current load group (page 19)

Load group compatibility (page 20)

Delete a load group (page 21)

Work with loads and load groups (page 41)
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Set the current load group
You can define one of the load groups as current. Tekla Structures adds all new
loads you create in the current load group.

Before you start, create at least one load group.

1. On the Analysis & design tab, click Load groups.

2. In the Load Groups dialog:

a. Select a load group.

b. Click Set current. 

Tekla Structures marks the current load group with the @ character in
the Current column.

c. Click OK to close the dialog.

See also

Create or modify a load group (page 18)

Load group properties (page 103)

Load group compatibility
When Tekla Structures creates load combinations for structural analysis, it
follows the building code you select in File menu --> Settings --> Options -->
Load modeling --> Current code.

To accurately combine loads which have the same load group type, you need
to use compatibility indicators (numbers) to identify which load groups:

• Can occur at the same time (are compatible)

• Exclude each other (are incompatible)

Compatible load groups can act together or separately. They can actually
be one single loading, for example, a live loading that needs to be split in
parts that act on different spans of a continuous beam. Tekla Structures then
includes none, one, several, or all of the compatible load groups in a load
combination.

Incompatible load groups always exclude each other. They cannot occur at the
same time. For example, a wind loading from the x direction is incompatible
with a wind loading from the y direction. In load combinations Tekla Structures
only takes into account one load group in an incompatible grouping at a time.

Tekla Structures automatically applies basic compatibility facts, such as self-
weight being compatible with all other loads, or live loads being compatible
with wind load.
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Tekla Structures does not combine loads in the x direction with those in the y
direction.

Compatibility indicators are all 0 by default. This indicates that Tekla Structures
combines the load groups as defined in the building code.

See also

Load group properties (page 103)

Create or modify a load group (page 18)

Combine loads (page 80)

Set the load modeling code (page 16)

Delete a load group
You can delete one or several load groups at a time.

WARNING When you delete a load group, Tekla Structures also deletes all
the loads in the load group.

If you try to delete the only load group, Tekla Structures will warn
you. At least one load group must exist.

1. On the Analysis & design tab, click Load groups.

2. In the Load Groups dialog:

a. Select the load group you want to delete. 

To select multiple load groups, hold down the Ctrl or Shift key.

b. Click Delete.

3. If there are loads in any of the deleted load groups, Tekla Structures
displays a warning dialog. 

Do one of the following:

• Click Cancel to not delete the load group and the loads in the load
group.

• Click Delete to delete the load group and the loads in the load group.

See also

Group loads together (page 18)

Create or modify a load group (page 18)

Work with loads and load groups (page 41)

Load group properties (page 103)
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2.3 Create loads
When you create loads, you have two choices: you can set the properties of
a load before you create it, or you can modify the properties after you have
created a load.

NOTE You cannot attach a load to a part after you have created the load.

You can detach a load from a part after you have created the load.

TIP To create loads perpendicular to sloped parts, you can shift the work plane.

Before you start creating loads, define the load groups and set the current
load group.

See also

Define the properties of a load (page 22)

Create a point load (page 25)

Create a line load (page 25)

Create an area load (page 26)

Create a uniform load (page 26)

Create a temperature load or a strain (page 27)

Create wind loads (page 28)

Distribute and modify loads (page 32)

Work with loads and load groups (page 41)

Group loads together (page 18)

Combine loads (page 80)

Define the properties of a load
Before you create a load, it is a good idea to define or check the load
properties.

1. On the Analysis & design tab, click Load properties, and then click a
relevant load type. 

For example, click Area load to define area load properties.

2. In the load properties dialog:

a. Enter or modify the properties. 

• Select a load group.

• Define the load magnitude, and the load form if needed.
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• Attach the load to a part or to a position.

You cannot attach a load to a part after you have created the load.

You can detach a load from a part after you have created the load.

• Define the load-bearing parts.

• If needed, adjust the loaded length or area.

• If needed, modify the load distribution on the Load panel tab.

b. Click OK to save the properties.

Tekla Structures uses these properties when you create new loads of this type.

See also

Load properties (page 105)

Load magnitude (page 23)

Load form (page 24)

Distribute and modify loads (page 32)

Group loads together (page 18)

Load magnitude
Load magnitude can occur in x, y, and z directions. The coordinate system is
the same as the current work plane. Positive coordinates indicate a positive
load direction.

For example, when you create loads perpendicular to sloped parts, shifting the
work plane helps you to place loads accurately.

Some load types can have several magnitude values. For example, the
magnitude of line loads may vary along the loaded length.

In the load properties dialogs, the following letters denote different magnitude
types:
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• P is for a force acting on a position, along a line, or across an area.

• M is for bending moments acting on a position or along a line.

• T is for torsional moments acting along a line.

The units depend on the settings in File menu --> Settings --> Options -->
Units and decimals.

In the load properties dialogs, the numbering of the magnitude values relates
to the order in which you pick points when you create loads.

See also

Load properties (page 105)

Load form
Distributed loads (line and area loads) can have different load forms.

The load form of a line load defines how the load magnitude varies along the
loaded length. The options are:

Option Description
The load magnitude is uniform across the loaded
length.

The load has different magnitudes at the ends of
the loaded length. The magnitude changes linearly
between the ends.
The load magnitude changes linearly, from zero at
the ends of the loaded length, to a fixed value in the
middle of the loaded length.
The load magnitude changes linearly, from zero at
one end of the loaded length, through two (different)
values, back to zero at the other end.

The load form of an area load defines the shape of the loaded area. It can be:

Option Description
Quadrangular

Triangular
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See also

Line load properties (page 106)

Area load properties (page 107)

Create a point load
You can create a concentrated force or a bending moment acting on a
position.

Before you start, shift the work plane if you need to create a load
perpendicular to a sloped part.

1. On the Analysis & design tab, click Load properties --> Point load .

2. In the Point Load Properties dialog:

a. Enter or modify the load properties.

b. On the Distribution tab, select whether you want to attach the load
to a part.

c. Click OK to save the changes.

3. On the Analysis & design tab, click Load --> Point load .

4. If you selected to attach the load to a part, select the part.

5. Pick the position of the load.

See also

Point load properties (page 105)

Define the properties of a load (page 22)

Attach loads to parts or locations (page 32)

Create a line load
You can create a linearly-distributed force or torsion between two points you
pick.

Before you start, shift the work plane if you need to create a load
perpendicular to a sloped part.

1. On the Analysis & design tab, click Load properties --> Line load .

2. In the Line Load Properties dialog:

a. Enter or modify the load properties.

b. On the Distribution tab, select whether you want to attach the load
to a part.

c. Click OK to save the changes.
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3. On the Analysis & design tab, click Load --> Line load .

4. If you selected to attach the load to a part, select the part.

5. Pick the start point of the load.

6. Pick the end point of the load.

See also

Line load properties (page 106)

Define the properties of a load (page 22)

Attach loads to parts or locations (page 32)

Create an area load
Area loads affect triangular or quadrangular areas. If you select the triangular
load form, the points you pick define the loaded area. To create a
quadrangular load form, pick three points, and Tekla Structures automatically
determines the fourth corner point.

Before you start, shift the work plane if you need to create a load
perpendicular to a sloped part.

1. On the Analysis & design tab, click Load properties --> Area load .

2. In the Area Load Properties dialog:

a. Enter or modify the load properties.

b. On the Distribution tab, select whether you want to attach the load
to a part.

c. Click OK to save the changes.

3. On the Analysis & design tab, click Load --> Area load .

4. If you selected to attach the load to a part, select the part.

5. Pick three corner points for the load.

See also

Area load properties (page 107)

Define the properties of a load (page 22)

Attach loads to parts or locations (page 32)
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Create a uniform load
Uniform load is an area load distributed uniformly on a polygonal area. The
bounding polygon is defined by at least three corner points you pick. Uniform
loads can have openings.

Before you start, shift the work plane if you need to create a load
perpendicular to a sloped part.

1. On the Analysis & design tab, click Load properties --> Uniform load .

2. In the Uniform Load Properties dialog:

a. Enter or modify the load properties.

b. On the Distribution tab, select whether you want to attach the load
to a part.

c. Click OK to save the changes.

3. On the Analysis & design tab, click Load --> Uniform load .

4. If you selected to attach the load to a part, select the part.

5. Pick three corner points for the load.

6. If needed, pick more corner points.

7. Pick the first point again.

8. If you want to create an opening:

a. Pick the corner points of the opening.

b. Pick the first point of the opening again.

9. Click the middle mouse button to finish picking.

See also

Uniform load properties (page 107)

Define the properties of a load (page 22)

Attach loads to parts or locations (page 32)

Create a temperature load or a strain
You can model a temperature change in a part, or a temperature difference
between two part surfaces, or a strain.

1. On the Analysis & design tab, click Load properties --> Temperature
load .

2. In the Temperature Load Properties dialog:

a. Enter or modify the load properties.

b. On the Magnitude tab, do one of the following: 
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• Use the Temperature difference section to define a temperature
load.

If you want to apply a temperature load to an entire structure,
enter the load in the Temperature change for axial elongation
box.

• Use the Strain section to define a strain.

c. On the Distribution tab, select whether you want to attach the load
to a part. 

If you want to apply a temperature load to an entire structure, adjust
the bounding box to surround all the beams and columns in the
structure.

d. Click OK to save the changes.

3. On the Analysis & design tab, click Load --> Temperature load .

4. If you selected to attach the load to a part, select the part.

5. Pick the start point of the load.

6. Pick the end point of the load.

See also

Temperature load properties (page 108)

Define the properties of a load (page 22)

Attach loads to parts or locations (page 32)

Create wind loads
You can model the effects of wind on a building.

1. On the Analysis & design tab, click Load properties --> Wind load .

2. In the Wind Load Generator (28) dialog:

a. Enter or modify the load properties (page 109).

b. Click OK to save the changes.

3. On the Analysis & design tab, click Load --> Wind load .

4. Pick points to indicate the shape of the building on the bottom level.

5. Click the middle mouse button to finish.

Tekla Structures does the following automatically:

• Creates area loads to model the effects of wind

• Creates load groups (page 18) for wind loads

• Includes wind loads in load combinations (page 80)

Create and group loads 28 Create loads



• Distributes wind loads if they act on plates, slabs, or panels that have
openings

TIP To select or modify existing wind loads in the model:

• Use the Select components switch  and the Wind Load Generator (28)
dialog (page 109) for all loads created as a group.

• Use the Select objects in components switch  and the Area Load
Properties dialog (page 107) for individual loads in a group.

See also

Wind load examples (page 29)

Wind load examples
Here are examples on how you can use Wind Load Generator (28) to create
wind loads.

Example 1

In this example, there are concentrated wind loads at the corners of a building.

The loads induced by the wind in the global x direction are multiplied by 3 at
both corners of wall 1 (windward wall), and at the other corner of walls 2 and 4
(side walls). The zone widths are defined by using dimensions.
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The walls are numbered according to the picking order of the building shape.
In this example, points were picked clockwise starting from the bottom left
corner of the building.

Example 2

In this example, wind loads vary along the height of the building.
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The z profile is defined in terms of pressure factors.

See also

Create wind loads (page 28)

Wind load properties (page 109)
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3 Distribute and modify loads

This section explains how Tekla Structures distributes loads to parts and how
you can modify loads and load distribution.

Click the links below to find out more:

Attach loads to parts or locations (page 32)

Apply loads to parts (page 33)

Change the loaded length or area of a load (page 35)

Modify the distribution of a load (page 36)

Modify the location or layout of a load (page 37)

Move a load end or corner using handles (page 40)

3.1 Attach loads to parts or locations
You can attach loads to parts or locations for modeling purposes.

Attaching a load to a part binds the load and the part together in the model.
If the part is moved, copied, deleted, etc., it affects the load. For example, you
can attach a prestressing load to a part, so that the load moves with the part,
and disappears if the part is deleted.

If you do not attach a load to a part, Tekla Structures fixes the load to the
positions you pick when you create the load.

NOTE You cannot attach a load to a part after you have created the load.

You can detach a load from a part after you have created the load.

See also

Apply loads to parts (page 33)
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3.2 Apply loads to parts
To apply loads in a structural analysis model, Tekla Structures searches for
parts in the areas that you specify. For each load, you can define the load-
bearing parts by name or selection filter, and the search area (the bounding
box of the load).

Define load-bearing parts by name
You can list the parts that carry a load or the parts that do not carry a load.

1. Double-click the load that you want to distribute to parts. 

The load properties dialog opens.

2. On the Distribution tab:

a. In the Load-bearing parts list, select one of the following: 

• Include parts by name to define the parts that carry the load.

• Exclude parts by name to define the parts that do not carry the
load.

b. Enter the part names. 

You can use wildcards when listing the part names.

3. Click Modify to save the change.

Example

In this example, braces do not carry this uniform load:
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Define load-bearing parts by selection filter
You can define the load-bearing parts by using selection filters.

Before you start, check if there is a selection filter available that suits your
needs. If not, create one.

1. Double-click the load that you want to distribute to parts. 

The load properties dialog opens.

2. On the Distribution tab:

a. In the Load-bearing parts list, select one of the following: 

• Include parts by filter to define the parts that carry the load.

• Exclude parts by filter to define the parts that do not carry the
load.

b. Select the selection filter in the second list.

3. Click Modify to save the changes.

Example

In this example, parts that match the Beam_Steel filter carry this uniform
load:

Bounding box of a load
A bounding box is the volume around a load where Tekla Structures searches
for load-bearing parts.
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In addition to selection filters or part name filters, you can use a load’s
bounding box to search for the parts that carry the load.

Each load has its own bounding box. You can define the dimensions of a
bounding box in the x, y, and z directions of the current work plane. The
dimensions are measured from the reference point, line, or area of the load.

Offset distances (page 35) from the reference line or area do not affect the
size of the bounding box.

3.3 Change the loaded length or area of a load
If a line, area, or uniform load affects a length or an area that is difficult to
select in the model, select a length or an area close to it. Then define offset
distances from the load reference points to set the length or area. You can
shorten, lengthen, or divide the loaded length, and enlarge or reduce the
loaded area. Offset distances only apply to the outer edges of loads, not the
openings in uniform loads.

To define offset distances for a load:

1. Double-click a load to open its properties dialog.

2. On the Distribution tab, enter the distance values in the Distances
boxes: 

• To shorten or divide the length of a line load, enter positive values for
a and/or b.

• To lengthen a line load, enter negative values for a and/or b.

• To enlarge an area load or a uniform load, enter a positive value for a.

• To reduce an area load or a uniform load, enter a negative value for a.

3. Click Modify to save the changes.

See also

Modify the location or layout of a load (page 37)

Move a load end or corner using handles (page 40)
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3.4 Modify the distribution of a load
You can modify the way Tekla Structures distributes loads.

1. Double-click a load to open its properties dialog.

2. Go to the Load panel tab.

3. In the Spanning list, select whether to distribute the load in one or two
directions.

4. If you set Spanning to Single, define the primary axis direction. If you set
Spanning to Double, you need to define the primary axis direction to be
able to manually define the primary axis weight. 

Do one of the following:

• To align the primary axis direction with a part, click Parallel to part or
Perpendicular to part, and then select the part in the model.

• To distribute the load in the global x, y, or z direction, enter 1 in the
corresponding Primary axis direction box.

• To distribute the load between several global directions, enter the
components of the direction vector in the relevant Primary axis
direction boxes.

To check the primary axis direction of a selected load in a model view, click
Show direction on selected loads. Tekla Structures indicates the primary
direction using a red line.

5. In the Automatic primary axis weight list, select whether Tekla
Structures automatically weights the primary direction in load distribution. 

If you select No, enter a value in the Weight box.

6. In the Load dispersion angle box, define the angle by which the load is
projected onto the surrounding parts.

7. In the Use continuous structure load distribution list of a uniform load,
define the distribution of support reactions in the first and last spans of
continuous slabs. 
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• Select Yes for the 3/8 and 5/8 distribution.

• Select No for the 1/2 and 1/2 distribution.

8. Click Modify to save the changes.

Example

When using double spanning, automatic primary axis weight and the weight
value affect the proportions of the load which is applied to the primary axis
and to the perpendicular axis.

• If Automatic primary axis weight is Yes, the proportions will be in
proportion to the third power of the span lengths in these two directions.
This means that the shorter the span, the bigger the proportion of the load.
The Weight value does not matter.

• If Automatic primary axis weight is No, the given Weight value (0.50 in
this example) is used to divide the load.

See also

Load panel settings (page 110)

Distribute and modify loads (page 32)
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3.5 Modify the location or layout of a load
You can modify the location or layout of loads using direct modification.

Before you start:

• Ensure that the  Direct modification switch is active.

• Select the load.

Tekla Structures displays the handles and dimensions that you can use to
modify the load.

When you select a handle and move the mouse pointer over , Tekla
Structures displays a toolbar with more modification options. The available
options depend on the type of the load you are modifying.

To modify the location or layout of a load:

To Do this Available for
Set a load
reference point to
move in one, two,
or any direction

1. Select the handle in the load
reference point.

2. To define in which directions
the handle can move, select
an option from the list on the
toolbar:

You can also press Tab to cycle
through the options.

3. To move the handle in a certain
plane only, click  and select
the plane.

Point loads, line
loads, area loads,
temperature
loads, wind loads

Move a point load
or a load end or
corner

Drag the handle in the load reference
point to a new location.

All loads

Move a line load
or a load edge

Drag a line handle to a new location. Line loads,
area loads,
uniform loads,
temperature
loads, wind loads
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To Do this Available for
Show or hide
direct modification
dimensions

1. Select a handle.

2. On the toolbar, click .

3. Click the eye button to show
or hide orthogonal and total
dimensions:

Line loads,
area loads,
uniform loads,
temperature
loads, wind loads

Change a
dimension

Drag a dimension arrowhead to a
new location, or:

1. Select the dimension arrowhead
which you want to move.

To change the dimension at both
ends, select both arrowheads.

2. Using the keyboard, enter the
value with which you want the
dimension to change.

To start with the negative sign (-),
use the numeric keypad.

To enter an absolute value for
the dimension, first enter $, then
the value.

3. Press Enter, or click OK in
the Enter a Numeric Location
dialog.

Line loads,
area loads,
uniform loads,
temperature
loads, wind loads

Show or hide the
midpoint handles
of a uniform load

1. Select a handle.

2. On the toolbar, click .

Uniform loads

Add corner points
to a uniform load Drag a midpoint handle  to a new

location.

Uniform loads

Remove points
from a uniform
load

1. Select one or more reference
points.

2. Press Delete.

Uniform loads

See also

Move a load end or corner using handles (page 40)
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3.6 Move a load end or corner using handles
Tekla Structures indicates the ends and corners of loads with handles. You can
use these handles to move load ends and corners when you do not want to
use direct modification.

1. Ensure that the Direct modification switch  is not active.

2. Select a load to display its handles. 

When you select a load, the handles are magenta. For line loads, the
handle of the first end is yellow.

3. Click the handle you want to move. 

Tekla Structures highlights the handle.

4. Move the handle like any other object in Tekla Structures. 

If you have the Drag & drop checkbox selected in File menu --> Settings
--> Switches, just drag the handle to a new position.

See also

Modify the location or layout of a load (page 37)
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4 Work with loads and load
groups

This section explains how to work with loads and load groups.

Click the links below to find out more:

Scale loads in model views (page 41)

Check loads and load groups (page 42)

Move loads to another load group (page 44)

Export load groups (page 45)

Import load groups (page 46)

Create and group loads (page 15)

4.1 Scale loads in model views
You can have Tekla Structures scale loads when you are modeling. This
ensures that loads are not too small to see, or so large that they hide the
structure.

1. On the File menu, click Settings --> Options , and go to the Load
modeling settings.

2. On the Arrow length tab, enter the minimum and maximum sizes for
load types.

3. Click OK.

Example

Define that point loads with magnitude of 1 kN or less are 500 mm high in the
model, and that point loads with magnitude of 10 kN or more are 2500 mm
high. Tekla Structures linearly scales all point loads that have magnitudes
between 1 kN and 10 kN between 500 mm and 2500 mm.
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The units depend on the settings in File menu --> Settings --> Options -->
Units and decimals.

See also

Work with loads and load groups (page 41)

4.2 Check loads and load groups
You can use several methods to check loads and load groups.

Inquire load properties
You can check the load group and the magnitude of a load and show them
in a model view. Tekla Structures also shows more information about the load
in the Inquire Object dialog. If you have an analysis model selected in the
Analysis & Design Models dialog, Tekla Structures also highlights the parts
that carry the load in that analysis model.

1. In the Analysis & Design Models dialog, select an analysis model.

2. In a model view, select a load.

3. Right-click and select Inquire.
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Tekla Structures shows the load group and the magnitude in the model view
and highlights the parts that carry the load in the selected analysis model. The
Inquire Object dialog also opens and shows more information about the load.

Find out to which load group a load belongs
You can check to which load groups selected loads belong.

1. On the Analysis & design tab, click Load groups.

2. Select a load in the model. 

To select multiple loads, hold down the Ctrl or Shift key.

3. In the Load Groups dialog, click Load groups by loads. 

Tekla Structures highlights the load group in the dialog.
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Find out which loads belong to a load group
You can check which loads belong to a selected load group.

1. On the Analysis & design tab, click Load groups.

2. In the Load Groups dialog:

a. Select a load group from the list.

b. Click Loads by load groups. 

Tekla Structures highlights the loads of the load group in the model.

Check loads using reports
You can create reports of loads and load groups, and use them to check load
and load group information.

When you select a row that contains an ID number in a load report, Tekla
Structures highlights and selects the corresponding load in the model.

Tekla Structures includes the following standard report templates for loads
and load groups:

• L_Loaded_Part
• L_Loadgroups
• L_Loadgroups_and_loads
• L_Loads
• L_Part_Loads

Example

This example report uses the L_Loadgroups_and_loads template:
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4.3 Move loads to another load group
You can change the load group of a load, or move several loads at the same
time to another load group.

To move loads to another load group, do one of the following:

To Do this
Change the load group of a
load

1. Double-click a load in the model.

2. In the load properties dialog:

a. Select a new load group in the Load group
name list.

b. Click Modify.
Move loads to another load
group

1. Select the loads in the model.

2. On the Analysis & design tab, click Load
groups.

3. In the Load Groups dialog:

a. Select a load group.

b. Click Change load group.

See also

Group loads together (page 18)

Work with loads and load groups (page 41)

4.4 Export load groups
You can export load groups to a file and then use them in another Tekla
Structures model.

Before you start, ensure that you have created the relevant load groups.

1. On the Analysis & design tab, click Load groups.

2. In the Load Groups dialog:

a. Select the load group or groups to export. 

To select multiple load groups, hold down the Ctrl or Shift key.

b. Click Export.

3. In the Export Load Groups dialog:

a. Browse for the folder to which you want to save the load group file.

b. Enter a name for the file in the Selection box.
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c. Click OK.

The file name extension of a load group file is .lgr.

See also

Import load groups (page 46)

Group loads together (page 18)

4.5 Import load groups
You can import load groups from another Tekla Structures model if they have
been exported to a file.

Before you start, ensure that you have the relevant load groups exported to a
file.

1. On the Analysis & design tab, click Load groups.

2. In the Load Groups dialog, click Import.

3. In the Import Load Groups dialog:

a. Browse for the folder where the load group file is.

b. Select the load group file (.lgr) to import.

c. Click OK.

See also

Export load groups (page 45)

Group loads together (page 18)
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5 Create analysis models

This section explains how to create analysis models in Tekla Structures.

Create the analysis models so that they only contain the main structural
parts that you need to analyze and design. Leave out the parts that are not
structurally significant.

Click the links below to find out more:

Objects included in analysis models (page 47)

Filters in analysis models (page 48)

Analysis model content (page 48)

Create an analysis model (page 49)

5.1 Objects included in analysis models
You can define which objects to include in an analysis model. Tekla Structures
includes or ignores some objects automatically.

The following factors affect which objects Tekla Structures includes in analysis
models:

• Analysis model filter (page 48)

• Analysis model content (page 48)

• Which objects you select, add (page 60), remove (page 60), or ignore
manually

Tekla Structures ignores the following objects in the analysis, even if you have
included them in an analysis model:

• Parts and loads that are filtered out

• Component objects, such as minor parts, bolts, and reinforcing bars

• Parts whose analysis class (page 132) is Ignore

• Parts whose analysis part has been deleted (page 79)
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The following components set the analysis properties of the parts they create,
so these parts are included in analysis models:

• Shed (S57)

• Building (S58) and (S91)

• Slab generation (61) and (62)

• Truss (S78)

For example, the vertical and diagonal parts created by Truss (S78) are
handled as braces in the analysis.

See also

Check which objects are included in an analysis model (page 52)

Change the content of an analysis model (page 53)

Filters in analysis models
You can use an analysis model filter to select parts to be included in an
analysis model. You can also use filters to define which of the included parts
are considered to be secondary analysis parts or braces in the analysis model.

The following filters are available in the analysis model properties (page 115):

• Analysis model filter

• Bracing member filter

• Secondary member filter

These filters are based on selection filters, and Tekla Structures saves the
settings with the analysis model properties. This means that you can check the
criteria you used to select objects.

Tekla Structures automatically adds the new objects you create in the physical
model to the analysis model if they fulfill the criteria of the analysis model
filter and analysis model content (page 48).

TIP Use the analysis model filter to filter out non-structural parts, such as end plates,
railings, and ladders, from the analysis model.

See also

Objects included in analysis models (page 47)

Analysis model content
In addition to the analysis model filter, you can define which objects to include
in an analysis model by selecting an option for the Analysis model content
setting.
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The available options are:

Option Description
Selected parts and loads Only includes selected parts and loads, and parts

created by components, when they match the analysis
model filter.

To later add or remove parts and loads, use the
following buttons in the Analysis & Design Models
dialog:

• Add selected objects

• Remove selected objects
Full model Includes all main parts and loads, except for parts

whose analysis class (page 132) is Ignore. Tekla
Structures automatically adds physical objects to the
analysis model when they are created and when they
match the analysis model filter.

Floor model by selected
parts and loads

Only includes selected columns, slabs, floor beams,
and loads when they match the analysis model filter.
Tekla Structures replaces columns in the physical
model with supports.

See also

Filters in analysis models (page 48)

Create an analysis model (page 49)

Add objects to an analysis model (page 60)

Remove objects from an analysis model (page 60)

Change the content of an analysis model (page 53)

5.2 Create an analysis model
There are several methods to create an analysis model in Tekla Structures.

You can create an analysis model that includes all parts and loads you have in
a physical model, or that only includes the selected parts and loads. You can
also create a new analysis model by copying an existing one, or you can create
a modal analysis model.

We recommend that you first only include columns in the analysis model, and
check that the columns are aligned. Then add primary beams and other parts
as needed.
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Create an analysis model for all or selected objects
1. On the Analysis & design tab, click A & D models to open the Analysis &

Design Models dialog.

2. Click New to open the Analysis Model Properties dialog.

3. On the Analysis model tab, select the analysis application you want to
use from the Analysis application list.

4. Enter a unique name for the analysis model. 

For example, you can use a name that describes the portion of the
physical model you want to analyze.

5. To make the analysis model more accurate, select an option for the
following filters (page 48): 

• Analysis model filter

• Bracing member filter

• Secondary member filter

6. Select an option for analysis model content (page 48). Whichever option
you choose, you can easily add (page 60) and remove (page 60) objects
later. 

• Selected parts and loads

• Full model

• Floor model by selected parts and loads

7. If you selected Selected parts and loads or Floor model by selected
parts and loads, select the parts and loads in the physical model. 

To select the objects, you can use Organizer categories, for example.

Note that if you create an analysis model for selected objects and then
use an analysis model filter to leave out more objects, you cannot revert
to the originally selected objects, even if you remove the filtering.

8. If needed, define other analysis model properties (page 115). 

For example, if you need to run a non-linear analysis, change the analysis
method on the Analysis tab.

9. Click OK to create the analysis model.

Create a modal analysis model
You can create modal analysis models of Tekla Structures models. In modal
analysis models, resonant frequency and the associated pattern of structural
deformation called mode shapes are determined, instead of performing stress
analysis.
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1. If you want to create an analysis model for specific parts, select them in
the model.

2. On the Analysis & design tab, click A&D models.

3. In the Analysis & Design Models dialog, click New.

4. In the Analysis Model Properties dialog:

a. Define the basic analysis model properties (page 115).

b. On the Analysis tab, select Yes from the Modal analysis model list.

c. Click OK.

5. When needed, define modal masses (page 55) for the analysis model.

Copy an analysis model
You can create copies of existing analysis models. You can then use the copies,
for example, to create multiple calculations with different settings.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog:

a. Select the analysis model to copy.

b. Click Copy. 

Tekla Structures adds the new analysis model to the list with the
name <original model name> - Copy.

3. Modify the analysis model or analysis parts or their properties as needed.

Delete an analysis model
You can delete unnecessary analysis models.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog:

a. Select an analysis model.

b. Click Delete.

3. Click Yes to confirm.
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6 Modify analysis models

This section explains how to modify analysis models and how to work with
analysis model objects.

Click the links below to find out more:

Check which objects are included in an analysis model (page 52)

Modify the properties of an analysis model (page 53)

Add objects to an analysis model (page 60)

Remove objects from an analysis model (page 60)

Create an analysis node (page 61)

Create a rigid link (page 62)

Merge analysis nodes (page 63)

Create an analysis model (page 49)

6.1 Check which objects are included in an analysis
model
You can check which parts and loads are included in an analysis model.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog:

a. Select an analysis model.

b. Click Select objects. 

Tekla Structures highlights and selects the parts and loads in the
physical model.

To remove the highlighting, click the view background.
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See also

Objects included in analysis models (page 47)

Add objects to an analysis model (page 60)

Remove objects from an analysis model (page 60)

6.2 Modify the properties of an analysis model
1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog:

a. Select the analysis model to modify.

b. Click Properties.

3. In the Analysis Model Properties dialog:

a. Modify the properties.

b. Click OK to save the changes.

See also

Change the content of an analysis model (page 53)

Define the axis settings of an analysis model (page 54)

Define seismic loads for an analysis model (page 54)

Define modal masses for an analysis model (page 55)

Define the design properties of an analysis model (page 56)

Define analysis model rules (page 57)

Analysis model properties (page 115)

Change the content of an analysis model
You can change the content of existing analysis models.

If you change the content of an analysis model to Full model, Tekla Structures
automatically adds all parts and loads in the physical model to the analysis
model if they match the analysis model filter.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog:

a. Select the analysis model to modify.

b. Click Properties.

3. In the Analysis Model Properties dialog:
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a. On the Analysis model tab, select the required option from the
Analysis model content list (page 48).

b. If needed, modify the analysis model filter (page 48) settings.

c. Click OK to save the analysis model properties.

Example

To change the analysis model content from Full model to Selected parts and
loads:

1. Copy an analysis model (page 49) that has been created using the Full
model option.

2. Change the content of the copied analysis model to Selected parts and
loads.

3. Remove the unwanted parts and loads from the analysis model.

See also

Remove objects from an analysis model (page 60)

Add objects to an analysis model (page 60)

Define the axis settings of an analysis model
You can define and modify the analysis axis settings of an entire analysis
model so that the settings apply to all parts in the analysis model.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog, do one of the following: 

• To define the axis settings for a new analysis model, click New.

• To modify the axis settings of an existing analysis model, select the
analysis model, and then click Properties.

3. In the Analysis Model Properties dialog:

a. In the Member axis location list, select an option. 

If you select Model default, Tekla Structures uses the axis properties
of individual analysis parts.

b. Click OK.

See also

Define or modify the axis location of an analysis part (page 76)

Define the location of analysis parts (page 75)
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Define seismic loads for an analysis model
You can define additional lateral seismic loads for analysis models. The seismic
loads are created in the x and y directions according to several building codes
using a static equivalent approach.

Before you start, ensure that you have the appropriate load modeling code
selected in File menu --> Settings --> Options --> Load modeling --> Current
code.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog, do one of the following: 

• To create a new seismic analysis model, click New.

• To modify an existing analysis model, select the analysis model, and
then click Properties.

The Analysis Model Properties dialog opens.

3. On the Seismic tab:

a. In the Type list, select the building code to be used in the seismic
analysis to generate seismic loads.

b. Define the seismic properties.

4. On the Seismic masses tab, define the loads and load groups to be
included in the seismic analysis:

a. To include the self-weight of parts, select the Include self weight as
seismic mass checkbox.

b. If needed, click Copy modal analysis masses to include the same
load groups in the seismic analysis as in the modal analysis.

c. To move the appropriate load groups to the Included load groups
table, select them and use the arrow buttons.

d. For each load group in the Included load groups table, enter a load
factor.

5. Click OK.

See also

Analysis model properties (page 115)

Define modal masses for an analysis model
You can perform a modal analysis instead of a stress analysis. In the modal
analysis, resonant frequencies and the associated patterns of structural
deformation called mode shapes are determined. For the modal analysis, you
can define modal masses to be used instead of static load combinations.

1. On the Analysis & design tab, click A&D models.
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2. In the Analysis & Design Models dialog, do one of the following: 

• To create a new modal analysis model, click New.

• To modify an existing analysis model, select the analysis model, and
then click Properties.

The Analysis Model Properties dialog opens.

3. On the Analysis tab, select Yes from the Modal analysis model list. 

This forces Tekla Structures to ignore static load combinations.

4. On the Modal analysis tab, define the modal analysis properties and the
load groups to be included as masses in the modal analysis:

a. Enter the count of modes to calculate.

b. Enter the maximum frequency to calculate.

c. Select the appropriate Include self weight checkboxes to indicate
the directions for which Tekla Structures includes the self-weight of
parts in the modal analysis.

d. If suitable, click Copy seismic masses to include the same load
groups in the modal analysis as in the seismic analysis.

e. To move the appropriate load groups to the Included load groups
table, select them and use the arrow buttons.

f. For each load group in the Included load groups table, enter a load
factor and set the mass direction. 

In the Mass direction column, select either:

• XYZ to include the load in all three directions.

• Model default to include the load only in the direction of the load.

5. Click OK.

See also

Create an analysis model (page 49)

Analysis model properties (page 115)

Define the design properties of an analysis model
You can define and modify the design properties of an entire analysis model
so that the properties apply to all parts in the analysis model.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog, do one of the following: 

• To define the design properties for a new analysis model, click New.
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• To modify the design properties of an existing analysis model, select
the analysis model, and then click Properties.

3. In the Analysis Model Properties dialog:

a. Go to a Design tab. 

There are separate Design tabs for steel, concrete, and timber.

b. Select the design code and design method for the material.

c. If needed, modify the design properties. 

Click an entry in the Value column, and then enter a value or select
an option.

d. Click OK.

See also

Define design properties for analysis parts (page 71)

Analysis model properties (page 115)

Define analysis model rules
You can create analysis model rules to define how Tekla Structures handles
individual parts when it creates analysis models, and how parts are connected
with each other.

Open the Analysis Model Rules dialog
Use the Analysis Model Rules dialog to work with the rules of an analysis
model.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog:

a. Select an analysis model.

b. Click Properties.

3. In the Analysis Model Properties dialog, go to the Analysis model tab
and click Analysis model rules. 

The Analysis Model Rules dialog opens.

Add an analysis model rule
1. Open the Analysis Model Rules dialog.

2. Click Add to define how two groups of parts are connected with each
other in the analysis.
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3. In the Selection filter 1 column, select a filter to define the first part
group. 

If you need to create a new selection filter that suits your needs, click
Selection filter.

4. In the Selection filter 2 column, select a filter to define the second part
group.

5. If you want to prevent connections between the part groups, select
Disabled in the Status column.

6. In the Linkage column, select one of the following options: 

• (blank): Merges nodes or creates a rigid link.

• Merge: Always merges nodes when parts matching the first selection
filter connect with parts matching the second selection filter.

• Rigid link: Creates a rigid link when parts matching the first selection
filter connect with parts matching the second selection filter.

• Rigid link, moment release at node 1: Creates a rigid link and a
moment release at the nodes of parts matching the first selection
filter.

• Rigid link, moment release at node 2: Creates a rigid link and a
moment release at the nodes of parts matching the second selection
filter.

• Rigid link, moment release at both nodes: Creates a rigid link and
moment releases at the nodes of parts matching the first and the
second selection filter.

7. Click OK to save the rules.

8. In the Analysis Model Properties dialog, click OK to save the rules as
properties of the current analysis model.

Organize analysis model rules
You can change the order of the analysis model rules that you have created for
an analysis model. The last rule in the Analysis Model Rules dialog overrides
the previous ones.

1. Open the Analysis Model Rules dialog.

2. Select a rule.

3. To move the rule up in the list, click Move up. 

To move the rule down in the list, click Move down.

4. Click OK to save the changes.

5. In the Analysis Model Properties dialog, click OK to save the rules as
properties of the current analysis model.
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Delete analysis model rules
You can delete one or more selected analysis model rules from an analysis
model.

1. Open the Analysis Model Rules dialog.

2. Select the rule or rules to delete. 

To select multiple rules, hold down the Ctrl or Shift key.

3. Click Remove.

4. Click OK to save the changes.

5. In the Analysis Model Properties dialog, click OK.

Test analysis model rules
You can test the analysis model rules that you have created on the selected
parts before you bring the rules into use.

1. In the model, select the parts on which you want to test the rules.

2. In the Analysis Model Rules dialog:

a. Click Test selected parts. 

Tekla Structures opens the Analysis model rules test report that
lists the IDs of the selected parts, matching selection filters, and the
results of using the rules.

b. If needed, modify or reorganize the rules and test again.

c. When the rules work as you desired, click OK to save the rules.

3. In the Analysis Model Properties dialog, click OK to save the rules as
properties of the current analysis model.

Save analysis model rules
You can save analysis model rules for later use in the same or another analysis
model.

1. In the Analysis Model Rules dialog:

a. If needed, save the rules for later use: 

Enter a unique name in the box next to the Save as button, and then
click Save as.

Tekla Structures saves the rules file in the \attributes folder under
the current model folder.

The file name extension of an analysis model rules file is .adrules.

b. Click OK.
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2. In the Analysis Model Properties dialog, click OK to save the rules as
properties of the current analysis model.

6.3 Add objects to an analysis model
You can modify existing analysis models by adding parts and loads to them.

1. In the physical model, select the parts and loads to add. 

To select the objects, you can use Organizer categories, for example.

2. On the Analysis & design tab, click A&D models.

3. In the Analysis & Design Models dialog:

a. Select the analysis model to modify.

b. Click Add selected. 

Tekla Structures adds the selected objects to the selected analysis
model.

See also

Check which objects are included in an analysis model (page 52)

Remove objects from an analysis model (page 60)

Copy an analysis part (page 78)

Create an analysis node (page 61)

Create a rigid link (page 62)

6.4 Remove objects from an analysis model
You can modify existing analysis models by removing parts and loads from
them.

1. In the physical model, select the parts and loads to remove.

2. On the Analysis & design tab, click A&D models.

3. In the Analysis & Design Models dialog:

a. Select the analysis model to modify.

b. Click Remove selected. 

Tekla Structures removes the selected objects from the selected
analysis model.

See also

Check which objects are included in an analysis model (page 52)
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Add objects to an analysis model (page 60)

Delete an analysis part (page 79)

6.5 Create an analysis node
You can create nodes on analysis parts. The analysis nodes you manually add
are not moved with the analysis part if you move the analysis part.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog, select the analysis model to
which you want to add the node.

3. On the Analysis & design tab, click Node .

4. Pick the location where you want to add the node.

See also

Analysis model objects (page 9)

Analysis node properties (page 137)

Status of analysis nodes (page 61)

Merge analysis nodes (page 63)

Status of analysis nodes
Analysis nodes can have different status and appearance in analysis models.

The color, size, and appearance of an analysis node indicate the status of the
node, for example, whether the node connects analysis parts and whether the
node has been selected.

Status Color Appearance Selection
Node connects at
least two analysis
parts.

Light aquamarine (Default)

Mouse pointer is
over the node.

Node has been
selected.
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Status Color Appearance Selection
Mouse pointer is
over a related
analysis part.

Node is on an
analysis part but
does not connect
it to other analysis
parts.

Yellow (Default)

Mouse pointer is
over the node.

Node has been
selected.

Mouse pointer is
over a related
analysis part.

Node is not on
any analysis part
and it should be
deleted.

Red (Default)

Mouse pointer is
over the node.

Node has been
selected.

See also

Create an analysis node (page 61)

Analysis node properties (page 137)

Analysis model objects (page 9)

Merge analysis nodes (page 63)
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6.6 Create a rigid link
A rigid link is an analysis object that connects two analysis nodes so that
they do not move in relation to each other. You can manually add rigid links
between analysis nodes.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog, select the analysis model to
which you want to add the rigid link.

3. On the Analysis & design tab, click Rigid link.

4. Pick the start point for the rigid link.

5. Pick the end point for the rigid link.

See also

Analysis model objects (page 9)

Analysis rigid link properties (page 138)

Create an analysis node (page 61)

6.7 Merge analysis nodes
You can merge analysis nodes that are located close to each other into a single
node.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog, select the analysis model in
which you want to merge nodes.

3. Select the nodes you want to merge.

4. On the Analysis & design tab, click Merge nodes.

5. If you are merging nodes on analysis parts that have Keep axis position
set to Yes, Tekla Structures prompts you to change it to No. To accept the
change, click Set keep axis as No.

6. Pick the location to which you want the nodes to be merged. 

Tekla Structures merges the nodes into a single node and extends the
analysis parts accordingly.
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See also

Create an analysis node (page 61)

Analysis node properties (page 137)

Status of analysis nodes (page 61)
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7 Modify analysis parts

This section explains how to modify analysis parts and their properties.

Click the links below to find out more:

About analysis part properties (page 65)

Modify the properties of an analysis part (page 66)

Define end releases and support conditions (page 68)

Define design properties for analysis parts (page 71)

Define the location of analysis parts (page 75)

Copy an analysis part (page 78)

Delete an analysis part (page 79)

7.1 About analysis part properties
You can view, define, or modify analysis part properties before or
after creating analysis models. You can define analysis part properties
independently from analysis models, or modify them according to an analysis
model. Analysis parts can have different properties in different analysis
models.

You can define analysis properties for parts before you create analysis models.
Tekla Structures applies the analysis part properties when the parts are added
to an analysis model. You can also modify analysis part properties after you
have created analysis models.

If you view the analysis properties of a part before you have modified
the properties or created any analysis models, Tekla Structures displays
the analysis properties according to the part type. For example, all steel
beams first have identical analysis properties. These settings are called current
analysis properties.

If you modify the analysis properties of a part before you create analysis
models, Tekla Structures saves the modified settings as the default analysis
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properties of the part in the AnalysisPartDefaults.db6 file under the
current model folder. These default analysis properties override the current
analysis properties and will be used when you add the part to an analysis
model.

When you create analysis models and then view the analysis properties of a
part, Tekla Structures displays the properties according to the selected analysis
model. If you do not have an analysis model selected in the Analysis & Design
Models dialog, Tekla Structures displays the current analysis properties for
unchanged parts and the default analysis properties for modified parts.

See also

Modify the properties of an analysis part (page 66)

7.2 Modify the properties of an analysis part
You can view, define, and modify the properties of analysis parts using the
analysis part properties dialog.

To access the properties of an analysis part, do one of the following:

To Do this
Define or modify
the current analysis
properties of a part
type independently from
analysis models

1. On the Analysis & design tab, click Part analysis
properties, and then click a relevant part type.

2. In the analysis properties dialog:

a. Modify the properties.

b. Click Apply or OK to save the changes as the
current analysis properties of the part type.

Tekla Structures will use these current analysis
properties for new parts of this type that you create
in the model.

Define or modify
the default analysis
properties of a part
independently from
analysis models

1. Ensure that you do not have an analysis model
selected in the Analysis & Design Models dialog.

2. In the physical model, select a part.

3. Right-click and select Analysis Properties.

4. In the part’s analysis properties dialog:

a. Modify the properties.
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To Do this
b. Click Modify to save the changes as the

default analysis properties of the part in the
AnalysisPartDefaults.db6 file.

Tekla Structures will use these default analysis
properties instead of current analysis properties for
this part when you add it to an analysis model.

View the analysis
properties of a part
independently from
analysis models

1. Ensure that you do not have an analysis model
selected in the Analysis & Design Models dialog.

2. In the physical model, select a part.

3. Right-click and select Analysis Properties.

If you have already previously modified the
analysis properties of this part, Tekla Structures
displays these default analysis properties in the
part’s analysis properties dialog (for example,
Beam Analysis Properties).

If you have not modified the analysis properties
of this part, Tekla Structures displays the
current analysis properties in the part’s analysis
properties dialog (for example, Beam Analysis
Properties - Current properties).

4. In the part’s analysis properties dialog:

a. View the properties.

b. Click Cancel to close the dialog.
View or modify the
properties of an analysis
part in an analysis model

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog, select an
analysis model (for example, AnalysisModel3).

3. In the physical model, select a part.

4. Right-click and select Analysis Properties.

5. In the part’s analysis properties dialog
(for example, Beam Analysis Properties -
AnalysisModel3), do one of the following:

• View the properties, and then click Cancel to
close the dialog.

• Modify the properties, and then click Modify
to save the changes.

See also

Analysis part properties (page 122)

About analysis part properties (page 65)
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Modify analysis parts (page 65)

7.3 Define end releases and support conditions
In structural analysis, the stresses and deflections of a part depend on how
it is supported by, or connected to, other parts. You normally use restraints
or springs to model connections. These determine how analysis parts move,
deflect, warp, and deform in relation to each other, or to nodes.

Part ends and nodes have degrees of freedom (DOF) in three directions. The
displacement of a part end can be free or fixed, and the rotation can be
pinned or fixed. If the degree of connectivity is between free, or pinned, and
fixed, use springs with different elastic constants to model them.

Tekla Structures uses analysis part, connection, or detail properties to
determine how to connect parts in the analysis model.

The analysis part properties determine the degrees of freedom for each end
of a part. The first end of a part has a yellow handle, the second end has a
magenta handle.

See also

Define the releases and support conditions of a part end (page 68)

Define the support conditions of a plate (page 69)

Support condition symbols (page 70)

Define the releases and support conditions of a part end
Before you start, in the Analysis & Design Models dialog, select the analysis
model in which you want to define the part end releases and support
conditions.

1. Select a part.

2. Right-click and select Analysis Properties.

3. In the part’s analysis properties dialog: 

• To define the end conditions for the start of the part (yellow handle),
go to the Start releases tab.

• To define the end conditions for the end of the part (magenta handle),
go to the End releases tab.

4. In the Start or End list, select an option. 

The options  and  for a pinned part end are shown as dark
blue circles close to the analysis part end in the analysis model.
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5. If needed for a supported part end, define the rotation.

6. If needed, modify the translational and rotational degrees of freedom.

7. If you selected Spring for any of the degrees of freedom, enter the spring
constant. 

The units depend on the settings in File menu --> Settings --> Options -->
Units and decimals.

8. If you selected Partial release for any of the rotational degrees of
freedom, specify the degree of connectivity. 

Enter a value between 0 (fixed) and 1 (pinned).

9. Click Modify.

See also

Define the support conditions of a plate (page 69)

Support condition symbols (page 70)

Analysis part properties (page 122)

About analysis part properties (page 65)

Define the support conditions of a plate
You can define support conditions for contour plates, concrete slabs, and
concrete panels. Tekla Structures creates supports for the bottom edge of a
panel, for all edge nodes of a slab or a plate, or for all nodes of a beam. For
panels, the bottom edge can be inclined.

Before you start, in the Analysis & Design Models dialog, select the analysis
model in which you want to define the support conditions.

1. Select a plate.

2. Right-click and select Analysis Properties.

3. In the plate’s analysis properties dialog:

a. On the Area attributes tab, select an option in the Supported list: 

• No: No supports are created.

• Simply (translations): Only translations are fixed.

• Fully: Both translations and rotations are fixed.

b. Click Modify.
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See also

Define the releases and support conditions of a part end (page 68)

Support condition symbols (page 70)

Analysis part properties (page 122)

About analysis part properties (page 65)

Support condition symbols
Tekla Structures displays symbols for nodes that indicate the support
conditions of a node.

Symbol Support condition
No supports

Pinned connection

Fixed connection

Translational direction fixed
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Symbol Support condition
Translational direction spring

Rotational fixed

Rotational spring

If you do not want to show the support condition symbols in model views, set
the advanced option XS_AD_SUPPORT_VISUALIZATION to FALSE in File menu
--> Settings --> Advanced Options --> Analysis & Design .

See also

Define end releases and support conditions (page 68)

7.4 Define design properties for analysis parts
You can define design properties for individual analysis parts. Design
properties are properties which can vary according to the design code and
the material of the part (for example, design settings, factors, and limits).
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The properties you see when you first open the Design tab in an analysis part
properties dialog are the properties that apply to the entire analysis model you
have selected in the Analysis & Design Models dialog.

You can modify the design properties of specific analysis parts using the
appropriate analysis part properties dialogs. When you change a value or
select an option in the Value column, the checkbox in the Use default column
is cleared indicating that the analysis model properties are not in use for this
particular analysis part and design property.

Example

If an analysis model contains parts with different material grades, define
the most common material grade using the analysis model properties. Then
change the material grade of specific parts in the analysis part properties.

See also

Omit analysis parts from design (page 72)

Define the buckling lengths of a column (page 73)

Define the design properties of an analysis model (page 56)

Analysis part properties (page 122)
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Omit analysis parts from design
You can omit individual analysis parts from the design check during the
analysis.

Before you start, in the Analysis & Design Models dialog, select the analysis
model in which you want to modify the analysis part properties.

1. In the physical model, select a part.

2. Right-click and select Analysis Properties.

3. In the part’s analysis properties dialog:

a. Go to the Design tab.

b. In the Value column, select No for Check design - Enable design
check of member.

c. Click Modify.

See also

Define design properties for analysis parts (page 71)

About analysis part properties (page 65)

Define the buckling lengths of a column
You can define buckling lengths for columns and column segments. Column
segments represent the building levels. Tekla Structures automatically divides
columns into segments at the point where a support in the buckling direction
exists, or where the column profile changes.

Effective buckling length is K*L, where K is the length factor and L is the
buckling length.

A column can have different buckling lengths in different analysis models.

Before you start, in the Analysis & Design Models dialog, select the analysis
model in which you want to define the buckling lengths.

1. Select a column.

2. Right-click and select Analysis Properties.

3. In the column’s analysis properties dialog:

a. Go to the Design tab and the Value column.

b. Select an option for Kmode.

c. Enter one or more values for K - Length factor for buckling in the y
and/or z direction. 
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The number of values you can enter depends on the option you
selected for Kmode.

To enter multiple values, enter a value for each column segment
starting from the lowest segment, and use spaces to separate the
values. You can also use multiplication to repeat factors, for example,
3*2.00.

d. Enter one or more values for L - Buckling length in the y and/or z
direction. 

• To automatically calculate length values, leave the fields blank.

• To override one or more length values, enter values in the relevant
buckling length fields. The number of values you need to enter
depends on the option you selected for Kmode. You can use
multiplication to repeat buckling lengths, for example, 3*4000.

e. Click Modify.

See also

Kmode options (page 74)

About analysis part properties (page 65)

Kmode options
Use the Kmode options to define how Tekla Structures calculates the buckling
lengths of columns.

The options are:

Option Description
Physical member L is the length of the column.
Column segment L is the length of one column segment.
Column segment,
multiple values

L is the length of one column segment with user-
defined factors and lengths for each column segment.

Analytical member L is the length of the member in the analysis model.
Analytical member,
multiple values

L is the length of the member in the analysis
model with user-defined factors and lengths for each
member.
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See also

Define the buckling lengths of a column (page 73)

7.5 Define the location of analysis parts
You can define and modify the analysis axis location of individual parts in an
analysis model, or you can use the axis settings of the analysis model that
apply to all parts in the analysis model.

You can also define offsets for analysis parts and use handles to move analysis
parts.

If you move an analysis part handle, you can view the offsets in the following
dialogs:

• Analysis Bar Position Properties

• Analysis Area Position Properties
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• Analysis Area Edge Properties

If you move a physical part or an analysis part, these handle offsets will be
reset. The Reset editing of selected parts command also resets the changes
you have made using the analysis part handles.

See also

Define or modify the axis location of an analysis part (page 76)

Define offsets for an analysis part (page 77)

Reset the editing of analysis parts (page 78)

Analysis bar position properties (page 140)

Analysis area position properties (page 140)

Analysis area edge properties (page 141)

Analysis part properties (page 122)

Define the axis settings of an analysis model (page 54)

Define or modify the axis location of an analysis part
You can define and modify the analysis axis location of individual parts.
The analysis axis defines the location of an analysis part in relation to the
corresponding physical part. For example, the analysis part can be located on
the neutral axis or the reference line of the physical part.

Before you start:

• In the Analysis & Design Models dialog, select the analysis model in which
you want to modify the analysis part properties.

• For the selected analysis model, ensure that Member axis location is set
to Model default in the Analysis Model Properties dialog.

1. In the physical model, select a part.

2. Right-click and select Analysis Properties.

3. In the part’s analysis properties dialog:

a. Go to the Position tab.

b. In the Axis list, select an option.

c. In the Keep axis position list, define whether the part’s analysis axis
can move, and in which direction when the part is connected with
other parts.

d. If needed, use the Axis modifier boxes to define whether the axis is
bound to global coordinates, to the nearest grid line, or neither.

e. Click Modify.
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Alternatively, you can modify the analysis axis location of parts by using
keyboard shortcuts that move analysis parts in relation to the corresponding
physical parts. First select analysis parts in the active analysis model, and then
use the following keyboard shortcuts:

• To move the analysis parts up, press Alt+arrow up.

• To move the analysis parts down, press Alt+arrow down.

• To move the analysis parts to the left, press Alt+arrow left.

• To move the analysis parts to the right, press Alt+arrow right.

See also

Define offsets for an analysis part (page 77)

Analysis part properties (page 122)

About analysis part properties (page 65)

Define the axis settings of an analysis model (page 54)

Define offsets for an analysis part
You can define offsets for an analysis part. Offsets move the analysis part in
relation to the default location of the analysis axis.

Before you start, in the Analysis & Design Models dialog, select the analysis
model in which you want to define offsets.

1. In the physical model, select a part.

2. Right-click and select Analysis Properties.

3. In the part’s analysis properties dialog:

a. Go to the Position tab.

b. In the Offset boxes, define the offset of the analysis part from the
physical part’s analysis axis in the global x, y, and z directions. 

These values change if you move the analysis part in the model.

These values do not reset if you move the physical part.

c. In the Longitudinal offset mode list, select whether the longitudinal
end offsets Dx of the physical part are taken into account. 

End offsets determine where Tekla Structures creates the end nodes
of the analysis part.

d. Click Modify.

See also

Define or modify the axis location of an analysis part (page 76)

Analysis part properties (page 122)
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Reset the editing of analysis parts
If you have changed the location of analysis parts using handles, you can reset
the selected analysis parts to the default analysis settings.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog, select the analysis model in
which you want to reset parts.

3. Select the parts to reset.

4. On the Analysis & design tab, click Reset editing of selected parts.

See also

Define the location of analysis parts (page 75)

Modify analysis parts (page 65)

7.6 Copy an analysis part
You can create copies of existing analysis parts together with the applied
properties and node offsets.

For example, you can use copying to apply analysis settings to multiple
repeated frames. First apply the correct analysis settings to one frame. Then
copy the settings to other similar frames.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog, select the analysis model that
includes the part you want to copy and uses the analysis part properties
you want to use.

3. In the physical model, select the part to copy.

4. Do one of the following: 

• On the Edit tab, click Copy.

• Right-click and select Copy.

5. Pick the origin for the copying.

6. Pick one or more destination points. 

If there is an identical physical part at a destination point, Tekla Structures
creates an analysis part with settings identical to the original.

If there already was an analysis part at a destination point, Tekla
Structures modifies the analysis part.

If a physical part at the destination point is not yet included in the analysis
model, Tekla Structures adds the part to the analysis model.
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7. To stop copying, do one of the following: 

• Press Esc.

• Right-click and select Interrupt.

See also

Modify analysis parts (page 65)

7.7 Delete an analysis part
You can remove parts from analysis models by deleting analysis parts.

If the analysis model content is Full model and you delete an analysis part,
Tekla Structures ignores the part in the analysis. If the analysis model content
is Selected parts and loads or Floor model by selected parts and loads,
and you delete an analysis part, Tekla Structures removes the part from the
analysis model.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog, select the analysis model that
includes the part you want to delete.

3. Select the analysis part to delete.

4. Do one of the following: 

• Right-click and select Delete.

• Press Delete.

TIP To undo the Delete command:

• For Full model analysis models, change the analysis class of the deleted part
from Ignore to the original setting.

• For other analysis models, add the deleted part again to the analysis model.

See also

Remove objects from an analysis model (page 60)

Modify analysis models (page 52)

Analysis model content (page 48)
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8 Combine loads

This section explains the load combination process in Tekla Structures.

Load combination is a process in which some simultaneously acting load
groups are multiplied by their partial safety factors and combined with each
other according to specific rules.

Load combination rules are specific to a design process and are defined in
building or design codes. One of the most typical design processes is the limit
state design.

Load combination properties define how Tekla Structures combines loads. The
following properties control the load combination process:

• Load modeling code (page 112)

• Load combination factors (page 113)

• Load combination types (page 113)

• Load group compatibility (page 20)

See also

About load combinations (page 80)

Create load combinations automatically (page 81)

Create a load combination (page 82)

Modify a load combination (page 83)

Copy load combinations between analysis models (page 83)

Delete load combinations (page 85)

8.1 About load combinations
A load combination is a set of load groups that is created in the load
combination process. Each load combination represents a real loading
situation, which means that permanent load should always be included in
each load combination.
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Each load combination must have a unique name. Use names that describe
the loading situation.

Each load combination has an ID. This is an incremental number, based on the
order in which load combinations are created in the analysis model.

You can have Tekla Structures automatically create load combinations, or you
can create and modify them manually.

See also

Create load combinations automatically (page 81)

Create a load combination (page 82)

Modify a load combination (page 83)

Copy load combinations between analysis models (page 83)

Delete load combinations (page 85)

8.2 Create load combinations automatically
You can have Tekla Structures automatically generate load combinations for
an analysis model according to a building code.

Before you start, ensure that you have the appropriate load modeling code
selected in File menu --> Settings --> Options --> Load modeling --> Current
code.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog:

a. Select an analysis model.

b. Click Load combinations.

3. In the Load Combinations dialog, click Generate.

4. In the Load Combination Generation dialog:

a. If needed, check the load combination factors. 

Click Options, and then do one of the following:

• View the factors. Then click Cancel to close the dialog.

• Modify the factors. Then click OK to save the changes.

b. Select the checkboxes against the combinations you want to create.

c. To automatically include the self-weight of parts in load combinations,
select the Include self weight checkbox.

d. (This step only applies to the Eurocode.) If needed, select the
Minimum permanent load with lateral loads only checkbox. This
reduces the amount of load combinations when only minimum
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permanent loading needs to be considered in lateral loading
situations.

e. Click OK to create the load combinations. 

If the analysis model has imperfection loads, Tekla Structures
automatically creates load combinations with both the positive and
negative directions (x and -x, or y and -y).

5. In the Load Combinations dialog, click OK to save the load combinations.

See also

Set the load modeling code (page 16)

Load combination factors (page 113)

Load combination types (page 113)

Create a load combination (page 82)

Modify a load combination (page 83)

Delete load combinations (page 85)

8.3 Create a load combination
If needed, you can create load combinations for an analysis model one by one.

Before you start, ensure that you have the appropriate load modeling code
selected in File menu --> Settings --> Options --> Load modeling --> Current
code.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog:

a. Select an analysis model.

b. Click Load combinations.

3. In the Load Combinations dialog, click New.

4. In the Load Combination dialog:

a. Select a load combination type from the Type list.

b. Enter a unique name for the load combination.

c. Use the arrow buttons to move load groups between the Load
groups list and the Load combination table.

d. If needed, modify the signs (+ or -) and combination factors in the
Load combination table by clicking a value.

e. Click Apply to create the load combination.

f. If needed, repeat steps a–e to create more load combinations.
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g. Click OK to create the last load combination and close the dialog.

5. In the Load Combinations dialog, click OK to save the load combinations.

See also

Set the load modeling code (page 16)

Load combination types (page 113)

Load combination factors (page 113)

Create load combinations automatically (page 81)

Modify a load combination (page 83)

Delete load combinations (page 85)

8.4 Modify a load combination
You can modify the load combinations of an analysis model by changing the
load combination name and factors.

You cannot change the load combination type or ID, or add or remove load
groups after you have created the load combination.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog:

a. Select an analysis model.

b. Click Load combinations.

3. In the Load Combinations dialog:

a. To change the name of a load combination, select it and enter a new
name.

b. To change a load combination factor, select it and enter a new value.

c. Click OK to save the changes.

See also

Create load combinations automatically (page 81)

Create a load combination (page 82)

Copy load combinations between analysis models (page 83)

Delete load combinations (page 85)
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8.5 Copy load combinations between analysis models
You can copy load combinations between analysis models within a physical
model. You can also copy between physical models if they have the same
environment and load groups.

First you need to save the load combinations that you want to copy to a .lco
file. If you want to make the load combinations available in another physical
model, you need to copy the .lco file to the \attributes folder of the
destination model, or to the project or firm folder. Then you can load the load
combinations to another analysis model.

Save load combinations for later use
You can save the load combinations of an analysis model for later use in other
analysis models.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog:

a. Select an analysis model.

b. Click Load combinations.

3. In the Load Combinations dialog:

a. Enter a name for the saved load combinations in the box next to Save
as.

b. Click Save as. 

Tekla Structures saves the load combinations as a .lco file in the
\attributes folder under the current model folder.

4. Click OK to close the dialogs.

Copy load combinations from another analysis model
You can copy load combinations from another analysis model that has the
same load groups and environment.

1. Ensure that the load combinations you want to copy have been saved in
a .lco file.

2. Check that the .lco file is located in the \attributes folder under the
current model folder, or in the project or firm folder. If not, copy the .lco
file.

3. If you are copying load combinations between two physical models, open
the model to copy to. If you are copying within a physical model, reopen
the model.

4. On the Analysis & design tab, click A&D models.
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5. In the Analysis & Design Models dialog:

a. Select the analysis model to copy to.

b. Click Load combinations.

6. In the Load Combinations dialog:

a. Select a load combinations file (.lco) from the list next to Load.

b. Click Load.

7. Click OK to close the dialogs.

8.6 Delete load combinations
In Tekla Structures, you can delete load combinations one by one, or several
selected or all load combinations of an analysis model at once.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog:

a. Select the analysis model whose load combinations you want to
delete.

b. Click Load combinations.

3. In the Load Combinations dialog, do one of the following: 

• Select the load combination to delete, and then click Remove.

• Hold down the Ctrl or Shift key and select the load combinations to
delete. Then click Remove.

• To delete all load combinations, click Remove all.

4. Click OK to close the dialogs.

See also

Modify a load combination (page 83)

Create load combinations automatically (page 81)

Create a load combination (page 82)
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9 Work with analysis and design
models

This section explains how to export, import, merge, and view analysis and
design models and how to save and view analysis results.

Click the links below to find out more:

Check warnings about an analysis model (page 86)

Export a model from Tekla Structures to an analysis application (page 89)

Import changes from Tekla Structural Designer to an analysis model (page 92)

Merge analysis models using analysis applications (page 96)

Save analysis results (page 98)

View the analysis results of a part (page 99)

Show analysis class in model views (page 100)

Show analysis bar, member, and node numbers (page 100)

Show the utilization ratio of parts (page 101)

9.1 Check warnings about an analysis model
If there were problems in creating an analysis model, Tekla Structures shows
a warning sign in the Analysis & Design Models dialog when you select the
analysis model.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog:

a. Select an analysis model.

b. If a warning sign appears, click Display warnings. 
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Tekla Structures displays a warning dialog that lists the problem types
that occurred in the analysis model creation. For example:

The numbers in the parentheses indicate how many instances of the
same problem type there are in the analysis model.

3. In the warning dialog, click Details to find out more. 
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Tekla Structures displays a detailed list of warnings and errors. For
example:

• If you select a row with an object ID, Tekla Structures highlights and
selects the corresponding object in the model, such as an analysis part,
bar, or node, a load, or a physical part.

Individual analysis members cannot be selected.

• If you right-click a row with an object ID, you can access the object’s
menu and use commands such as Inquire and Zoom selected.

• If you select a row with position coordinates, diamond-shaped position
locators are displayed in the model to point you to the error.

For example, when a rigid link would be required to connect analysis
parts but the rigid links are disabled in the settings, the locators
indicate where the rigid link ends should be:

See also

Create analysis models (page 47)
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Work with analysis and design models (page 86)

9.2 Export a model from Tekla Structures to an analysis
application
To run structural analysis on a Tekla Structures model, you need to export an
analysis model or the physical model to an analysis application. For example,
you can use Tekla Structural Designer as the analysis application.

Export an analysis model to Tekla Structural Designer
You can export Tekla Structures analysis model data to Tekla Structural
Designer along with the physical model. The exported .cxl file can be
imported to Tekla Structural Designer to update an existing model, or to create
a new Tekla Structural Designer model on the basis of the Tekla Structures
analysis model.

If you have compatible versions of Tekla Structures and Tekla Structural
Designer installed on your computer, also the corresponding Tekla Structural
Designer model (.tsmd file) can be created or updated during the export, and
it then automatically opens in Tekla Structural Designer.

Limitations:

• Walls that consist of several segments are not exported. Only walls with a
single analysis area are exported.

• Walls with chamfered corners are exported without chamfers.

• Openings in concrete walls are only exported when the walls and openings
are rectangular.

• The physical position of the exported polybeams in Tekla Structural
Designer may not match the physical position in Tekla Structures. However,
the analysis position is correct.

Before you start:

• Open the Tekla Structures model from which you want to export.

• If you want to manually define which member type will be used for a Tekla
Structures part in Tekla Structural Designer, use the TSD Member Type,
TSD Slab Type, or TSD Wall Type user-defined attribute of the physical
part. These attributes are available on the Tekla Structural Designer tab
in the part's user-defined attributes dialog in Tekla Structures.

For example, you can set TSD Slab Type to STEEL_DECK_1WAY, or TSD
Wall Type to MID_PIER.

For more information about the member types, see Specifying object types
in Structural BIM software in the Tekla Structural Designer documentation.

Work with analysis and design models 89 Export a model from Tekla Structures to an
analysis application

https://support.tekla.com/article/specifying-object-types-in-structural-bim-software
https://support.tekla.com/article/specifying-object-types-in-structural-bim-software


• Create an analysis model (page 49) that includes the parts you want to
analyze. Set Tekla Structural Designer as the analysis application in the
analysis model properties.

• Ensure that the analysis parts of the columns are aligned in the analysis
model.

1. On the Analysis & design tab, click A&D models. 

Alternatively, you can go to the File menu and click Export --> Tekla
Structural Designer with analysis model.

2. In the Analysis & Design Models dialog:

a. Select the analysis model to export. 

Ensure that Analysis application is set to Tekla Structural Designer
for this analysis model.

b. Click Export.

3. In the Export to Tekla Structural Designer dialog:

a. Click the ... button next to Export file to set the folder location and
name for the export file. 

We recommend that you use a file name that indicates the analysis
model name, the phase of the analysis and design workflow, and
the file transfer direction. For example, AnalysisModel1 - A -
Initial export from TS to TSD or AnalysisModel1 - C -
Further changes from TS to TSD.

If you have a compatible version of Tekla Structural Designer
installed, the .tsmd file type is automatically selected.

b. In the Grids list, specify which of the Tekla Structures grids you want
to export: All, Selected, or None. 

With Selected, select the grids in the model.

c. To check the proposed profile and material grade conversions, open
the Conversions section and click the preview buttons. 

The export uses an internal conversion list containing the standard
profiles and material grades. If the profile or material grade of any
part cannot be converted using the internal conversion, the export
name will be replaced with the following text in the Conversions
tables:

--- NO MATCH ---
d. If the text --- NO MATCH --- is displayed, or if you want override

the standard conversion, you can convert the profiles and materials
in the following way: 

• Create a profile and/or material grade conversion file in a text
editor using the file name extension .cnv.
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• In the text file, enter the Tekla Structural Designer profile or
material grade name, for profiles the # symbol and the profile
code, then the equal sign (=), and the corresponding Tekla
Structures name.

You may need help from your local Tekla support with this.

• In the Profile conversion file and Material conversion file
boxes, specify the conversion files that you want to use for
mapping profiles and material grades.

If the conversion files are not used, the parts with profiles or material
grades that cannot be converted will still be created but they will use
the export file profile or material grade that may be invalid.

e. Click Export.

A .cxl file is created in the folder you specified using the file name you
specified. Also with the .tsmd export file type, a .cxl is created first and
a timestamp is added after the file name.

4. If you have a compatible version of Tekla Structural Designer installed
and .tsmd selected as the export file type, Tekla Structural Designer starts
and the BIM Integration : Structural BIM Import wizard appears. Do the
following:

a. Review and modify the settings in the wizard as needed, and then
click Next in each step. 

For example, you can set the building code, and select whether
this is a first-time transfer from Tekla Structures to Tekla Structural
Designer, or an update to an existing model.

For more information about the options, see 'Import a project from
a Structural BIM Import file' in the Tekla Structural Designer product
guides.

b. When you are happy with the settings, click Finish in the final step of
the wizard. 

A Tekla Structural Designer model file (.tsmd) is created in the folder
you specified using the file name you specified.

Next you can start working with the model in Tekla Structural
Designer.

To import a .cxl file to Tekla Structural Designer on another computer, for
example, see 'Import a project from a Structural BIM Import file' in the Tekla
Structural Designer product guides.
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Export a physical model to Tekla Structural Designer
If you do not want to create a Tekla Structures analysis model and use it in
export to Tekla Structural Designer, you can export a Tekla Structures physical
model instead, and use it for analysis in Tekla Structural Designer.

NOTE We recommend that you export to Tekla Structural Designer using the
analysis model. It ensures better analytical connectivity and produces
a more accurate model in Tekla Structural Designer than the physical
model.

For more information about the physical model export, see Export to Tekla
Structural Designer and Example workflow of integration between Tekla
Structures and Tekla Structural Designer.

Export an analysis model to an analysis application
To run structural analysis on a Tekla Structures analysis model using an
analysis application, you need to export the analysis model into a folder. By
default, the export folder is the current model folder. If you have a direct
link to an analysis application, and you export an analysis model from Tekla
Structures using that particular analysis application, the analysis model is
opened in the application.

1. On the Analysis & design tab, click A&D models.

2. If needed, define the export folder.

a. In the Analysis & Design Models dialog, select the analysis model to
export, and then click Properties....

b. In the Analysis Model Properties dialog, click Browse for export
folder on the Analysis model tab.

c. In the Browse For Folder dialog, browse to the export folder, and
then click OK.

d. Click OK to save the export folder settings with the analysis model
properties.

3. In the Analysis & Design Models dialog:

a. Select the analysis model to export.

b. Click Export.
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9.3 Import changes from Tekla Structural Designer to an
analysis model
When you use Tekla Structural Designer as the analysis application, and you
have analyzed, designed, and modified a model in Tekla Structural Designer,
you can import the changes to Tekla Structures.

You can import the new parts created in Tekla Structural Designer, profile and
material changes, design intent reinforcement, and other analysis results.

The location of the existing parts does not change in the Tekla Structures
model even if you have moved the corresponding parts in Tekla Structural
Designer.

If you want to import reinforcement, you need to have compatible versions of
Tekla Structures and Tekla Structural Designer installed on your computer and
access to the original Tekla Structural Designer file (.tsmd).

1. Open the Tekla Structures model to which you want to import.

2. On the Analysis & design tab, click A&D models.

3. In the Analysis & Design Models dialog:

a. Select the analysis model to which you want to import.

b. Click Get results.

4. In the Tekla Structural Designer Import dialog:

a. Click the ... button next to Import file to browse for and select the file
exported from Tekla Structural Designer. 

To import reinforcement, select the original Tekla Structural Designer
model file (.tsmd). Rebar sets can be created for pad footings, strip
footings, beams, columns, and walls. Meshes are not transferred.

b. Select among the following grid options: 

• Import grids from import file: The grid lines from the import
file will be imported into the Tekla Structures model. A grid line
pattern will be created, and all the imported grid lines will be
attached as individual grid planes to this pattern.

• Delete existing Tekla Structures grids: Import will remove all
grid lines/planes from the current Tekla Structures model.

c. If you want to remove slab and wall openings in the Tekla Structures
model that were previously imported from Tekla Structural Designer,
select the Remove previously imported openings checkbox.

d. Open the Location section and define to which location you want to
import the model. Do one of the following: 

• In the X, Y, and Z boxes, enter offsets for the imported model
from the global origin of the Tekla Structures model.
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• Click Pick and then pick a location for the import model datum
point in the Tekla Structures model.

You can also define a rotation.

e. In the Rebars section, define whether the reinforcing bars are
imported, and how they are imported. 

Note that the Rebars section and its options will become available
only when you have selected a .tsmd file as the import file.

f. To check the proposed profile, material grade, and rebar grade
conversions, open the Conversions section and click the preview
buttons. 

The import uses an internal conversion list containing the standard
profiles and grades. If the profile or grade of any part cannot be
converted using the internal conversion, the Tekla Structures name
will be replaced with the following text in the Conversions tables:

--- NO MATCH ---
g. If the text --- NO MATCH --- is displayed, or if you want to override

the standard conversion, you can convert the profiles, materials, and
rebar grades in the following way: 

• Create a profile, material, and/or rebar grade conversion file in a
text editor using the file name extension .cnv.

• In the text file, enter the Tekla Structural Designer profile, material,
or rebar grade name, for profiles the # symbol and the profile
code, then the equal sign (=), and the corresponding Tekla
Structures name.

You may need help from your local Tekla support with this.

In the rebar grade conversion file, list the size mappings for the
grade on the rows underneath the grade name in the same way,
indented by a tab.
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• In the Profile conversion file, Material conversion file, and/or
Rebar conversion file boxes, specify the conversion files that you
want to use for mapping profiles and grades.

The Rebar conversion file box is only available if you have
a compatible version of Tekla Structural Designer installed and
a .tsmd import file selected.

If the conversion files are not used, the parts with profiles or material
grades that cannot be converted will still be created but they will use
the import file profile or material grade that may be invalid.

h. Select the Show model comparison tool checkbox at the bottom of
the dialog.

i. Click Import. 

Model Comparison Tool shows all parts that are flagged as Added,
Updated, Deleted, or Unchanged.

5. In Model Comparison Tool, accept or reject changes as follows: 

a. Go to an appropriate tab: Added, Updated, Deleted, or Unchanged.

b. To display the properties of an object, select the object from the list
on the left.

If the selected object has been updated or deleted, or has not been
changed, the object is also highlighted in the model.

c. To append the Tekla Structures object ID to the object name in the
comparison tool list, select the Display part IDs checkbox.

d. To reduce the amount of information displayed about the objects
that have been updated, select the Only display changed fields
checkbox.

Only the values that have been changed are displayed instead of all
the object properties.

e. On the Added, Updated, and Deleted tabs, ensure that the checkbox
after the object name is selected for each object (or object type) that
you want to import or update.

f. On the Updated tab, for each object to update, select the object from
the list on the left, and then in the list of properties, select the Apply
updates checkbox for each object property whose value you want to
update.

g. If you want to exclude the objects that did not previously exist in the
Tekla Structures model but that are in the import file, clear the Add
new objects checkbox.
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h. If you want to delete objects that currently exist in the Tekla
Structures model but that are not in the import file, select the Delete
current objects checkbox.

If you clear this checkbox, no objects will be deleted.

i. Click Accept changes to use the current settings and complete the
import.

The result of the import is shown in Process log in the Tekla Structural
Designer Import dialog, for example, the number of parts that have been
imported, and any warnings or errors related to the import.

6. Close the Tekla Structural Designer Import dialog.

9.4 Merge analysis models using analysis applications
You can merge Tekla Structures analysis models with models in some external
analysis applications. This means that you can make changes to Tekla
Structures physical and analysis models even after you have exported them
to an analysis application, and still keep the additions you have made to the
exported models in the analysis application.

For example, you can create a Tekla Structures model, create an analysis
model of it, export the analysis model to an analysis application, add special
loads to the model in the analysis application, and then run the analysis. If
you then need to make changes to the physical or analysis model in Tekla
Structures, you can merge models in the analysis application. If you do not
merge models and you re-export the changed Tekla Structures analysis model
to the analysis application, you will lose the additions you have made to the
model in the analysis application.

For more information, see Analysis and design systems.

Merge analysis models using SAP2000
You can merge Tekla Structures analysis models with models in SAP2000.

By default, Tekla Structures and SAP2000 analysis models are not merged. This
means that a new SAP2000 model is created always when you export a Tekla
Structures analysis model to SAP2000.

If you choose to merge a Tekla Structures analysis model with a model in
SAP2000, the changes in the Tekla Structures physical or analysis model are
merged to the model in SAP2000. Additional objects and definitions, such as
parts, bars, loads, and load combinations, created in SAP2000 are retained in
SAP2000. Additional objects created in SAP2000 cannot be imported to Tekla
Structures, but they are taken into account in the analysis. They affect the
analysis results, which you can import to Tekla Structures.
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When exported to SAP2000, the objects created in Tekla Structures will receive
a prefix "_" to their names. The prefix distinguishes the objects created in Tekla
Structures from the objects created in SAP2000.

Additional loads created in SAP2000 will be added to the load combinations
that are created in SAP2000. If you add additional loads to the load
combinations that are created in Tekla Structures, the loads will be removed
from these load combinations when you merge models and export a Tekla
Structures analysis model to SAP2000.

Merging Tekla Structures and SAP2000 analysis models helps in retaining the
existing analysis node and bar numbers in SAP2000.

• Existing node numbers are kept if the node coordinates stay the same.

• Existing bar numbers are kept if the start and end node numbers stay the
same.

• Old node and bar numbers are not re-used.

Limitations

Changes in the following properties in Tekla Structures are not updated in
SAP2000 even if you merge models:

• The profile and material properties of parts if a profile or material name
already exists in SAP2000

• Load combinations if the name of the load combination already exists in
SAP2000

To keep the changes made in SAP2000 when you re-export a changed Tekla
Structures analysis model, you can adjust the profile and material properties
and the load combination type in SAP2000.

If you change the support condition settings in SAP2000 and then re-export a
Tekla Structures analysis model, you will lose these changes.

How to merge a Tekla Structures analysis model with a
model in SAP2000
1. On the Analysis & design tab, click A&D models.

2. In the Analysis Model Properties dialog, do one of the following: 

• To merge an existing analysis model, select the analysis model, and
then click Properties to check and modify its properties.

• To create a new analysis model and merge it, click New.

3. In the Analysis Model Properties dialog:

a. In the Analysis application list, select SAP2000.

b. In the Model merging with analysis application list, select Enabled.
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c. If you are merging a new analysis model, modify the other analysis
model properties if needed.

d. Click OK to save the analysis model properties.

Tekla Structures merges the models the next time you export the Tekla
Structures analysis model to SAP2000 to run the analysis.

Reset merged analysis models
You can reset model merging between Tekla Structures and external analysis
applications.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog:

a. Select the analysis model to reset.

b. Click Properties.

3. In the Analysis Model Properties dialog:

a. In the Model merging with analysis application list, select
Disabled.

b. Click OK to save the analysis model properties.

9.5 Save analysis results
When you save the analysis results and then save the physical model,
Tekla Structures saves the results of all load combinations in a database,
analysis_results.db5, in the current model folder.

If you do not want to create the analysis results database
analysis_results.db5, set XS_AD_RESULT_DATABASE_ENABLED to FALSE
in File menu --> Settings --> Advanced Options --> Analysis & Design .

Use the following advanced options in File menu --> Settings --> Advanced
Options --> Analysis & Design to define the analysis member points whose
results are saved in the database:

• XS_AD_MEMBER_RESULT_DIVISION_COUNT

• XS_AD_MEMBER_RESULT_DISP_DIVISION_COUNT

• XS_AD_MEMBER_RESULT_MIN_DISTANCE

• XS_AD_MEMBER_RESULT_GRID_SIZE

See also

Save analysis results as user-defined attributes of parts (page 99)
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Save analysis results as user-defined attributes of parts
After running the analysis, you can save the maximum axial force, shear force,
and bending moment at the part ends as user-defined attributes in the part
properties. You can save the results for each part in an analysis model or for
specific parts.

Before you start, run the analysis.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog:

a. Select an analysis model.

b. Do one of the following: 

• To save the results for each part in the analysis model, click Get
results.

• To save the results for specific parts, select the parts in the
physical model, and then click Get results for selected.

See also

View the analysis results of a part (page 99)

Show the utilization ratio of parts (page 101)

9.6 View the analysis results of a part
You can view a part’s analysis results using the user-defined attributes.

Before you start, ensure that you have saved the analysis results using the Get
results or Get results for selected command on the correct analysis model.

1. Double-click a part in the physical model.

2. In the part's property pane, click User-defined attributes.

3. In the user-defined attributes dialog: 

• Go to the End conditions tab to view the analysis results at the part
ends.

• Go to the Analysis tab to view the utilization ratio of a steel part or the
required area of reinforcement in a concrete part.

To access the analysis results database, use the .NET interface or Tekla
Structures’s excel design interface.

See also

Save analysis results as user-defined attributes of parts (page 99)
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Save analysis results (page 98)

9.7 Show analysis class in model views
The analysis class defines how Tekla Structures handles individual parts in the
analysis. You can show the analysis class of parts in an object group using
different colors in the physical model.

Before you start, create an object group that includes the parts whose analysis
class you want to show.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog, select an analysis model.

3. On the View tab, click Representation.

4. In the Object Representation dialog:

a. Select an object group.

b. In the Color column, select Color by analysis type from the list.

c. Click Modify.

See also

Analysis class options and colors (page 132)

9.8 Show analysis bar, member, and node numbers
You can show the analysis bar, member, and analysis node numbers of the
active analysis model in model views.

1. On the Analysis & design tab, click A&D models.

2. In the Analysis & Design Models dialog, select an analysis model.

3. On the Analysis & design tab on the ribbon:

• Click Member numbers to switch the analysis member or bar
numbers on or off.

• Click Node numbers to switch the analysis node numbers on or off.

Alternatively, you can use the following advanced options in File menu --
> Settings --> Advanced Options --> Analysis & Design to define which
numbers are shown:

• XS_AD_MEMBER_NUMBER_VISUALIZATION

• XS_AD_NODE_NUMBER_VISUALIZATION
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• XS_AD_NODE_NUMBER_BY_Z

Some analysis applications work on analysis members whereas others work
on analysis bars. This also affects how analysis models are shown in Tekla
Structures model views. Either member numbers or bar numbers are shown.

See also

Analysis model objects (page 9)

Status of analysis nodes (page 61)

9.9 Show the utilization ratio of parts
Once you have exported an analysis model to an analysis application and run
the analysis, you can view the analysis results. To perform a visual check, you
can use different colors to show the utilization ratio of the steel parts in an
object group in the physical model.

Before you start, ensure that you have saved the analysis results using the Get
results or Get results for selected command on the correct analysis model.

1. Create an object group that includes the parts whose utilization ratio you
want to show.

2. On the View tab, click Representation.

3. In the Object Representation dialog:

a. Select the object group whose utilization ratios you want to show.

b. In the Color column, select Color by analysis utility check from the
list.

4. In the Utility Ratio Ranges dialog:

a. Set the ranges of ratio for each of the colors that Tekla Structures
uses to show safe and unsafe parts.

b. Click OK.

5. In the Object Representation dialog, click Modify.

Tekla Structures shows the utilization ratio of the steel parts in the selected
analysis model using the following colors:
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See also

Save analysis results as user-defined attributes of parts (page 99)

View the analysis results of a part (page 99)
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10 Analysis and design settings

This section provides information about the various analysis and design
settings you can modify in Tekla Structures.

Click the links below to find out more:

Load group properties (page 103)

Load properties (page 105)

Load combination properties (page 112)

Analysis model properties (page 115)

Analysis part properties (page 122)

Analysis node properties (page 137)

Analysis rigid link properties (page 138)

Analysis bar position properties (page 140)

Analysis area position properties (page 140)

Analysis area edge properties (page 141)

10.1 Load group properties
Use the Load Groups dialog to view, define, and modify the load group
properties and to work with load groups.

Option Description
Current The @ character identifies the current load group.

When you create loads in the model, Tekla Structures
adds them to the current load group. You can only
define one load group as current.

To change the current load group, select a load group
and click Set current.
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Option Description
Name Unique name of the load group.

Use load group names to define the visibility and
selectability of loads. For example, you can select,
modify, or hide loads based on their load group.

Type The type of a load group is the type of action that
causes the loads.

Actions causing loads are building code specific and
depend on the load modeling code (page 16) selected
in File menu --> Settings --> Options --> Load
modeling --> Current code.

Most building codes use some or all of the following
actions and load group types:

• Permanent, dead, and/or prestressing loads

• Live, imposed, traffic, and/or crane loads

• Snow loads

• Wind loads

• Temperature loads

• Accidental and/or earthquake loads

• Imperfection loads
Direction The direction of a load group is the global direction of

the action that causes the loads. Individual loads in a
load group retain their own magnitudes in the global
or local x, y, and z directions.

The load group direction affects which loads Tekla
Structures combines in a load combination:

• z direction groups are combined with both x and y
direction groups.

• x or y direction groups are not combined with each
other.

Compatible A number that identifies all the load groups that are
compatible with each other.

Incompatible A number that identifies all the load groups that are
incompatible with each other.

Color The color that Tekla Structures uses to show the loads
in the group.

See also

Group loads together (page 18)

Analysis and design settings 104 Load group properties



Work with loads and load groups (page 41)

10.2 Load properties
This section provides information about the properties of specific loads.

Use the load properties dialogs to view, define, and modify the load
properties. Each load type has its own properties dialog.

Click the links below to find out more:

Point load properties (page 105)

Line load properties (page 106)

Area load properties (page 107)

Uniform load properties (page 107)

Temperature load properties (page 108)

Wind load properties (page 109)

Load panel settings (page 110)

Point load properties
Use the Point Load Properties dialog to view and modify the properties of
a point load or a bending moment. The file name extension of a point load
properties file is .lm1.

Option Description
Load group name The load group to which the load belongs.

To view load group properties or to create a new load
group, click Load groups.

Magnitude tab Load magnitudes in the x, y, and z directions of the
work plane.

Load attachment Indicates if the load is attached to a part.
Load-bearing parts Parts to which the load is applied, or not applied, on

the basis of part names or selection filters.
Bounding box of the
load

Dimensions of the bounding box in the x, y, and z
directions.

Load panel tab See Load panel settings (page 110).

See also

Create a point load (page 25)
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Define the properties of a load (page 22)

Load magnitude (page 23)

Attach loads to parts or locations (page 32)

Apply loads to parts (page 33)

Modify the distribution of a load (page 36)

Line load properties
Use the Line Load Properties dialog to view and modify the properties of
a line load or a torsional moment. The file name extension of a line load
properties file is .lm2.

Option Description
Load group name The load group to which the load belongs.

To view load group properties or to create a new load
group, click Load groups.

Magnitude tab Load magnitudes in the x, y, and z directions of the
work plane.

Load form Defines how the load magnitude varies along the
loaded length.

Load attachment Indicates if the load is attached to a part.
Load-bearing parts Parts to which the load is applied, or not applied, on

the basis of part names or selection filters.
Bounding box of the
load

Dimensions of the bounding box in the x, y, and z
directions.

Distances Offsets from the load end points, used to shorten or
lengthen the loaded length.

To shorten the loaded length, enter positive values for
a and b. To lengthen the loaded length, enter negative
values.

Load panel tab See Load panel settings (page 110).

See also

Create a line load (page 25)

Define the properties of a load (page 22)

Load magnitude (page 23)

Load form (page 24)

Distribute and modify loads (page 32)
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Area load properties
Use the Area Load Properties dialog to view and modify the properties of an
area load. The file name extension of an area load properties file is .lm3.

Option Description
Load group name The load group to which the load belongs.

To view load group properties or to create a new load
group, click Load groups.

Magnitude tab Load magnitudes in the x, y, and z directions of the
work plane.

Load form Defines the shape of the loaded area.
Load attachment Indicates if the load is attached to a part.
Load-bearing parts Parts to which the load is applied, or not applied, on

the basis of part names or selection filters.
Bounding box of the
load

Dimensions of the bounding box in the x, y, and z
directions.

Distances Offset used to enlarge or reduce the loaded area.

To enlarge the loaded area, enter a positive value for
a. To reduce the loaded area, enter a negative value.

Load panel tab See Load panel settings (page 110).

See also

Create an area load (page 26)

Define the properties of a load (page 22)

Load magnitude (page 23)

Load form (page 24)

Distribute and modify loads (page 32)

Uniform load properties
Use the Uniform Load Properties dialog to view and modify the properties
of a uniform load. The file name extension of a uniform load properties file
is .lm4.

Option Description
Load group name The load group to which the load belongs.

To view load group properties or to create a new load
group, click Load groups.
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Option Description
Magnitude tab Load magnitudes in the x, y, and z directions of the

work plane.
Load attachment Indicates if the load is attached to a part.
Load-bearing parts Parts to which the load is applied, or not applied, on

the basis of part names or selection filters.
Bounding box of the
load

Dimensions of the bounding box in the x, y, and z
directions.

Distances Offset used to enlarge or reduce the loaded area.
Load panel tab See Load panel settings (page 110).

See also

Create a uniform load (page 26)

Define the properties of a load (page 22)

Load magnitude (page 23)

Distribute and modify loads (page 32)

Temperature load properties
Use the Temperature Load Properties dialog to view and modify the
properties of a temperature load or a strain. The file name extension of a
temperature load properties file is .lm6.

Option Description
Load group name The load group to which the load belongs.

To view load group properties or to create a new load
group, click Load groups.

Temperature change for
axial elongation

Temperature change in the part.

Temperature
differential from side to
side

Difference in temperature between the left side and
the right side of a part.

Temperature
differential from top to
bottom

Difference in temperature between the top surface
and the bottom surface of a part.

Initial axial elongation Axial strain of a part.

A positive value indicates elongation, a negative value
indicates shrinkage.

Load attachment Indicates if the load is attached to a part.
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Option Description
Load-bearing parts Parts to which the load is applied, or not applied, on

the basis of part names or selection filters.
Bounding box of the
load

Dimensions of the bounding box in the x, y, and z
directions.

See also

Create a temperature load or a strain (page 27)

Define the properties of a load (page 22)

Apply loads to parts (page 33)

Wind load properties
Use the Wind Load Generator (28) dialog to view and modify the properties
of wind loads.

To select or modify existing wind loads in the model as a group, use the Select

components switch .

Option Description
Wind load direction The main direction of the wind.

The options are:

• Global X

• Global -X

• Global Y

• Global -Y

• Global X, -X, Y, -Y (for all directions)
Nominal wind pressure The nominal value of wind pressure.
Top level The highest level of the wind loads.
Bottom level The lowest level of the wind loads.
Ground level The level of the ground around the building.
Part names Parts to which the load is applied, or not applied.

See also Define load-bearing parts by name (page 33).
Front The external exposure factors for the windward,

leeward, and side walls.

A positive value indicates pressure, a negative value
indicates suction.

Left side
Back
Right side
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Option Description
Internal The internal exposure factor.
Z profile tab The distribution of wind load along the height of the

building, in terms of pressure factors. Starts from the
ground level.

Global X, Global Y,
Global -X, Global -Y tabs

A tab for each wind direction, where you can define
zones for concentrated corner loads on each wall.

Each zone is the height of the wall. Define the width of
the zone using either dimensions or proportions. You
can define up to five zones for each wall.

Walls are numbered according to the order you pick
points to indicate the shape of the building on the
bottom level.

To select or modify individual existing wind loads in the model as separate

area loads, use the Select objects in components switch  and the Area
Load Properties dialog (page 107).

See also

Create wind loads (page 28)

Wind load examples (page 29)

Load panel settings
Use the options on the Load panel tab in a load properties dialog to modify
the way Tekla Structures distributes the load.

Option Description
Spanning Defines the directions in which Tekla Structures

distributes the load.

• Single distributes the load only in the direction of
the primary axis.

• Double distributes the load along the primary and
secondary axes.

Primary axis direction Defines the direction of the primary axis using one of
the following methods:

• A value (1) in the x, y, or z box distributes the load
in the corresponding global direction.

• Values in multiple boxes distribute the load
between the corresponding global directions. The
values are the components of the direction vector.
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Option Description
• Clicking Parallel to part, or Perpendicular to

part, and then selecting a part in the model aligns
the primary axis direction with the part.

If Spanning is Double, you need to define the primary
axis direction to be able to manually define the
primary axis weight.

To check the primary axis direction of a selected load
in a model view, click Show direction on selected
loads. Tekla Structures indicates the primary direction
using a red line.

Automatic primary axis
weight

Defines whether Tekla Structures automatically
weights the directions in load distribution.

The options are:

• Yes: Tekla Structures automatically calculates the
load portions for the primary and secondary
directions in proportion to the third power of
the span lengths in these two directions. This
means that the shorter the span, the bigger the
proportion of the load.

• No: You can enter the weight for the primary
direction in the Weight box. Tekla Structures
calculates the weight for the secondary direction
by subtracting this value from 1.

Load dispersion angle The angle by which the load is projected onto the
surrounding parts.

Use continuous
structure load
distribution

Use for uniform loads on continuous slabs. Defines
the distribution of support reactions in the first and
last spans.

The options are:
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Option Description
• Yes: The distribution of support reactions is 3/8

and 5/8.

• No: The distribution of support reactions is 1/2 and
1/2.

See also

Modify the distribution of a load (page 36)

10.3 Load combination properties
This section provides information about the settings that control the load
combination process.

Click the links below to find out more:

• Load modeling code options (page 112)

• Load combination factors (page 113)

• Load combination types (page 113)

Load modeling code options
These are the load modeling codes available in Tekla Structures in File menu
--> Settings --> Options --> Load modeling --> Current code:

Option Description
Eurocode European code
British British code
AISC (US) American Institute of Steel Construction, US code
UBC (US) Uniform building code, US code
CM66 (F) French code for steel structures
BAEL91 (F) French code for concrete structures
IBC (US) International building code, US code
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Option Description
ACI American Concrete Institute’s publication 318

Each of the available codes has a separate tab in the Options dialog.
The Options dialog lists the partial safety factors in limit states and other
combination factors for the code, based on load group types. For the
Eurocode, you can also set the reliability class factor and the formula to be
used in load combination.

See also

Set the load modeling code (page 16)

Load combination factors (page 113)

Load combination factors
In the load combination process, Tekla Structures uses partial safety
factors and, for example, reduction factors on load groups to create load
combinations.

The partial safety factors needed in the limit state design are:

• Unfavorable partial safety factor in the ultimate limit state (γsup)

• Favorable partial safety factor in the ultimate limit state (γinf)

• Unfavorable partial safety factor in the serviceability limit state (γsup)

• Favorable partial safety factor in the serviceability limit state (γinf)

Depending on the codes you use, you may need to use other combination
factors. For example, the Eurocode contains three reduction factors (ψ0, ψ1, ψ2).
Reduction factors exclude the impractical effects of simultaneous loads.

You can use values for load combination factors that are building code specific
or user-defined.

See also

Set the load modeling code (page 16)

Use non-standard load combination factors (page 17)
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Load combination types
You can perform several load combination types which vary according to the
building code you use.

Use the Load Combination Generation dialog, or the Load Combination
dialog, to select the load combination types you want to create. The options
are:

Combination type Description Applies to
Ultimate limit state
(ULS)

Combines load groups that occur
persistently and transiently. Uses the
partial safety factors of the ultimate
limit state when combining loads.

Eurocode,
British, AISC
(US)

Serviceability limit state
(SLS)

Combines load groups that occur
quasi-permanently. Uses the partial
safety factors of the serviceability
limit state when combining loads.

Eurocode, AISC
(US)

Serviceability limit state
– Rare (SLS RC)

Combines load groups that occur
quasi-permanently and rarely. Uses
the partial safety factors of the
serviceability limit state when
combining loads.

Eurocode

Serviceability limit state
– Quasi-permanent (SLS
QP)

Combines load groups that occur
quasi-permanently. Uses the partial
safety factors of the serviceability
limit state when combining loads.

Eurocode

Normal loads Combines load groups and uses
factors according to the French codes
CM66 or BAEL91.

CM66, BAEL91
Extreme loads CM66
Displacement loads CM66
Accidental loads CM66,

Eurocode
Ultimate loads BAEL91
Ultimate accidental
loads

BAEL91

Earthquake loads Combines load groups and uses
factors according to the Eurocode.

Eurocode

Loads for public
structures

Combines load groups according
to the US IBC code (International
Building Code).

IBC (US)

Loads for public
structures with drifted
snow

IBC (US)

Loads for non public
structures

IBC (US)
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Combination type Description Applies to
Loads for non public
structures with drifted
snow

IBC (US)

Loads for public non
concrete and masonry
structures

Combines load groups according to
the US UBC code (Uniform Building
Code).

UBC (US)

Loads for public non
concrete and masonry
structures with drifted
snow

UBC (US)

Loads for non concrete
and masonry structures

UBC (US)

Loads for non concrete
and masonry structures
with drifted snow

UBC (US)

Loads for public
concrete and masonry
structures

UBC (US)

Loads for public
concrete and masonry
structures with drifted
snow

UBC (US)

Loads for concrete and
masonry structures

UBC (US)

Loads for concrete and
masonry structures with
drifted snow

UBC (US)

ACI Table 1 - ACI Table 8 Combines load groups according to
the ACI code (American Concrete
Institute’s publication 318).

ACI

See also

Combine loads (page 80)

10.4 Analysis model properties
Use the Analysis Model Properties dialog to define, view, and modify the
properties of an analysis model. These properties apply to all parts in an
analysis model.
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Analysis model tab

Option Description
Analysis application The analysis application (page 12) or format used in

the analysis of the analysis model.

To use the same application or format by default
for other new analysis models, select the Set as the
default checkbox.

See also Link Tekla Structures with an analysis
application (page 12).

Analysis model name A unique name for the analysis model. User-definable.

For example, you can use a name that describes
the portion of the physical model that you want to
analyze.

To define the export folder for the analysis model, click
Browse for export folder.

Analysis model filter Defines which objects to include in the analysis model,
based on the list of available selection filters.

See also Filters in analysis models (page 48).
Bracing member filter Defines which of the included objects are considered

to be braces. The analysis nodes of braces can move
more freely than the ones of primary analysis parts
when the analysis model is created.

Secondary member
filter

Defines which of the included objects are considered
to be secondary analysis parts. The nodes of
secondary analysis parts can move more freely than
the ones of primary analysis parts when the analysis
model is created.

Analysis model content Defines which objects are included in the analysis
model.

The options are:

• Selected parts and loads

Only includes selected parts and loads, and parts
created by components, when they match the
analysis model filter.

To later add or remove parts and loads, use
the Add selected objects or Remove selected
objects button in the Analysis & Design Models
dialog.

• Full model

Includes all main parts and loads, except for parts
whose analysis class (page 132) is Ignore. Tekla

Analysis and design settings 116 Analysis model properties



Option Description
Structures automatically adds physical objects to
the analysis model when they are created and
when they match the analysis model filter.

• Floor model by selected parts and loads

Only includes selected columns, slabs, floor beams,
and loads when they match the analysis model
filter. Tekla Structures replaces columns in the
physical model with supports.

See also Analysis model content (page 48).
Use rigid links Use to allow or prevent rigid links in the analysis

model.

The options are:

• Enabled

Rigid links are created if they are needed to
connect analysis parts.

• Disabled, with keep axis: Default

No rigid links are created. The Keep axis position
settings of the analysis parts are not changed.

• Disabled, with keep axis: No

No rigid links are created. The Keep axis position
settings of the connected analysis parts are
changed to No.

If you use Tekla Structural Designer as the analysis
application, you can use the Enabled option for
concrete parts. The Disabled, with keep axis:
Default option is automatically used for steel parts.

Analysis model rules Click to create rules to define how Tekla Structures
handles individual parts in the analysis model, and
how parts are connected with each other in the
analysis.

Curved beams Defines whether beams are analyzed as curved beam
or as straight segments. Select either:

• Split into straight segments

• Use curved member

Use the advanced option XS_AD_CURVED_BEAM_
SPLIT_ACCURACY_MM in File menu --> Settings -->
Advanced Options --> Analysis & Design to define
how closely straight segments follow the curved beam.
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Option Description
Consider twin profiles Defines whether twin profiles are considered as one

part (Enabled) or as two parts (Disabled) in the
analysis.

Member axis location Defines the location of each analysis part in relation to
the corresponding physical part.

The options are:

• Neutral axis

The neutral axis is the analysis axis for all parts.
The location of the analysis axis changes if the
profile of the part changes.

• Reference axis (eccentricity by neutral axis)

The part reference line is the analysis axis for all
parts. The location of the neutral axis defines axis
eccentricity.

• Reference axis

The part reference line is the analysis axis for all
parts.

• Model default

The analysis axis of each part is defined
individually according to the analysis part
properties.

To define the axis location of specific parts, use
the Position tab in the appropriate analysis part
properties dialog.

If you select Neutral axis, Tekla Structures takes the
part location and end offsets into account when it
creates nodes. If you select either of the Reference
axis options, Tekla Structures creates nodes at part
reference points.

Member end release
method by connection

Defines whether the support conditions of parts (No)
or connections (Yes) are used.

Automatic update Defines if the analysis model is updated according to
the changes in the physical model.

The options are:

• Yes - Physical model changes are considered

• No - Physical model changes are ignored
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Option Description
Model merging with
analysis application

Only use with SAP2000 when changes occur in the
Tekla Structures physical or analysis model that has
already been exported to the analysis application.

Defines whether the changed analysis model is
merged with the previously exported model in the
analysis application.

The options are:

• Disabled

Models are not merged. Additions made in the
analysis application to the previously exported
model are lost. A new model is created every
time you export the analysis model to the analysis
application.

• Enabled

Models are merged. Additions made in the analysis
application to the previously exported model are
retained when you re-export the analysis model to
the analysis application. The model in the analysis
application is updated with the changes from Tekla
Structures.

Analysis tab

Option Description
Analysis method Defines whether second order stresses are taken into

consideration.

The options are:

• 1st order

Linear analysis method.

• P-Delta

A simplified second order analysis method. This
method gives accurate results when deflections are
small.

• Non-linear

Non-linear analysis method.
Maximum number of
iterations

Tekla Structures repeats second order iteration until it
reaches one of these values.

Accuracy of the
iteration
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Option Description
Modal analysis model Select Yes to create a modal analysis model and to

use modal analysis properties instead of static load
combinations.

Job tab

Defines the job information in STAAD.Pro reports.

Output tab

Defines the contents of the STAAD.Pro analysis results file.

Seismic tab

Use the Seismic tab to define which building code to follow in the seismic
analysis and the properties required by the seismic analysis. These properties
vary depending on the code you select.

Option Description
Type The building code to use to generate seismic loads.

The options are:

• None: Seismic analysis not run.

• UBC 1997: Uniform Building Code 1997

• UBC 1994: Uniform Building Code 1994

• IBC 2000: International Building Code 2000

• IS 1893-2002: Indian Standard. Criteria for
Earthquake Resistant Design of Structures

• IBC 2003: International Building Code 2003

• IBC 2006: International Building Code 2006

• IBC 2006 (ZIP): International Building Code 2006,
with an option to add a ZIP code in the properties

• IBC 2006 (Longitude/Latitude): International
Building Code 2006, with an option to add
longitude and latitude information in the
properties

• AIJ: Japanese code

• Response spectrum: Response spectrum
specification

Seismic properties Depending on the code you select, you can define
various seismic properties.

Seismic masses tab

The loads and load groups included in the seismic analysis.
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Modal analysis tab

Use the Modal analysis tab to define the properties required by the modal
analysis.

Option Description
Count of modes The number of natural mode shapes in the structure.
Max frequency The maximum natural resonant frequency of the

structure.
Modal analysis masses The loads and load groups included in the modal

analysis.

Design tabs

Use the Design tabs for steel, concrete, and timber to define the codes
and methods to use in structural design. The design options available vary
depending on the material.

Option Description
Design code Design codes for different materials.

The design code options available vary depending on
the analysis application you use.

Design method The material-specific principle used to compare
stresses and material capacities.

The options are:

• None

Tekla Structures only runs a structural analysis
and creates data on stresses, forces, and
displacements.

Available for steel, concrete, and timber.

• Check design

Tekla Structures checks whether the structures
fulfill the criteria in the design code (whether cross
sections are adequate).

Available for steel and timber.

• Calculate required area

Tekla Structures defines the required area of
reinforcement.

Available for concrete.
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Option Description
Design properties The design code and method specific design

properties of the analysis model that apply to all parts
in the analysis model.

When you select a design code and method for a
material, Tekla Structures lists the design properties
in the lower part of the Design tab.

To change the value of a particular property, click on
an entry in the Value column.

The units depend on the settings in File menu -->
Settings --> Options --> Units and decimals.

To change the design properties of a specific part,
use the Design tab in the appropriate analysis part
properties dialog.

See also

Create analysis models (page 47)

Modify the properties of an analysis model (page 53)

10.5 Analysis part properties
Use the options in a part’s analysis properties dialog (for example, Beam
Analysis Properties) to define how Tekla Structures handles the part in the
analysis. The settings you have available in the dialog vary depending on the
part type and analysis class. The table below lists all settings regardless of the
part type and the analysis class.

Analysis tab

Use the Analysis tab to define the analysis properties of a part.

Option Description
Class Defines how the part is handled in the analysis.

The selected Class defines which analysis properties
are available. For example, plates have different
properties from columns.

Filter

(Rigid diaphragm
properties)

Only available when the Class is Contour plate - Rigid
diaphragm or Slab - Rigid diaphragm.

Defines the filter used when filtering objects for a rigid
diaphragm.

Nodes that belong to a part matching the filter will be
connected to the rigid diaphragm. For example, you
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Option Description
can use a column filter to connect only column nodes
to rigid diaphragms.

Built-up section mode Indicates the role of the part in a built-up section that
consists of a main part and one or more sub-parts. In
the analysis, sub-parts are merged to the main part.

The options are:

• Automatic

• Not part of built-up section

Disconnects the part from a built-up section.

• Main part of built-up section

Always use to define the main part of a built-up
section.

• Sub-part of built-up section

• Beam sub-part of built-up section

Defines that the part is a part of the built-up
section when the main part of the built-up section
is a beam.

• Column sub-part of built-up section

Defines that the part is a part of the built-up
section when the main part of the built-up section
is a column.

Design group Defines to which design group the part belongs. Used
in optimization.

Automatic update Defines if the analysis part is updated according to the
changes in the physical model.

The options are:

• Yes - Physical model changes are considered

• No - Physical model changes are ignored

Start releases tab, End releases tab

Use the Start releases and End releases tabs to define the support
conditions and the degrees of freedom for the part ends.

The Start releases tab relates to the first part end (yellow handle), the End
releases tab to the second part end (magenta handle).
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Option Description
Start or End Defines which of the predefined or user-defined

combinations for end conditions is used for part start
or end.

These are the predefined options:

 (Not available with Tekla Structural Designer)

 (Not available with Tekla Structural Designer)

They automatically set the support condition and
degrees of freedom.

You can modify a predefined combination to suit your
needs. If you do that, Tekla Structures indicates it with
this option:

Support condition Not available with Tekla Structural Designer.

Defines the support condition.

The options are:

• Connected

Part end is connected to an intermediate analysis
node (another part).

Indicate degrees of freedom for the node.

• Supported
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Option Description
Part end is the ultimate support for a
superstructure (for example, the foot of a column
in a frame).

Indicate degrees of freedom for the support.
Rotation Only available if Support condition is Supported.

Defines whether the support is rotated.

The options are:

• Not rotated

• Rotated

If you select Rotated, you can define the rotation
around the local x or y axis, or you can set the rotation
by the current work plane by clicking Set rotation by
current work plane.

Ux

Uy

Uz

Define the translational degrees of freedom
(displacements) in the global x, y, and z directions.

The options are:

• Free

• Fixed

• Spring

If you select Spring, enter the translational spring
constant. The units depend on the settings in
File menu --> Settings --> Options --> Units and
decimals.

Rx

Ry

Rz

Define the rotational degrees of freedom (rotations) in
the global x, y, and z directions.

The options are:

• Pinned

• Fixed

• Spring

• Partial release

If you select Spring, enter the rotational spring
constant. The units depend on the settings in
File menu --> Settings --> Options --> Units and
decimals.

Use Partial release to specify if the degree of
connectivity is between fixed and pinned. Enter a
value between 0 (fixed) and 1 (pinned).
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Composite tab

Use the Composite tab with STAAD.Pro to define the analysis properties of the
slab in a composite beam.

Option Description
Composite beam Defines whether the composition is a:

• Non-composite beam

• Composite beam

• Automatic composite beam
Material Defines the material of the slab.
Thickness Defines the thickness of the slab.
Effective slab width Defines if the effective slab width is calculated

automatically or based on the values you enter.

You can define different values for the left and right
side of the beam.

Automatic values are calculated in relation to the span
length.

Spanning tab

Use the Spanning tab to define the analysis and load distribution properties
of a one-way or two-way slab system.

Option Description
Spanning Defines in which directions the part carries loads.

The options are:

• Single spanning plate carries loads in the direction
of the primary axis. Beams or columns parallel to
the spanning direction are not connected to the
part, and will not carry loads from the part.

• Double spanning part carries loads along the
primary and secondary axes. Beams or columns in
both directions will carry loads from the part.

Primary axis direction Defines the direction of the primary axis in one of the
following ways:

• Enter 1 in the box (x, y, or z) which is parallel to the
primary axis direction.

• Enter values in multiple boxes to define the
components of a direction vector.

• Click Parallel to part, and then select a part in the
model that is parallel to the direction.
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Option Description
• Click Perpendicular to part, and then select a part

in the model that is perpendicular to the direction.

To check the primary spanning direction of a selected
part in a model view, click Show direction on
selected members. Tekla Structures indicates the
primary direction using a red line.

Loading tab

Use the Loading tab to include a part as loads in analysis models.

Option Description
Generate self weight
load

Analysis models include the part weight, for example
a deck, as a load even if the part is not otherwise
included in the analysis models.

If the part is included in an analysis model, so is
its self-weight. The option No works only with the
analysis classes Ignore and Rigid diaphragm.

List boxes for additional
loads

Enter slab live load or additional self-weight (screed,
services) using three additional loads with a load
group name and magnitude. The directions of these
loads follow the direction of the load group to which
they belong.

Part names Use this filter to ensure that the area load from the
slab is transferred to the correct parts, for example,
beams supporting the slab. Typically, you would enter
the beam name as the filter value.

Use continuous
structure load
distribution

Use to assign most of the load to the middle supports
on continuous structures.
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Design tab

Use the Design tab in the analysis part properties dialog to view and modify
the design properties of an individual part in an analysis model. Design
properties are properties which can vary, according to the design code and
the material of the part (for example, design settings, factors, and limits).

Position tab

Use the Position tab to define the location and offsets of an analysis part.

Option Description
Axis Defines the location of the analysis part in relation to

the corresponding physical part.

The location of the analysis axis of a part defines
where the part meets with other parts and where
Tekla Structures creates nodes in analysis models.

The options are:

If you select Neutral axis, Tekla Structures takes the
part location and end offsets into account when it
creates nodes. If you select either of the Reference
axis options, Tekla Structures creates nodes at part
reference points.

Keep axis position Defines whether the axis position is kept or changed
according to changes in the physical model.

The options are:
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Option Description
• No

The axis is free to move when snapping end
positions to nearby objects. Use this option for
secondary members.

• Partial - keep in major direction

The axis is free to move partially, but the member
is not moved in the major (stronger) direction of
the part profile.

• Partial - keep in minor direction

The axis is free to move partially, but the member
is not moved in the minor (weaker) direction of the
part profile.

• Yes

The axis is not moved, but the end positions can
move along the axis (thus extending or shortening
the member).

• Yes - Keep end positions also

The axis and the end positions of the member are
not changed.

Connectivity Defines whether the member snaps or connects with
rigid links to other members.

The options are:

• Automatic

The member snaps or connects with rigid links to
other members.

• Manual

The member does not snap or connect with rigid
links to other members. Automatic connectivity
to other members is created only if the member
position matches the other member exactly.

Axis modifier X

Axis modifier Y

Axis modifier Z

Define whether the member location is bound to
global coordinates, grid line, or neither.

The options are:

• None

The member location is not bound.

• Fixed coordinate

The member location is bound to the coordinate
you enter in the X, Y, or Z box.
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Option Description
• Nearest grid

The member is bound to the nearest grid line (the
snap zone is 1000 mm).

Offset Use to move the analysis part in the global x, y, and z
directions.

Longitudinal offset
mode

Defines whether the longitudinal end offsets Dx of
the physical part are used from the physical part
properties.

The options are:

• Offsets are not considered

• Only extensions are considered

• Offsets are always considered

Bar attributes tab

Use the Bar attributes tab in a frame object’s (beam, column, or brace)
analysis properties dialog to define the properties of its analysis bars.

You can use the options on this tab when the analysis class of the analysis part
is Beam, Column, or Secondary.

Option Description
Start offset

End offset

Calculate offsets to account for longitudinal
eccentricity at the member end (resulting in a bending
moment).

These offsets have no effect on the topology on the
analysis model. The offset value is only passed as a
member attribute to the analysis.

Replacement profile
name

Select a profile from the profile catalog. You can use
different analysis profiles at the start and end of parts
if the analysis application you use supports it.

To use different profiles at part ends, enter two
profiles separated by a pipe character, for example:
HEA120|HEA140
If the part is a built-up section in an analysis model,
the name of the built-up section can be entered here.
Any name can be entered, but if the name matches an
existing catalog profile name, the physical properties
of the section will be the same as the catalog profile
properties.

Curved beam mode Defines whether a beam is analyzed as a curved beam
or as straight segments.

The options are:
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Option Description
• Use model default

• Use curved member

• Split into straight segments

If you select Use model default, Tekla Structures uses
the option selected from the Curved beams list in the
Analysis Model Properties dialog.

Use the advanced option
XS_AD_CURVED_BEAM_SPLIT_ACCURACY_MM in File
menu --> Settings --> Advanced Options --> Analysis
& Design to define how closely straight segments
follow the curved beam.

No. of split nodes Use to create additional nodes or analyze a beam as
straight segments, for example, a curved beam.

Enter the number of nodes.
Split distances To define additional nodes in the member, enter

distances from the part starting point to the node.

Enter distances, separated by spaces, for example:

1000 1500 3000
Bar start number Defines the start number for analysis bars.
Member start number Defines the start number for analysis members.

Area attributes tab

Use the Area attributes tab in a plate’s (contour plate, concrete slab, or
concrete panel) analysis properties dialog to define the properties of its
analysis elements.

You can use the options on this tab when the analysis class of the analysis part
is Contour plate, Slab, or Wall.

Option Description
Element type The shape of the elements.
Rotation of local XY Defines the rotation of the local xy plane.
Element size x and y: The approximate dimensions of the elements,

in the local x and y direction of the plate. For
triangular elements, the approximate dimensions of
the bounding box around each element.

Holes: The approximate size of the elements around
openings.

Area start number Defines the start number for the plate.
Simple area (ignore cuts
etc)

Select Yes to create a simpler analysis model of the
plate, where cuts and openings are not considered.
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Option Description
Smallest hole size to
consider

Use to ignore small openings in the plate in the
analysis.

Enter the size of the bounding box around the
opening.

Supported Not available with Tekla Structural Designer.

Use to define supports for a contour plate, concrete
slab, or concrete panel.

You can create supports for the bottom edge of a
panel, for all edge nodes of a slab or plate, or for all
nodes of a beam. For panels, the bottom edge can be
inclined.

The options are:

• No

No supports are created.

• Simply (translations)

Only translations are fixed.

• Fully

Both translations and rotations are fixed.

See also

Analysis class options and colors (page 132)

Analysis axis options (page 135)

Modify the properties of an analysis part (page 66)

Define end releases and support conditions (page 68)

Define design properties for analysis parts (page 71)

Define the location of analysis parts (page 75)

Analysis class options and colors
Use the options in the Class list on the Analysis tab in a part’s analysis
properties dialog to define how Tekla Structures handles the part in the
analysis.

The option you select in the Class list determines which tabs are available in
the analysis part properties (page 122) dialog.

When the advanced option XS_AD_MEMBER_TYPE_VISUALIZATION is set to
TRUE (which is the default value), you can show the analysis class of parts
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using the following colors in the analysis model. You can also indicate the
analysis classes using different colors in the physical model (page 100).

The analysis application you use may not support all of the following
options. For example, the Truss options are not available with Tekla Structural
Designer.

Option Description Color
Beam Line object of two nodes.

Part can take any load, including temperature.

Blue

Beam - Truss Part can only take axial forces, not bending or
torsion moments, or shear forces.

Bright
green

Beam - Truss-
Compression
only

Part can only take compressive axial forces, not
moments or shear forces. If this part goes into
tension, it is ignored in the analysis.

Yellow

Beam - Truss-
Tension only

Part can only take tensile axial forces, not
moments or shear forces. If this part goes into
compression, it is ignored in the analysis.

Pink

Beam - Ignore Part is ignored in the analysis.

Self-weight load is taken into account if you have
set Generate self weight load to Yes on the
Loading tab.

Part not
shown in
the model

Column Vertical line object of two nodes. Modeled from
bottom to top.

Part can take any load, including temperature.

Blue

Column - Truss Part can only take axial forces, not bending or
torsion moments, or shear forces.

Bright
green

Column - Truss-
Compression
only

Part can only take compressive axial forces, not
moments or shear forces. If this part goes into
tension, it is ignored in the analysis.

Yellow

Column - Truss-
Tension only

Part can only take tensile axial forces, not
moments or shear forces. If this part goes into
compression, it is ignored in the analysis.

Pink

Column - Ignore Part is ignored in the analysis.

Self-weight load is taken into account if you have
set Generate self weight load to Yes on the
Loading tab.

Part not
shown in
the model

Bracing Line object of two nodes.

Part can take any load, including temperature.

For parts whose analysis class is Bracing, Keep
axis position is off by default.

Green

Bracing - Truss Part can only take axial forces, not bending or
torsion moments, or shear forces.

Bright
green
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Option Description Color
Bracing - Truss-
Compression
only

Part can only take compressive axial forces, not
moments or shear forces. If this part goes into
tension, it is ignored in the analysis.

Yellow

Bracing - Truss-
Tension only

Part can only take tensile axial forces, not
moments or shear forces. If this part goes into
compression, it is ignored in the analysis.

Pink

Bracing - Ignore Part is ignored in the analysis.

Self-weight load is taken into account if you have
set Generate self weight load to Yes on the
Loading tab.

Part not
shown in
the model

Secondary Line object of two nodes.

Part can take any load, including temperature.

For parts whose analysis class is Secondary, Keep
axis position is off by default. Secondary parts
snap to nearest nodes instead of part end nodes.

Orange

Secondary -
Ignore

Part is ignored in the analysis.

Self-weight load is taken into account if you have
set Generate self weight load to Yes on the
Loading tab.

Part not
shown in
the model

Wall - Shell Part can take any load, except temperature. Aqua
Wall - Plate Same as Wall - Shell but plate elements are used

in the analysis application.
Aqua

Wall - Shear
wall

Part can take lateral forces and vertical forces. Aqua

Wall - Ignore Part is ignored in the analysis.

Self-weight load is taken into account if you have
set Generate self weight load to Yes on the
Loading tab.

Aqua

Slab - Shell Part can take any load, except temperature. Aqua
Slab - Plate Same as Slab - Shell but plate, membrane, or

mat foundation elements are used in the analysis
application.

Aqua
Slab -
Membrane
Slab - Mat
foundation
Slab - Rigid
diaphragm

Only applies to parts parallel to a global xy plane.

Filter: Nodes that belong to a part matching
the filter will be connected with rigid links which
together affect displacement. For example, you can
use a column filter to connect only column nodes
to rigid diaphragms.

Lilac
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Option Description Color
Slab - Ignore Part is ignored in the analysis.

Self-weight load is taken into account if you have
set Generate self weight load to Yes on the
Loading tab.

Part not
shown in
the model

Contour plate -
Shell

Part can take any load, except temperature. Aqua

Contour plate -
Plate

Same as Contour plate - Shell but plate or
membrane elements are used in the analysis
application.

Aqua

Contour plate -
Membrane

Aqua

Contour plate
- Rigid
diaphragm

Only applies to parts parallel to a global xy plane.

Filter: Nodes that belong to a part matching
the filter will be connected with rigid links which
together affect displacement. For example, you can
use a column filter to connect only column nodes
to rigid diaphragms.

Lilac

Contour plate -
Ignore

Part is ignored in the analysis.

Self-weight load is taken into account if you have
set Generate self weight load to Yes on the
Loading tab.

Part not
shown in
the model

Analysis axis options
Use the options in the Axis list on the Position tab in a part’s analysis
properties dialog to define the location of the analysis part in relation to the
physical part.

Option Description Use for
Neutral axis The neutral axis is the analysis axis

for this part. The location of the
analysis axis changes if the profile of
the part changes.

 

Reference axis
(eccentricity by neutral
axis)

The part reference line is the analysis
axis for this part. The location of
the neutral axis defines the axis
eccentricity.

 

Reference axis The part reference line is the analysis
axis for this part.

 

Top left The analysis axis is located in the top
left corner of the part.

Beam objects
(beams,
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Option Description Use for
columns,
braces)

Top center The analysis axis is located in the top
center point of the part cross section.

Beam objects

Top right The analysis axis is located in the top
right corner of the part.

Beam objects

Middle left The analysis axis is located in the
middle of the left side of the part.

Beam objects

Middle center The analysis axis is located in the
center point of the part cross section.

Beam objects

Middle right The analysis axis is located in the
middle of the right side of the part.

Beam objects

Bottom left The analysis axis is located in the
bottom left corner of the part.

Beam objects

Bottom center The analysis axis is located in the
bottom center point of the part cross
section.

Beam objects

Bottom right The analysis axis is located in the
bottom right corner of the part.

Beam objects

Top plane The analysis axis is bound to the top
plane.

Plate objects
(plates, slabs,
panels)

Middle plane The analysis axis is bound to the
middle plane.

Plate objects

Bottom plane The analysis axis is bound to the
bottom plane.

Plate objects

Left plane The analysis axis is bound to the left
plane.

Plate objects

Right plane The analysis axis is bound to the right
plane.

Plate objects

Middle plane (of left/
right)

The analysis axis is bound to the
middle plane of left/right.

Plate objects

Tekla Structures uses the options above for each part when you select Model
default from the Member axis location list in the Analysis Model Properties
dialog.

If you select Neutral axis, Tekla Structures takes the part location and
end offsets into account when it creates nodes. If you select either of the
Reference axis options, Tekla Structures creates nodes at part reference
points.
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TIP You can also use keyboard shortcuts to move the selected analysis part
in relation to the physical part.

See also

Analysis part properties (page 122)

Analysis model properties (page 115)

Define or modify the axis location of an analysis part (page 76)

10.6 Analysis node properties
Use the Analysis node properties dialog to view and modify the properties of
a node in an analysis model.

To access the dialog, double-click an analysis node.

Option Description
Supports Defines which support conditions are used for the

node.

The options are:

• Get supports from part(s)

The support conditions of a corresponding part
end are used for the node.

• User-defined node supports

You can define the support conditions for the
node.

If you select User-defined node supports, you can
select one of the following options:

These options automatically set the degrees of
freedom for the node.

You can modify a predefined combination to suit your
needs. If you do that, Tekla Structures indicates it with
this option:
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Option Description

Rotation If you selected User-defined node supports, you can
define the rotation of the node.

The options are:

• Not rotated

• Rotated

If you select Rotated, you can define the rotation, or
you can set the rotation by the current work plane by
clicking Set rotation by current work plane.

Ux

Uy

Uz

Rx

Ry

Rz

Define the translational (U) and rotational (R) degrees
of freedom (displacements and rotations) of the node
in the global x, y, and z directions.

The options are:

• Free

• Fixed

• Spring

If you select Spring, enter the spring constant. The
units depend on the settings in File menu --> Settings
--> Options --> Units and decimals.

See also

Create an analysis node (page 61)

Merge analysis nodes (page 63)

Analysis model objects (page 9)

Status of analysis nodes (page 61)

10.7 Analysis rigid link properties
Use the Analysis rigid link properties dialog to view and modify the end
conditions of a rigid link.

To access the dialog, double-click a rigid link.

Option Description
Releases Defines which releases are used for a rigid link start or

end.

The options are:
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Option Description
• Automatic releases (by rules)

• User-defined releases
Start or End Defines which of the predefined or user-defined

combinations for releases is used for a rigid link start
or end.

These are the predefined options:

These options automatically set the degrees of
freedom.

You can modify a predefined combination to suit your
needs. If you do that, Tekla Structures indicates it with
this option:

Ux

Uy

Uz

Define the translational degrees of freedom
(displacements) in the global x, y, and z directions.

The options are:

• Free

• Fixed

• Spring

If you select Spring, enter the translational spring
constant. The units depend on the settings in
File menu --> Settings --> Options --> Units and
decimals.

Rx

Ry

Rz

Define the rotational degrees of freedom (rotations) in
the global x, y, and z directions.

The options are:

• Pinned

• Fixed

• Spring

• Partial release

If you select Spring, enter the rotational spring
constant. The units depend on the settings in
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Option Description
File menu --> Settings --> Options --> Units and
decimals.

Use Partial release to specify if the degree of
connectivity is between fixed and pinned. Enter a
value between 0 (fixed) and 1 (pinned).

Local Y direction Defines the local y direction of the rigid link. The
options are the global x, y, and z directions.

The local x direction is always the direction of the rigid
link.

See also

Create a rigid link (page 62)

Analysis model objects (page 9)

10.8 Analysis bar position properties
Use the Analysis Bar Position Properties dialog to view and modify the
position of an analysis bar.

To access the dialog, select an analysis bar, and then double-click a handle at
an end of the analysis bar.

Option Description
Offset mode Defines whether the automatic (Automatic offset) or

user-defined (Manual offset) offset values are used
for the analysis bar end.

Offset Defines the offset values in the global x, y, and z
directions.

See also

Define the location of analysis parts (page 75)

Analysis and design settings 140 Analysis bar position properties



10.9 Analysis area position properties
Use the Analysis Area Position Properties dialog to view and modify the
position of an analysis area.

To access the dialog, select an analysis area, and then double-click a handle at
an analysis area corner.

Option Description
Offset mode Defines whether the automatic (Automatic offset) or

user-defined (Manual offset) offset values are used
for the analysis bar end.

Offset Defines the offset values in the global x, y, and z
directions.

See also

Define the location of analysis parts (page 75)

10.10 Analysis area edge properties
Use the Analysis Area Edge Properties dialog to view and modify the position
and connectivity of an analysis area edge.

To access the dialog, select an analysis area, and then double-click a handle at
the mid-point of an analysis area edge.

Option Description
Offset mode Defines whether the automatic (Automatic offset) or

user-defined (Manual offset) offset values are used
for the analysis bar end.

Offset Defines the offset values in the global x, y, and z
directions.

Releases Defines which of the predefined or user-defined
combinations for releases is used for the analysis area
edge.

These are the predefined options:

These options automatically set the degrees of
freedom.
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Option Description
You can modify a predefined combination to suit your
needs. If you do that, Tekla Structures indicates it with
this option:

Ux

Uy

Uz

Define the translational degrees of freedom
(displacements) in the global x, y, and z directions.

The options are:

• Free

• Fixed

• Spring

If you select Spring, enter the translational spring
constant. The units depend on the settings in
File menu --> Settings --> Options --> Units and
decimals.

Rx

Ry

Rz

Define the rotational degrees of freedom (rotations) of
a member end in the global x, y, and z directions.

The options are:

• Pinned

• Fixed

• Spring

• Partial release

If you select Spring, enter the rotational spring
constant. The units depend on the settings in
File menu --> Settings --> Options --> Units and
decimals.

Use Partial release to specify if the degree of
connectivity is between fixed and pinned. Enter a
value between 0 (fixed) and 1 (pinned).

See also

Define the location of analysis parts (page 75)
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11Disclaimer

© 2025 Trimble Inc. and affiliates. All rights reserved.

Use of the Software and of this Software Manual are governed by a License
Agreement which determines whether you are an authorized user of the
Software and the Software Manual. The warranties and disclaimers set forth
in the License Agreement apply to the Software and the Software Manual.
Neither the Trimble entity granting the license nor any of its affiliates assume
responsibility that the text is free of technical inaccuracies or typographical
errors. The right to make changes and additions to this manual is reserved.

Trimble and certain product names are registered trademarks of Trimble Inc.
in the United States, the European Union and other countries and may have
similar statutory protections. Trademarks of third parties are not mentioned in
this Manual to suggest an affiliation with or endorsement by their owners.

Elements of the software described in this Manual may be the subject of
pending patent applications in the European Union and/or other countries.

Portions of this software:

Portions of this software make use of Open CASCADE Technology software.
Open Cascade Express Mesh Copyright © 2019 OPEN CASCADE S.A.S. All rights
reserved.

FLY SDK - CAD SDK © 2012 VisualIntegrity™. All rights reserved.

This application incorporates Open Design Alliance software pursuant to a
license agreement with Open Design Alliance. Open Design Alliance Copyright
© 2002–2020 by Open Design Alliance. All rights reserved.

CADhatch.com © 2017. All rights reserved.

RapidXml C++ library © All rights reserved.

FlexNet Publisher © 2016 Flexera Software LLC. All rights reserved. This
product contains proprietary and confidential technology, information and
creative works owned by Flexera Software LLC and its licensors, if any. Any
use, copying, publication, distribution, display, modification, or transmission
of such technology in whole or in part in any form or by any means
without the prior express written permission of Flexera Software LLC is
strictly prohibited. Except where expressly provided by Flexera Software LLC
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in writing, possession of this technology shall not be construed to confer any
license or rights under any Flexera Software LLC intellectual property rights,
whether by estoppel, implication, or otherwise.

To see the third party open source software licenses, go to Tekla Structures,
click File menu --> Help --> About Tekla Structures --> 3rd party licenses
and then click the option.
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