Benutzer in Tekla Model Sharing verwalten

Modified: 14 Aug. 2026 Tekla Structures 2025

Benutzer in Tekla Model Sharing verwalten

Benutzer mit der Rolle Besitzer können die Benutzer in einem freigegebenen Modell auf mehrere Arten verwalten. U. a. können Besitzer neue Benutzer einladen, Benutzerrollen und Berechtigungen ändern, E-Mail-Benachrichtigungen senden und Benutzer entfernen.

Wenn Ihnen die Rolle Tekla Model Sharing Admin für ein Firmenkonto zugewiesen ist, können Sie auch freigegebene Modelle und deren Benutzer über die Tekla Model Sharing Management Console verwalten. Sie können beispielsweise einem anderen Benutzer die Rolle Besitzer zuweisen, wenn der ursprüngliche Besitzer des Modells die Firma verlässt.

Die Management Console for Tekla Model Sharing funktioniert auch, wenn Tekla Structures nicht geöffnet ist. Sie müssen auch nicht Benutzer der freigegebenen Modelle sein. Beachten Sie dabei, dass die Rolle Besitzer nicht mit der Rolle Tekla Model Sharing Admin gleichzusetzen ist. Weitere Informationen finden Sie unter In der Management Console die Benutzer freigegebener Modelle verwalten.

Einladen von neuen Benutzern zu freigegebenen Modellen

  1. Öffnen Sie das freigegebene Modell, zu dem Sie neue Benutzer einladen möchten.
  2. Klicken Sie im Menü Datei auf Freigeben > Benutzer und Daten.
  3. Im Dialogfeld Benutzer und Daten geben Sie im Feld Anwender einladen die E-Mail-Adressen der neuen Benutzer ein und stellen die zugehörigen Benutzerrolle auf Editor, Besitzer, Project Viewer oder Viewer ein.

    Sie können mehrere Benutzer gleichzeitig hinzufügen. Trennen Sie die E-Mail-Adressen durch Semikola. Verwenden Sie keine Leerzeichen zwischen den E-Mail-Adressen.

    Wenn Sie mehrere Benutzer gleichzeitig hinzufügen, gilt für alle dieselbe Benutzerrolle. Die Rollen können später geändert werden.

  4. Klicken Sie auf die Schaltfläche Hinzufügen, um die neuen Benutzer zum Modell hinzuzufügen.
  5. Ändern Sie bei Bedarf die Benutzerrollen der neuen Benutzer.
  6. Aktivieren Sie das Kontrollkästchen E-Mail-Benachrichtigung an Benutzer senden, um die eingeladenen Benutzer per E-Mail zu informieren, und verfassen Sie bei Bedarf eine Nachricht an die eingeladenen Personen.
  7. Klicken Sie auf Änderungen speichern, um die Benutzer einzuladen.

Informationen über Benutzer und Freigabeaktionen anzeigen

Um Tekla Model Sharing-Benutzer und die grundlegenden Freigabeaktionen im Modell zu prüfen oder neue Benutzer zum freigegebenen Modell einzuladen, öffnen Sie unter das Dialogfeld Datei > Freigeben > Benutzer und Daten > Benutzer und Daten.

Option Beschreibung

Name

Name des Benutzers.

E-Mail

E-Mail-Adresse des Benutzers.

Rolle

Rolle des Benutzers: Besitzer, Editor, Project Viewer oder Viewer.

Wenn Sie ein Modell erstmals freigeben, werden Sie zum Besitzer des Modells und können die Rollen anderer Benutzer bestimmen. Die Rollen können später bei Bedarf geändert werden.

Verwenden Sie die verschiedenen Rollen, um die Berechtigungen der Benutzer für das freigegebene Modell zu steuern.

Beachten Sie, dass ein Modell mehrere Besitzer haben kann.

Wenn Ihnen die Rolle Tekla Model Sharing Admin für ein Firmenkonto zugewiesen ist, können Sie auch Benutzer und deren Rollen über die Management Console for Tekla Model Sharing verwalten.

Verbunden

Gibt an, ob der eingeladene Benutzer dem Modell beigetreten ist.

Datum

Datum, an dem der Benutzer dem Modell beigetreten ist.

Durch

Person, die den Benutzer eingeladen oder seine Benutzerrolle zuletzt geändert hat.

Zuletzt eingelesen

Datum, an dem der Benutzer das Modell zuletzt eingelesen hat.

↓

Die Zahl mit dem Abwärtspfeil gibt die Gesamtzahl der Aktualisierungspakete an, die im Freigabedienst verfügbar sind.

Die Zahl neben dem Pfeil gibt an, wie viele von diesen Paketen der Benutzer eingelesen hat.

Zuletzt ausgelesen

Datum, an dem der Benutzer zuletzt Änderungen rausgeschrieben hat.

↑

Die Zahl mit dem Aufwärtspfeil gibt die Gesamtzahl der Aktualisierungspakete an, die im Freigabedienst verfügbar sind.

Die Zahl neben dem Pfeil gibt die Nummer des letzten Pakets an, dass der Benutzer rausgeschrieben hat.

Entfernt die Berechtigungen des ausgewählten Benutzers für das Modell.

Nur Benutzer mit der Rolle Besitzer können andere Benutzer aus dem Freigabedienst entfernen.

Ändern von Benutzerrollen in einem freigegebenen Modell

Benutzerrollen legen fest, welche Rechte ein Benutzer beim Betrachten und Bearbeiten des freigegebenen Modells hat. Wenn Ihnen die Rolle Tekla Model Sharing Admin für ein Firmenkonto zugewiesen ist, können Sie auch Benutzer und deren Rollen über die Management Console for Tekla Model Sharing verwalten.

Die Berechtigungen der Benutzerrollen werden in der nachstehenden Tabelle aufgeführt:

Rolle Berechtigungen

Besitzer

Wenn Sie ein Modell erstmals in Tekla Model Sharing freigeben, werden Sie zum Besitzer des Modells.

Benutzer mit der Rolle Besitzer können:

  • Einlesen der Änderungen anderer Benutzer, Rausschreiben der eigenen Änderungen an den Freigabedienst

  • Einladen neuer Benutzer

  • Auflisten anderer Benutzer und Ändern ihrer Rollen

  • Ausschließen von Benutzern von diesem Modell

  • Entfernen der Modellinstanz und aller zum Modell gehörenden Daten aus dem Freigabedienst

  • Ändern der Modelleigenschaften Code und Beschreibung

Mehrere Benutzer können sich die Rolle Besitzer in einem Modell teilen. Der Besitzer, der die Modellfreigabe gestartet hat, kann jedem beliebigen Benutzer die Rolle Besitzer zuteilen.

Editor

Möglichkeiten für Benutzer mit der Rolle Editor:

  • Einlesen der Änderungen anderer Benutzer, Rausschreiben der eigenen Änderungen an den Freigabedienst

  • Bearbeiten des Modells

  • Auflisten anderer Benutzer

Project Viewer

Möglichkeiten für Benutzer mit der Rolle Project Viewer:

  • Einlesen der Änderungen anderer Benutzer, Rausschreiben der eigenen Änderungen an den Freigabedienst

  • Betrachten des Modells, jedoch kein Ändern von Modellobjekten

  • Auflisten anderer Benutzer

Für Benutzer mit der Rolle Project Viewer gesperrte Funktionen:

  • Ändern von benutzerdefinierten Attributen, die sich auf die Positionierung auswirken

  • Einfügen und Ändern von Achsen

  • Importieren und Aktualisieren von Modellen, wenn dadurch Träger und andere Objekte erstellt würden

Beachten Sie, dass Tekla Structures beim Öffnen des Modells mit der Rolle Project Viewer neu gestartet werden muss.

Die Berechtigungen der Rolle Project Viewer in einem freigegebenen Modell entsprechen den Funktionen, die in der Tekla Structures Carbon-Konfiguration verfügbar sind.

Viewer

Möglichkeiten für Benutzer mit der Rolle Viewer:

  • Einlesen der Änderungen anderer Benutzer

  • Betrachten des Modells

Für Benutzer mit der Rolle Viewer gesperrte Funktionen:

  • Rausschreiben beliebiger Änderungen an den Freigabedienst

  • Ändern von Modellobjekten

  • Verwenden der Exportbefehle

Beachten Sie, dass Tekla Structures beim Öffnen des Modells mit der Rolle Viewer neu gestartet werden muss.

Wenn Sie eine Tekla Structures-Partnerlizenz verwenden und einem Tekla Model Sharing-Produktionsmodell beitreten möchten, verwenden Sie die Rolle Viewer. Sie können dann Änderungen einlesen, aber keine Änderungen rausschreiben. Dadurch wird sichergestellt, dass das Fertigung-Modell nicht in ein Partnermodell konvertiert wird.

Wenn Sie die Tekla Structures-Partnerlizenz mit einer anderen Rolle als Viewer verwenden und Modelländerungen rausschreiben, ist das Modell dann für die Nicht-Produktion bestimmt, und alle Zeichnungen im Modell sind mit einem Wasserzeichen versehen.

Beachten Sie, dass die Berechtigung zum Zugriff auf das freigegebene Modell entfernt wird, wenn Sie das Modell mittels einer der folgenden Methoden aus der Freigabe entfernen:

Benutzer mit der Rolle Besitzer können die Rolle eines Benutzers wie folgt ändern:

  1. Öffnen Sie das freigegebene Modell, dessen Benutzerrollen Sie ändern möchten.
  2. Klicken Sie im Menü Datei auf Freigeben > Benutzer und Daten.
  3. Im Dialogfeld Benutzer und Daten wählen Sie den Benutzer aus, dessen Rolle geändert werden soll.
  4. Klicken Sie auf den Pfeil in der Spalte Rolle, und wählen Sie eine neue Rolle für den Benutzer aus der Liste aus.
  5. Um dem Benutzer mit der geänderten Rolle eine E-Mail-Benachrichtigung zu senden, markieren Sie das Kontrollkästchen E-Mail-Benachrichtigung an Benutzer senden.
  6. Schreiben Sie gegebenenfalls eine kurze Nachricht, die Sie der E-Mail-Benachrichtigung hinzufügen.

    Wenn Sie eine Nachricht beifügen, erhalten alle eingeladenen Benutzer und der Benutzer, dessen Rolle geändert wurde, dieselbe Nachricht.

  7. Klicken Sie auf Änderungen speichern.

Entfernen von Benutzern aus freigegebenen Modellen

Benutzer mit der Rolle Besitzer können nicht mehr benötigte Benutzer aus einem freigegebenen Modell entfernen.

  1. Klicken Sie im Menü Datei auf Freigeben > Benutzer und Daten.
  2. Im Dialogfeld Benutzer und Daten wählen Sie den Benutzer aus, der gelöscht werden soll.
  3. Klicken Sie auf die Schaltfläche , um die Berechtigungen des Benutzers für Modellzugriff und -änderungen zu entfernen.

    Wenn Sie versehentlich auf die Schaltfläche geklickt haben, können Sie erneut auf die Schaltfläche klicken, um das Entfernen der Benutzerberechtigungen abzubrechen.

  4. Wiederholen Sie die Schritte 2 und 3 für alle Benutzer, die Sie aus dem Modell entfernen möchten.
  5. Klicken Sie auf Änderungen speichern, um die Benutzer aus dem Modell zu entfernen.

Benutzer exportieren und importieren

Benutzer mit der Rolle Besitzer können die Liste der Benutzer im aktuellen freigegebenen Modell exportieren, um Änderungen an Rollen und Berechtigungen der Benutzer vorzunehmen oder dieselben Benutzer einem anderen freigegebenen Modell hinzuzufügen.

  1. Klicken Sie im Menü Datei auf Freigeben > Benutzer und Daten.
  2. Unten im Dialogfeld Benutzer und Daten klicken Sie auf Benutzer exportieren.

    Die Liste der Benutzer wird in der Datei users.csv im Unterordner \ModelSharing im Modellordner gespeichert. Die Liste weist das Format <E-Mail-Adresse>; <Rolle> auf.

  3. Je nach Bedarf können Sie folgendes tun:

    Ziel

    Vorgehensweise

    Rollen und Berechtigungen von Benutzern im aktuellen Modell ändern

    1. Öffnen Sie die Datei users.csv.

    2. Ändern Sie je nach Bedarf die Benutzerrollen, oder entfernen Sie Benutzerberechtigungen, indem Sie die jeweilige Rolle auf KEINE einstellen.

    3. Speichern und schließen Sie die Datei users.csv.

    4. Kehren Sie zum freigegebenen Modell zurück.

    5. Damit die Änderungen zur Anwendung kommen, klicken Sie unten im Dialogfeld Benutzer und Daten auf Benutzer importieren.

    6. Wählen Sie die Datei users.csv aus.

    7. Klicken Sie auf Öffnen.

      Die in users.csv vorgenommenen Änderungen werden jetzt in der aktuellen Benutzerliste aktualisiert.

    8. Um die Änderungen in den Benutzer für das aktuelle Modell zu speichern, klicken Sie auf Änderungen speichern.

    Benutzer in ein anderes freigegebenes Modell kopieren

    1. Schließen Sie das aktuelle Modell, und öffnen Sie ein anderes freigegebenes Modell.

    2. Klicken Sie im Menü Datei auf Freigeben > Benutzer und Daten.

    3. Unten im Dialogfeld Benutzer und Daten klicken Sie auf Benutzer importieren.

    4. Suchen Sie die Datei users.csv des vorherigen Modells, und wählen Sie diese aus.

      Standardmäßig wird die Datei users.csv im Unterordner \ModelSharing im Modellordner gespeichert.

    5. Klicken Sie auf Öffnen.

      Die Benutzer aus der Datei users.csv werden dem aktuellen Modell mit den in dieser Datei definierten Rollen hinzugefügt.

    6. Um die Änderungen in den Benutzern zu speichern, klicken Sie auf Änderungen speichern.

E-Mail-Benachrichtigungen senden

Benutzer mit der Rolle Besitzer können jederzeit per E-Mail anderen Modellbenutzern Benachrichtigungen senden.

  1. Klicken Sie im Menü Datei auf Freigeben > Benutzer und Daten.
  2. Im Dialogfeld Benutzer und Daten markieren Sie das Kontrollkästchen E-Mail-Benachrichtigung an Benutzer senden.
  3. Im Dialogfeld geben Sie unter dem Kontrollkästchen E-Mail-Benachrichtigung an Benutzer senden den Text der Benachrichtigung ein.
  4. Je nach Bedarf können Sie folgendes tun:
    • Um die Benachrichtigung an bestimmte Benutzer zu senden, wählen Sie die Benutzer in der Liste der Modellbenutzer aus.

      Sie können mit Hilfe der Shift-Taste eine ganze Reihe von Benutzern oder mit Hilfe der Strg-Taste mehrere Benutzer auswählen.

    • Um die Nachricht allen Benutzer zu senden, vergewissern Sie sich, dass keine Benutzer in der Liste der Modellbenutzer ausgewählt sind.

  5. Klicken Sie auf Senden.
Fanden Sie das hilfreich?
Absenden
Zurück
Weiter