Verbesserungen beim Modellieren

Tekla Structures
2021
Tekla Structures

Verbesserungen beim Modellieren

Mit Tekla Structures 2021 werden viele Verbesserungen bei der Modellierung eingeführt.

Verbesserungen bei der Erstellung von Teilkörpern

In Tekla Structures 2021 Stahl- und Betonteilkörper mit Hilfe von Instantiierung erstellt. Dadurch wird die Gesamtleistung verbessert, da dieselbe Teilkörpergeometrie an mehreren Positionen im Modell verwendet werden kann, ohne dass ähnliche Geometrien wiederholt neu erstellt werden müssen. Es ist auch weniger Speicher erforderlich für das Speichern der Körpergeometrien im Körper-Buffer erforderlich, da nur ein Geometrieeintrag für alle ähnlichen Instanzen gespeichert wird. Je nach Häufigkeit der Anwendung gleicher Teile im Modell machen sich beispielsweise beim Öffnen der Modellansicht, bei der Positionierung und bei Exporten eine verbesserte Leistung bemerkbar.

Körpergeometrien werden jetzt in den lokalen Koordinaten der Teile erstellt und gespeichert. Das verbessert die Genauigkeit. Hierdurch wird wiederum die Positionierung verbessert, da Teile in derselben Reihenfolge unabhängig von der Lage der Teile in globalen Koordinaten des Modells zugewiesen werden.

Neue Vorschau beim Kopieren oder Verschieben von Objekten

Wenn Sie Objekte mit Hilfe der Befehle Kopieren oder Verschieben kopieren oder verschieben, zeigt Tekla Structures jetzt eine Vorschau der neuen Position der kopierten oder verschobenen Objekte im Modell an. Auf diese Weise können Sie das Endergebnis des Kopierens oder Verschiebens sehen, bevor Sie den Zielpunkt für die kopierten oder verschobenen Objekte ausgewählt haben.

  1. Wählen Sie die zu kopierenden oder zu verschiebenden Objekte aus.

  2. Führen Sie einen der Befehle Kopieren oder Verschieben aus.

  3. Picken Sie den Ursprung zum Kopieren oder Verschieben.

    Tekla Structures zeigt eine Gummibandlinie zwischen dem ersten gepickten Punkt und der Cursorposition an. Bewegen Sie den Cursor, um zu sehen, wie sich die Vorschau ändert.

    Beachten Sie, dass Tekla Structures immer die Vorschau an der Position anzeigt, an der die Objekte kopiert oder verschoben werden, nicht an der Position, an der sich der Cursor beim Picken des Zielpunkts befindet.

  4. Picken Sie den Zielpunkt.

Mit der erweiterten Option XS_PREVIEW_LIMIT können Sie die Anzahl der in der Vorschau angezeigten Objekte begrenzen. Der Standardwert lautet 1000. Wenn der Wert 0 beträgt, ist die Vorschau deaktiviert.

Verbesserungen im Linienraster-Tool und im Radialraster-Tool

  • Wenn Sie im Linienraster-Tool nicht die Anzahl der Kopien eingeben, wird die Anzahl der Kopien jetzt aus den im Feld Abstand zwischen Kopien definierten Abständen zwischen den Objekten übernommen.

  • Wenn Sie im Radialraster-Tool nicht die Anzahl der Winkel oder den Abstand eingeben, wird die Anzahl der Kopien jetzt aus den im Feld Abstand zwischen Kopien definierten Abständen zwischen den Objekten übernommen.

Eingabetaste als Befehlsabschluss

Sie können jetzt die Befehle mit der Eingabetaste abschließen. Vergewissern Sie sich, dass die neue erweiterte Option XS_ENTER_FINALIZES_COMMANDS auf TRUE eingestellt ist, um die Eingabetaste als Tastenkombination zu aktivieren.

Bisher konnten nur die Leertaste und die mittlere Maustaste als Tastenkombinationen für den Befehlsabschluss bzw. bei Befehle der direkten Änderung nur die mittlere Maustaste verwendet werden.

Verbesserungen bei den Fangfunktionen

Die Fangfunktion wird jetzt nicht mehr von den objekteigenen ausgeblendeten Referenzlinien oder Geometrielinien mit der Rendering-Option Gerenderte Teile oder Gerenderte Komponenten (Ctrl/Shift + 4) ausgelöst.

Verbesserungen bei Schnittebenen

Beim Erstellen von Schnittebenen können Sie jetzt auch Ebenen auf Teilen und Komponentenobjekten auswählen, wenn Sie die Rendering-Optionen Schattiertes Drahtmodell oder Graustufen verwenden (Ctrl+2, Shift+2, Ctrl+3 bzw. Shift+3). Die zugehörigen Meldungen in der Statuszeile wurden ebenfalls verbessert.

Verbesserte Fehlermeldungen im Eigenschaftenbereich

Wenn Sie bisher einen ungültigen Wert in einem Wertfeld im Eigenschaftenbereich eingegeben haben, wurde ein roter Rahmen um das Feld und ein rotes Ausrufezeichen angezeigt. Jetzt ist das Ausrufezeichen durch ein ToolTip ersetzt, der die Fehlermeldung über dem Wertfeld anzeigt.

Verbesserungen in der Ortbetonfunktionalität

  • Es gibt Leistungsverbesserungen in den Funktionen für der Managementfunktionen für Betonierabschnitte. Dank dieser Verbesserungen werden das Öffnen und Ändern der Modelle sowie die Berechnung der Betoniereinheiten beschleunigt.

  • Mit Hilfe des Befehls Betoniereinheiten erstellen werden die Fertigteilbauteile nicht mehr automatisch den Betoniereinheiten hinzugefügt. Sie können diese jedoch weiterhin manuell hinzufügen.

  • Der Standardwert von XS_CALCULATE_POUR_UNITS_ON_SHARING wurde in FALSE geändert. Dadurch berechnet und aktualisiert Tekla Structures beim Rausschreiben und Einlesen nicht mehr automatisch die Betoniereinheiten in freigegebenen Modellen. Stattdessen kann jeder Benutzer den Befehl Betoniereinheiten erstellen jetzt in der lokalen Version des freigegebenen Modells ausführen, um aktuelle Informationen zu den Einheiten zu erhalten.

  • Einige Verbesserungen bei der Berechnung von Betonierabschnitten wurden bereits mit Tekla Structures 2020 SP1 eingeführt. Siehe 2020 SP1: Neue Funktionen und Verbesserungen für Details.

Der Abschnitt Nutzungsstatistiken wurde aus dem Menü Datei entfernt.

Der Abschnitt Nutzungsstatistiken wurde aus Datei > Einstellungen entfernt. Beachten Sie, dass Nutzungsdaten standardmäßig erfasst werden.

Die in der UserFeedbackLog.txt-Datei enthaltenen Nutzungsdaten können jetzt unter Datei > Logs > Nutzungsdaten-Log zusammen mit den anderen Logdateien eingesehen werden.

Beachten Sie beim Öffnen der Datei UserFeedbackLog.txt per Mausklick auf Nutzungsdaten-Log, dass die Logdatei immer mit dem Standardtexteditor geöffnet wird, nicht wie andere Logdateien, die über die Tekla Structures-Protokollanzeige eingesehen werden können. Die Option zum Umschalten zwischen den Protokollanzeigen funktioniert bei der UserFeedbackLog.txt-Datei nicht.

Die Logdatei UserFeedbackLog.txt befindet sich nun im Ordner TeklaStructuresModels.

Weitere Verbesserungen beim Modellieren

  • Oberflächenobjekte können jetzt kopiert werden. Wenn sie mit einer Teilfläche verbunden sind, werden sie zusammen mit dem Teil kopiert. Oberflächen können auch separat von einem Objekt zu einem anderem mit demselben Objekttyp kopiert oder verschoben werden, z. B. von einem Teil zu einem anderen Teil und von einem Betonierteil zu einem anderen Betonierteil.

  • In Modellansichten werden keine Mosaikkanten innerhalb von gebogenen Oberflächenobjekte mehr angezeigt. Das gilt sowohl bei DirectX-Rendering als auch bei älteren Rendering-Methoden (OpenGL).

  • Die Befehle Teil in Element konvertieren und Form aus Geometrie erstellen sind jetzt in Bearbeiten auf dem Menüband verfügbar. Bisher konnten diese Befehle über das Kontextmenü mit der rechten Maustaste oder mit Schnellstart ausgeführt werden.

  • Das Untermenü Aktives Fenster wurde jetzt aus dem Kontextmenü Zoom im Modellmodus und im Zeichnungsmodus entfernt. Im Modellmodus sind die Zoom-Befehle auf der Registerkarte Ansicht im Menü Zoom verfügbar, und in den Tooltips werden die entsprechenden Tastenkombinationen angezeigt. In beiden Modi sind die Zoom-Befehle im Schnellstart verfügbar, in dem Sie auch die Tastenkombinationen anzeigen können.

  • Die Abzweigungen Bewehrungsstab und Bewehrungsmatten wurden aus dem Materialkatalog entfernt. Bewehrungsdefinitionen sind im Bewehrungskatalog verfügbar.

Was this helpful?
Previous
Next