Release notes: Tekla Structural Designer 2021 SP5

Tekla Structural Designer
2021
Tekla Structural Designer

Release notes: Tekla Structural Designer 2021 SP5

This release will update your Tekla Structural Designer installation to version number 21.5.0.85 and should be installed to ensure optimum function of the program. It includes a number of new features, enhancements and issue resolutions as detailed below.

Note:

Release 2022 (version 22.0.0.49 released Mar 2022) is now available. This includes all the enhancements listed below and many more. In preference to installing this service pack, it is our strong recommendation that you upgrade to R22 as soon as possible.

If you are upgrading from a version earlier than the immediately prior release 2021 SP4.1 (version 21.4.1.2 released Jan 2022), you can find details of requirements, enhancements and fixes for all previous releases in Tekla User Assistance (TUA) and Tekla Downloads via the links below:

Licensing & Installation

Licensing:

Installation:

  • This service pack requires Tekla Structural Designer 2021 first release (version 21.0.0.116) to be installed and will update your current version.

  • Integration:
    • Tekla Structures - if you wish to integrate with Tekla Structures you should install both this release and Tekla Structures 2021 (latest Service Pack) for optimum performance.

      • Note that there have been significant improvements to integration with Tekla Structural Designer - especially for rebar transfer - in the 2021 release of Tekla Structures. For more information about this please see the Tekla Structures Help Topic Tekla Structural Designer Import and Export.

    • Tekla Tedds - to use Design using Tekla Tedds, for optimum performance you should install Tekla Tedds 2021. This can be obtained from Tekla Downloads.

    • Tekla Portal Frame and Connection Designer 21 - if you wish to integrate this release with Tekla Portal Frame Designer/ Tekla Connection Designer - or use these products on their own - you should install Service Pack 4 for Tekla Portal Frame Designer 21/ Tekla Connection Designer 21 which is installed at the same time as this release. The installation for this can be obtained from Tekla Downloads.

    • Autodesk Revit© - the Tekla Structural Designer Integrator for Autodesk Revit© 2022 (version 8.0) was released in June 2021. For more information about this see the Tekla Structural Designer Integrator June 2021 updates page. The installation for this is available in Tekla Downloads. If you are using Autodesk Revit© 2022, you can install this to perform BIM integration with Tekla Structural Designer.
      • Fixes and enhancements included in the Integrator for Revit© 2022 were also included in updates for the Integrators specific to the other currently supported Revit© versions which are 2019 (update version 5.04), 2020 (update version 6.03) and 2021 (update version 7.02). For more information see the Tekla Structural Designer Integrator June 2021 updates page. If you are performing BIM integration with any of these Revit© versions, we recommend you update to the latest version of the associated Integrator.
        • Please note that the Integrator for Revit© 2018 is no longer supported and so there is no update for this.

  • Previous Versions and file compatibility - files from all previous versions can be opened in this release, however note that, once saved, they cannot then be opened in a previous release. If you wish to retain this option we therefore recommend using the File > Save As… option to save a copy of the file in the previous release and retain the original.

Issues with Associated Product Bulletins

  • [TSD-10846] - Timber Design Using Tekla Tedds - Eurocode and USA Head Codes - for Timber Design using Tekla Tedds and models with seismic loading using the RSA method, the RSA analysis results were not considered when determining the design forces populated to the Tedds timber design calculation. This was an intended scope limitation of the initial release of this feature, but unfortunately this was not made clear in the release documentation. For more information please see Product Bulletin PBTSD-2201-1.
    • This issue is addressed in this release - RSA results are now considered when determining the design forces populated to the Tedds timber design calculation.

Highlight - New Quick Access window

An exciting new productivity feature is added in this release, the Quick Access Window which can be used to quickly search for and access/ activate any of; File menu and Ribbon commands; View actions; Settings; Entity properties. A demonstration is provided in this video topic, but briefly its operation is as follows:

  • Press the keyboard Ctrl+Q keys to open the Quick Access Window - it can then be moved and docked etc just like Scene Content Window for example.

    • Ctrl+Q is the only way to open this window currently.
  • To find an action/ command, just start typing in the search box at the top of the window. As you type, the top 10 matching actions are listed. Click “Show all matching actions” at the bottom of the window - or press the keyboard Ctrl+M keys - to see all matches.

    • Use the keyboard Up/ Down keys to navigate through the list, then press the Enter key to select and activate your chosen action/ command.

  • When the search box is empty, the last 10 actions are listed giving rapid and convenient access to the actions/ commands you have been using recently.
  • Typical actions that can be listed are:
    • File menu and ribbon commands
    • Entity properties (entity selected first)
    • View actions
    • Open and orientate views
    • Scene content settings
    • Global/Model Settings
  • File Menu and ribbon commands - not yet active actions are indicated with “✔”. When an action is selected and active it will no longer be listed..

  • Following are just some of the ways you can use the new Quick Access Window to quickly and efficiently access actions and make edits:

    • Properties of Selected Entity - to edit the properties of entities do the following; select one or more entities, search for and select the property in the Quick Access Window - it will then be selected in the Properties Window. Then do the following depending on the property settings:

      • Property values - type in new values.

      • Drop lists - press the keyboard space bar to open the list, use the up/ down keys to navigate it and hit Enter to select the desired value.

      • Checkboxes - double-press the keyboard space bar to toggle the checkbox from the current on/ off setting.


  • Scene Content - type “scene..” in the search box and Scene Content settings will be listed. You can type another following term such as ‘beam’ to narrow the settings to a particular type of entity. Then navigate to and select your chosen scene content setting to hide the associated entities in the scene. As you repeat this process, the current search list will be sorted by the most recently accessed scene content settings. As shown in the picture below a “✔” symbol indicates the scene content setting will be switched ON when it is selected (i.e. the entity type is currently hidden) - while a “✖” symbol indicates the scene content setting will be switched off if selected (i.e. the entity is currently displayed).


  • Opening, Activating & Navigating Views - you can quickly search for and open views, for example Level views by entering the search term “open st” or Frame views with the term "open frm"" as shown in the picture below - just navigate to a listed view and Enter to select and open it.

    • You can also list currently open views using the “activate” search term, then select any of the listed views to activate it. Add “st.” to the search term to prioritize level views in the list or “frm” for frame views etc.

    • Use “Set” (TOP/FRONT/LEFT etc) to list and select from the viewcube orientation options.



General & modeling

  • A number of additional fixes which are not detailed explicitly here are also made to improve general performance and stability. An example of this is given directly below:

    • [TSD-11177] - an exception would occur when splitting a continuous member with a Temperature load applied to it. This problem no longer occurs and the temperature load is correctly duplicated on the new members resulting from the split.

  • [TSD-7338] - New Keyboard Shortcuts

    The following new keyboard shortcuts are added in this release to provide quick and efficient access to a number of key actions and features:

    • Ctrl+P Process Window - to open/close the Process Window.

    • Ctrl+C Copy - first make a selection of entities then press Ctrl+C to start the copy operation.

    • Ctrl+D Validation - press Ctrl+D to run the model validation process - on completion the Project Workspace switches to the Status page if not already active.

    • Ctrl+T 2D/3D toggle - for any planar view, press Ctrl+T to toggle between 2D and 3D view options.

    • Ctrl+R,1..6 View Regime - to change the view regime depress the Ctrl key then, keeping it depressed, press R followed by a number key from 1 to 6 to activate the associated view regime as follows (note this only functions with the number keys above keyboard letter keys, not the numpad) : 1 = Structural View, 2 = Solver View, 3 = Results View, 4 = Wind View (only if Wind model exists), 5 = Review View, 6 = Slab Deflection View.

Interoperability

FBEAM export

The following issues with FBEAM Export are addressed in this release.

  • [TSD-10764] - Cantilever reactions now exported

    Previously there was a limitation that the reaction from any supported beam or column at the tip of a FABSEC cantilever beam was not exported to FBEAM. This limitation is removed in this release and such reactions are now exported.

  • [TSD-10944] - Export failed when composite beam had no shear connectors

    No export file was created when any composite beams selected for export had an undefined shear connector layout. For any such beams a default connector layout is now assigned and the export will complete successfully.

  • [TSD-10448] - Camber set to proportion of load now exported

    When the camber option is enabled and set to the option “Apply as Proportion of deflection” the appropriate camber value is now exported.

Performance

  • [TSD-10221] - Concrete design speed improved when load envelopes present

    Previously, when load envelopes were added they were unnecessarily considered by the concrete design process (which design for all combinations hence does not need to consider envelopes). This is fixed in this release resulting in significantly reduced concrete design time when load envelopes are present.

  • [TSD-4946] - Improved interactive concrete column & wall design check process

    When making edits - for example to the number of bars - in the Interactive column and wall design dialogs, previously the process to update the check results was made for each edit which could take some time and slow down the process of interactive design. In a previous release this was improved with a manual “suspend checking” option for walls but not for columns. In this release, the suspend checking (until edits are complete) process is now fully automated for both columns and walls as follows:

    • During editing, the check process is now constantly automatically aborted/ re-started as necessary, hence editing is not prevented and the wait time after the final edit is minimized.

    • An “Updating” message is displayed below the dialog buttons while checks continue as shown in the picture below


  • [TSD-10900] - Improved performance for models with composite steel beams

    The procedures to determine composite beam flange effective widths have been optimized to minimize RAM requirements and improve speed. The effective width calculation procedures run when opening a model and are re-run repeatedly while editing and designing the model. The reduction in RAM is significant and means that, particularly for systems with a "favor speed" setting (see Help topic Performance settings), there is much less chance of RAM requirements reaching the system limits and the drastic performance reduction this can cause. In summary:

    • For systems and models where RAM availability was not an issue, you will see small performance benefits.

    • Where RAM availability was a limiting factor you may see very significant performance benefits (potentially order of magnitude improvements) at various stages of modeling and design.

    • Quite modest models which might previously have challenged the RAM limits on a system with 16GB of RAM will now run comfortably on such machines.

Loading

[TSD-11047] - USA seismic wizard can now be resized and layout is fixed

An error was introduced in the Seismic Wizard dialog in release 2021 SP1 for the Site Specific Spectra option (user defined - generic curve). The user was prevented from seeing or accessing the bottom lines in the table when defining the generic curve and access to the drop down list of shear wave velocity, vs:30 located beneath the table was also prevented. This is fixed in this release.

Validation

[TSD-3601] - Composite beams - new validation check for beams with non-composite slab

Validation now checks for the circumstance of composite beams in contact with composite slabs for only part of their length and any other slab types for the remaining length. Where previously the effective width of such beams was automatically calculated (based on the touching composite slab), the default effective width is now set to zero, producing a Validation error. For such cases you can then exercise your judgment and either set them to non-composite, or check on their “Override effective width” setting and enter your own user-defined effective width value.

Analysis & results

  • [TSD-9396] - Sorting of sway and drift tabular results by column

    The Review View > Tabular Data results tables for Sway and Drift can now be sorted in ascending and descending order of any column by clicking the column header. This applies to all of the following tables; Sway, Kamp, Drift, Wind Drift, Seismic Drift.

    • Sorting can be performed in the summary view as well as full tabular view.

    • The user defined sorted table can be exported to Excel.


  • [TSD-10693] - Analysis results display - New progress bar and option to cancel

    For large models there can be quite lengthy wait times while results are processed for display in the Results view, especially for the display of the results for envelopes for a large number of combinations. Additionally in previous releases it was not clear that a process was in operation during the wait time. This is addressed in this release as follows:

    • When results are activated, a new progress bar is shown at the top of the view window making clear the operation that is ongoing and the progress through this.

    • The Cancel button at the left of the status bar is enabled, allowing you to cancel the operation if, for example, you wish to change the selection of results you wish to view.


  • [TSD-10778] - Wind Drift Check - All Head Codes - correct critical combination flagged in Details

    In previous releases, while the Wind Drift Tabular Data Results table reported the correct critical combination, an incorrect combination could be flagged as critical (with the ❢ symbol) in the list of combinations in the check details dialog.

Design - general

  • [TSD-10571 & 11179] - Design Status - new “Not Yet Designed” status

    In the Review View > Design Status view, a new “Not Yet Designed” status has been added to the legend. This clarifies the design status for entities that are not designed ‘natively’ within Structural Designer, such as Precast Concrete and Timber members. This especially helps to clarify the workflow for design using Tekla Tedds as illustrated in the picture above.

    • In addition to this change, other than Pass and Fail the legend now only lists other statuses with an entity count > 0, giving a clearer idea of the overall design status of the model.

  • [TSD-10260] - Steel beams with web openings - new warning for closely spaced openings

    For the USA and Eurocode Head Codes, a new warning status and message in the design details is issued when any pair of openings in a beam is established as 'closely spaced' with the text "Warning: one or more openings are 'closely spaced'. Not all local Vierendeel effects around openings have been taken into account in determining the deflection."


Design - head code Eurocode

[TSD-10880] - Concrete beam design - modified calculation of maximum allowable shear and torsion capacity

The calculation of the maximum allowable shear and torsional strengths in the design of reinforced concrete beams has been modified to utilize the calculated shear strut angle 𝛳 rather than the maximum shear strut angle 𝛳max. This change may result in a difference in the value of the calculated design force/strength ratios to some extent, however that the outcome of the design in terms of pass or fail should remain the same in the majority of cases.

Design - head code USA

[TSD-8482 & 10608] - Seismic steel design - new warnings for SFRS members in non-linear models

New design warnings are issued for SFRS members in non-linear models - such as those that include Tension Only bracing. Please refer to Product Bulletin PBTSD-2110-1 for full details about the issues for this situation. The location and behavior for the warnings is as follows:

  • When the model is non-linear and the Design Setting for Analysis ``Solve lateral loadcases in isolation if non-linear analysis is required during design” is NOT enabled, a warning is now issued in the Seismic Required strength checks for SFRS members which require the inclusion of an amplified seismic force. As shown in the picture below, the cursor tooltip for the warning directs the user to enable the Design > Analysis setting. This warning is reflected in the overall design status of SFRS members.


  • SFRS members attached to Tension Only bracing - when the above setting is enabled, a Warning is still issued in the design details for such members directing the user to the Product Bulletin. The overall design status is governed by that of the design checks.


Reports & drawings

[TSD-7750] - Problem with generating report images fixed

In a small number of models, reports containing multiple images on a single page could display 'The image could not be generated!" error in place of one or more of the images. This problem has now been fixed.

Notes

The number in brackets before an item denotes an internal reference number. This can be quoted to your local Support Department should further information on an item be required.

Was this helpful?
Předchozí
Další