Release Info Tekla Structures 2019i

Tekla Structures
2019i
Tekla Structures
Release Info
Environment
Netherlands
South America
Spain

The Release Info 2019i includes the following topics:

General

Tekla Structures 2019i videos

Tekla Structures Tekla Structures provides many new options, improvements and fixes. These are all explained in this Release Info. Besides, some videos are available in which these functionalities are explained.

Image
2019-08-23_11-05-52_0.png


You can check the following videos (per segment):

Tekla Structures 2019i for Steel

Tekla Structures 2019i for Precast

 

Creates sub-folders in the ts folder

Tekla Structures includes the folder ts (..:\TeklaStructures\2019.1\Environments\construsofteuropean\TS) by default in which you can store your created settings and have these settings available for all Tekla Structures models. The location of this folder is defined by the advanced option XS_FIRM in the Advanced options (via File > Settings > Advanced options).
 
You can now also create sub-folders in the ts folder and store your own settings in there. This means that you can have a more organized folder structure in the ts folder, for example:

Image
2019-07-18_09-40-26.png


As you can see in the picture above, modified databases (such as the profile- or material database) are not stored in any sub-folder but always direct in the ts folder.
Besides that, it is not allowed to use sub-folders with the following names:

- ProjectOrganizerData
- AdditionalIPSets
- macros
- Drawing Details
- extensions
- CustomInquiry
- PropertyRepository
- symbols
- template
- profil
- the names of the "Environment" folders (such as construsofteuropean, common, etc.)

Custom components

The following counts for custom components:
 
As you can see in the picture above, a sub-folder Custom_components is added and custom components are located in this folder.
The advanced option XS_UEL_IMPORT_FOLDER (stored in the "role"-file in the folder C:\TeklaStructures\2019.1\Environments\construsofteuropean) points to the folder in which the custom components can be located. The advanced option points to the folder ..environments\construsofteuropean\<your_configuration>\ComponentsSketches\ by default but you can also point this advanced option to the sub-folder:

Image
2019-09-18_10-39-15.png

 

Adapted content in role files

In Tekla Structures 2019i the content of several role files has been adapted. Many lines, starting with the text rem, are deleted from the files:
 
Tekla Structures 2019i:

Image
2019-09-16_14-29-50.png


Tekla Structures 2019:

Image
2019-09-16_14-29-11.png


The files now only include lines starting with the text set and are therefore executed. The role files are located in the folder ..:\TeklaStructures\2019.1\Environments\construsofteuropean.
 

Updating model templates

In case you have created model templates in earlier Tekla Structures versions, you must update the templates to use them hassle-free in Tekla Structures 2019i.
 
Click here for the general step plan.
 

Copy customized ribbon and shortcuts to Tekla Structures 2019i

You can copy your customized ribbon and shortcuts (after installing Tekla Structures 2019i) from an older Tekla Structures version to Tekla Structures 2019i.
 
Copy the ribbon
 
1. In the Windows Explorer, go to the folder (depends on the Tekla Structures-version) C:\Users\<user>\AppData\Local\Trimble\TeklaStructures\<version>\UI\Ribbons\                                            
 or the folder C:\Users\<user>\AppData\Local\Trimble\Tekla Structures\<version>\UI\Ribbons\
2. The *.xml file: albl_up_<license>--main_menu.xml contains the customized ribbon.
3. Copy this *.xml file to the folder C:\Users\<user>\AppData\Local\Trimble\Tekla Structures\2019.1\UI\Ribbons.
 
Click here for more detailed information about copying the ribbon.
 

Copy shortcuts

To copy shortcuts from an earlier Tekla Structures version to Tekla Structures 2019i:
 
1. In an earlier Tekla Structures version, go to File > Settings > Keyboard shortcuts.
2. Click on the button Export, save the *.xml file on the desired location with the desired name.
3. In Tekla Structures 2019i, go to File > Settings > Keyboard shortcuts.
4. Click on the button Import, select the *.xml file and click on the button Open, the shortcuts are now imported.
 
You can copy the exported *.xml file to any computer and next import the file in Tekla Structures 2019i.
 

New macros available

Tekla Structures includes many macros by default. You can use these macros to automatically run specific commands in Tekla Structures.
 
Tekla Structures 2019i includes many new macros in the Applications & components database. You can use the search term type:macro to view all macros, in both Model- and Drawing Editor:

Image
2019-09-16_15-24-04.png


                                       Model Editor                                                                                   Drawing Editor

We will describe some of these new macros:

In the Model Editor:

Image
2019-08-28_09-29-01.png


You can use these macros to show the exact or the basic geometry for the selected part (for example for checking purposes).
 
Tip: To be able to use these macros even faster, you can also add the macros to the Mini toolbar:

Image
2019-08-28_09-51-15.png


Click here for more information about adding macros to the Mini toolbar.

Image
2019-09-16_15-37-37.png


Several macros to run specific clash checks.

Image
2019-09-16_15-39-04.png


You can use this macro to open a shop drawing directly from a selected part. There is no need to first open the Document manager.

- If you want to open a drawing of a part from which multiple drawings (sheets) have been generated, the first drawing (sheet 0) will be opened.

- If you want to open a drawing of a part from which multiple workshop drawings (single part and assembly drawing) have been generated, the following message appears:

Image
2019-08-28_11-08-41.png


You can now select which drawing you want to open.

Image
2019-09-17_15-43-31.png


You can use this macro to inquire the level mark on a selected point on a part:

Image
2019-08-28_11-28-37.png


 

Macro Bolts between points improved

The tool Bolts between points (m093) was already included in Tekla Structures for many versions to quick and easily model bolt groups:

Image
2017-09-05_15-26-29.png


It is preferred to switch snap option Snap to lines and edges on so that you can snap to the edges of parts. The yellow arrowhead indicates the direction of the bolt group. If you want to change the direction, move the cursor closer to the opposite end of the line.

The macro is adapted and now includes the new option Auto detect:

Image
2019-09-17_16-01-22.png


You can use the option to define whether a search area should be used or not. If you set the option to Yes, neighbor parts that are close to the selected main part (in the example below the upper plate) are included in the bolt group:

Image
2019-09-02_14-01-10.png

                                                         Yes                                                                                                                           No
 

Interoperability

Trimble Connect Visualizer

Starting from Tekla Structures 2019i, you can now access Trimble Connect Visualizer directly from Tekla Structures:

Image
2019-07-15_13-16-20.png

 
                                                    Tekla Structures                                                                                                  Trimble Connect Visualizer
 
In Trimble Connect Visualizer, you can take snapshots or create animations that demonstrate the design of your models and the build options and use the snapshots and animations to create more appealing sales and project presentations. The Visualize commands are located on the View tab:

Image
2019-09-17_16-09-53.png


Click Visualize selected to open a rendering of the selected model objects in Trimble Connect Visualize.
Click Visualize all to open a rendering of the entire model in Trimble Connect Visualizer.
Click Visualizer material type settings to open the Visualizer settings dialog box, where you can adjust how the materials in your model are shown in Trimble Connect Visualizer.
 
Adjusted settings are stored in the file VisualizerMaterials.xml in the sub-folder .\attributes in the model folder. If desired, you copy these setting to the folder ..:\TeklaStructures\2019.1\Environments\common\system\Visualizer to make the settings available in all Tekla Structures models after restarting Tekla Structures.

Adjust the model view in Trimble Connect Visualizer
In Trimble Connect Visualizer you can zoom, pan, and rotate the model to view different angles of the model. Click
Image
2019-07-15_14-05-55.png
on the Trimble Connect Visualizer side pane to further adjust the scene. You can change the background, the brightness of the scene or the visibility:

Image
2019-07-15_14-42-57.png


Take and view snapshots

In Trimble Connect Visualizer you can take and view snapshots. All snapshots that you take in Trimble Connect Visualizer are stored in the folder ..:\Users\<username>\Pictures\TrimbleConnectVisualizer.
- To take a snapshot of the current view, click
Image
2019-07-15_15-00-28.png
  in the Trimble Connect Visualizer side pane.

- To open the ..\Users\<username>\Pictures\TrimbleConnectVisualizer folder, click
Image
2019-07-15_15-05-57.png
.

Create animations

You can create animations that show the model from different angles, or views.

To take a snapshot of the current view, click
Image
2019-07-15_15-15-02.png
in the Trimble Connect Visualizer side pane.

Next click
Image
2019-07-15_15-16-28.png
to add the views that you want to include in the animation.

Image
2019-07-15_15-20-11.png


You can also adjust the speed of the animation and the sun position and preview the animation.
 

Modeling

Command CS Visualizer in the side pane extended

Tekla Structures includes the side pane on the right where you have access to several commands. The command CS Visualizer includes three tabs by default:

Image
2019-09-19_11-08-53.png


Assembly: Visualize the assembly, sub- and nested assembly hierarchies.
Phases: Visualize the phases in model views.
Zone: Visualize the zones.

In Tekla Structures 2019i, the tab Zone is extended. Click the right mouse button, a new pop-up menu appears:

Image
2019-09-19_11-11-54.png


Here you can define the parts you want to display in the model view.

When you use the option Material for example, you can display the various materials in the model views.

All materials (concrete and steel) are displayed:

Image
2019-07-15_09-56-23.png


Only concrete is displayed:

Image
2019-07-15_10-02-46.png

 

Attaching point clouds enhanced

You can attach point clouds in your Tekla Structures model via the command Point clouds
Image
2019-09-02_14-30-23.png
in the side pane. In earlier Tekla Structures versions, you could only use local point clouds or point clouds stored on a server.
From Tekla Structures 2019i on you can now use point clouds through internet. There is a new URL option in the Attach point cloud dialog box where you can enter the URL address:

Image
2019-09-18_11-37-58.png

 

Updates to the property pane, UDAs, and to the Property pane editor

Tekla Structures 2019i introduces improvements in the property pane and the Property pane editor. With these updates, especially the viewing and modifying of user-defined attributes (UDAs) is now easier and more straightforward.

New options to control the visibility of properties and user-defined attributes in the property pane

You can now control which properties are shown in the property pane without customizing the property pane layout. Click the Visibility button (1) to open a drop-down menu in the property pane. When you open the property pane for the first time without any customizations in firm, project, or environment folders, the Show properties based on visibility settings option is selected by default.

Image
2019-09-19_11-23-24.png


Expand all or Collapse all

Use to expand or collapse all the property groups:

Image
2019-09-19_11-28-06.png


Show properties that have a value

Select to show only those properties that have a value. This is useful especially with user-defined attributes (UDAs). UDAs that have a value are always shown, even if they have not been added to the property pane layout. This means that you can view and modify the UDA values in the property pane without customizing the property pane layout.
 
1. Select objects in the model.

Property pane shows all the properties and UDAs for which you or someone else has entered a value. Properties and UDAs which do not have a value are hidden.

UDAs that are not included in your current property pane layout but which have a value are listed in the Additional matches property group.

2. Modify the property values as needed.

3. If you want to enter a value to an empty property, use the search to temporarily show the needed properties, or select the Show properties based on visibility settings option. The Show properties that have a value option is common for all object types. For example, if you select a steel beam in the model and use the Show properties that have a value option, and then select a concrete beam in the model, only those properties that have a value are shown for the concrete beam as well.

Show properties based on visibility settings

Select which property groups are visible and which are hidden. You can show and hide property groups by clicking the property group names. The eye symbols indicate which property groups are visible and which are hidden.
 
1. Select objects in the model.

Property pane shows all the property groups which are visible in the property pane.

Property groups with the
Image
2019-08-27_10-45-41_1.png
icon are visible. Property groups with the
Image
2019-08-27_10-45-53_1.png
icon are hidden.

2. Modify the property values as needed.

3. If you want to make a hidden property group visible, click the eye icon again.

The Show properties based on visibility settings option is common for all object types. If different object types have property groups of the same name, the visibility of a property group is adjusted for all the object types. For example, if you select a steel beam and hide the Position property group, and then select a concrete beam, the Position property group is hidden for the concrete beam as well.

To easily define the default visibility of property groups, use the Property pane editor. Note that the changes in the visibility settings in the property pane override the default settings defined in the Property pane editor.

Set default values automatically
 
You can use the new Set default values automatically option to switch between automatic and manual applying of properties for the next objects of the same type:

Image
2019-09-04_14-36-47.png


The option Set default values automatically is not selected:

Image
2019-09-19_11-56-58.png


1. Double-click the command Column to open the Steel column properties dialog box.
2. Select the setting standard and pick a column in the Tekla Structures model:

Image
2019-09-03_11-12-54_1.png


3. Double-click on the column and adjust the properties, for example the class and the top of the column, next click Modify:

Image
2019-09-03_11-16-31.png


You now have two options:

a. You can click the button Set as default to retain the properties in the dialog box. Tekla Structures uses the current values for the next objects of the same type. Click command Column and pick a column in the model:

Image
2019-09-03_11-19-46.png


b. If you do not click on the button Set as default, Tekla Structures will not retain the properties in the dialog box. Click the command Column and pick a column in the model:

Image
2019-09-03_11-24-13.png


The option Set default values automatically is selected:

Image
2019-09-19_12-06-39.png


1. Double-click the command Column to open the Steel column properties dialog box.
2. Select the setting standard and pick a column in the Tekla Structures model:

Image
2019-09-03_11-12-54_3.png


3. Double-click on the column and adjust the properties, for example the class and the top of the column, next click Modify:

Image
2019-09-03_11-16-31 - kopie.png


The properties in the dialog box are retained automatically. Tekla Structures uses the current values for the next objects of the same type. Click the command Column and pick a column in the model:

Image
2019-09-03_11-19-46_0.png


Customize
 
Use to open the Property pane editor and customize the property pane layout.
 

Updates in the Property pane editor

Set property groups hidden or visible
 
You can define whether the property groups in the property pane are visible or hidden by default.

For example, if you are an administrator, you can create property groups for different user-defined attributes (UDAs) in the Property pane editor, and then set the default visibility for each of the property groups.

1. In the property pane layout on the right, select the property groups you want to hide.

2. Right-click and select Hide by default.

The eye symbol changes to hidden:
Image
2019-08-27_10-45-53_2.png
. The selected property groups are now by default hidden in the property pane.

To have the property groups again by default visible in the property pane, right-click and select Show by default.

The eye symbol changes to visible:
Image
2019-08-27_10-45-41_2.png
. The selected property groups are now by default visible in the property pane.

Note that visibility changes in the property pane override the default settings defined in the Property pane editor.

Copy multiple property groups
 
In the Property pane editor, you can now select multiple property groups to be copied.

1. In the property pane layout on the right, select the property groups to be copied.

2. Right-click and select Copy properties or click
Image
2019-08-27_13-10-27_0.png
.

The copied property groups and the nested groups inside the property groups are shown in the middle column.
The copied property groups are expanded and the content of the groups is shown.

3. Add the copied properties to a property pane layout by dragging the Copied properties box from the middle column to the property pane layout on the right.

All the copied property groups are added to the property pane layout as they are. Previously, the copied properties were nested inside a Copied properties container.

Additionally, when you add copied properties to the property pane layout and the property group would be empty as a result of duplicate or incompatible properties, the group is not created at all. Previously, an empty Copied properties container was created without any properties.
 

Improved search in the property pane

Search in the property pane has been improved. Now the search finds all the properties and user-define attributes (UDAs) that are available for the object type.

Image
2019-09-19_13-42-54.png


If you have several object types selected in the model, the search finds properties that are common to all the selected object types. UDAs that match to the search criteria are shown even if they have not been added to the property pane layout. This means that you can view and modify the UDA values in the property pane without customizing the property pane layout.

Properties and UDAs that are not included in your current property pane layout are listed in the Additional matches property group.
 

Create and modify items

In Tekla Structures you can import and use items, especially for modeling complex 3D objects (shapes), for example roof tiles, pipe supports or anchors:

Image
2019-08-30_13-51-23.png


Items are similar to other parts in Tekla Structures, such as beams and columns. The main difference between items and other types of parts is that a 3D shape defines the geometry of an item, whereas a part has a 2D profile that is extruded to create the length of the part.

In addition to importing item shapes or downloading them from Tekla Warehouse, you can now create shapes using existing geometry and parts in Tekla Structures models. For example, you can create a shape using a single part or several parts that have been attached to each other.

Create an item

We want to be able to use a purlin support profile in Tekla Structures. It starts with a number of 5 single (contour) plates including holes. We will attach the single plates to each other and next we will create an item to be able to use the purlin support profile as one part in Tekla Structures:

Image
2019-08-30_11-17-57.png


To create an item like this, you can do next:

1. Model five single (contour) plates including the holes in Tekla Structures:

Image
2019-08-30_13-36-54.png


The name of the bottom plate (in this case PURLIN SUPPORT) will be used later as the name of the item.

2. Attach the single plates by using command Added material > Attach to part in tab Edit: first select the plate to attach to (1) and next the four plates to be attached (2):


Image
2019-08-30_13-33-17.png



3. Click middle mouse button, the parts are attached:

Image
2019-08-30_13-42-49.png


4. Select the combined part and click right mouse button, next select command Create shape from geometry, the item is created and added automatically to the shape catalog (via File menu > Catalogs > Shape catalogs), the name of the bottom plate is now used as the name of the item:

Image
2019-09-20_13-19-07.png


You can now use this item in your Tekla Structures models.

5. Double-click the command Item on tab Steel or Concrete, dialog box Item appears:

Image
2019-09-20_13-23-43.png


6. Click the button
Image
2019-08-30_14-04-40.png
to select an item in the Shape catalog, the following dialog box appears:

Image
2019-09-20_13-28-47.png


7. Select the item PURLIN SUPPORT and click OK.

8. Pick two points in the model, the item is created.

Modify an item

In Tekla Structures 2019i you can now modify the item's geometry after they have been created. You can move item vertexes (corner points), edges, and faces by dragging them.

To modify the geometry of an item:

1. Go to Quick Launch and search for Enter geometry editing mode command:

Image
2019-09-20_13-44-10.png


2. Select the command.
 
3. Select the item whose geometry you want to modify: the Geometry editing tab appears at the right end of the ribbon:

Image
2019-09-20_13-49-03.png


4.You can now modify the shape of the item:

Image
2019-09-09_08-43-21_0.png

 
5. To save the modified shape, click
Image
2019-09-06_16-35-16.png
and select one of the options in the dialog box:

Image
2019-09-20_13-54-30.png


6. Click Save, Tekla Structures updates the items in the model and saves the shape in the shape catalog.

When you save the modified shape in the shape catalog with a new name, you might want to delete the old ones form the shape catalog. For this, you can use the tool Shape cleaner in the Applications & components catalog:

Image
2019-09-20_13-58-45.png


The temporary shapes that were created during the editing process will be deleted from the shape catalog when you save the model if the shapes are not used by any item.

Click here for more information about modifying items.
 

Improved representation for welded L profiles in model views

Since Tekla Structures 2018i the representation for welded plates in model views has been improved: welded plates color light blue, loose plates don't:

Image
2018-08-10_15-46-04.png


Since Tekla Structures 2019, also the representation for welded RHS profiles has been improved:

Image
2019-01-18_11-29-46.png


In Tekla Structures 2019i also the representation for welded L profiles has been improved:


Image
2019-07-12_15-41-32.png



If desired, you can customize the default model view settings (even further) to represent RHS profiles or L profiles till a specific length, for example:

Image
2019-09-23_08-47-45.png


 

Snapping improvements

Tekla Structures 2019i introduces new colors and other visual cues for snapping. Also, the behaviour of the orthogonal snapping has been slightly changed.

Orthogonal snapping has lower priority among the snap points than previously

The behaviour of the Ortho tool has been changed. Now the orthogonal snap points have the lowest priority among the snap points. If Tekla Structures detects any other possible snap point than an orthogonal point, Tekla Structures uses the found snap point instead of the orthogonal snap point. If there are no other possible snap points found, then Tekla Structures uses the orthogonal snap point.
 

Snap tooltips for snap points

Now when you start a command that requires picking points and you move the mouse pointer over objects in the model, Tekla Structures displays a snap tooltip that shows the name of the snap point:

Image
2019-07-19_10-19-09.png


To show or hide these snap tooltips, click File > Settings and select the Snap tooltips check box.
 

Snapping color changes

The colors related to snapping have been enhanced to make the snapping easier and more accurate.

When the Ortho tool is active and you start a command that requires snapping to two or more points, for example a beam or polybeam, Tekla Structures displays a rubber band line between the last point picked and the snap point:

Image
2019-09-04_11-30-20.png


The color of the cursor, line, and the angle symbol follows the color of the work plane axis: red for x-axis, green for y-axis and blue for z-axis:

Image
2019-09-04_11-39-16.png


For any other direction the line between the last point picked and the snap point and the cursor is grey.
 

Setting the temporary reference point by using a right-click command

In Tekla Structures 2019, the handling of temporary reference point information was changed. Starting from Tekla Structures 2019, the reference point information is cleared when you interrupt a command. If you wanted to use the reference points in Tekla Structures 2019, you had to set the reference point manually by pressing the Ctrl key and picking a point when you run a command.

Now in Tekla Structures 2019i, you can set the temporary reference point also by right-clicking when a command is running and selecting the Define temporary snap reference point option. If you use the Define temporary snap reference point command, you need to activate it for every reference point you pick:

Image
2019-07-19_09-04-04.png


To define a temporary reference point:

1. Start a command that requires snapping to points, for example the command Create steel beam.
2. Click right mouse button and select the command Define temporary snap reference point.
3. Pick the position of the temporary snap reference point, a grey cross indicates the temporary snap reference point.
4. Pick the first position of the beam.
5. Pick the second position of the beam.
 

New part types: lofted plate and lofted slab

Tekla Structures 2019i introduces new part types: steel lofted plate and concrete lofted slab:

Image
2019-09-19_09-30-01.png


Use lofted plates to model rolled plates and plates with double-curved form, for example. Use lofted slabs to model curved and double-curved slabs or walls, for example.
 
Before you can create lofted plates or lofted slabs , you need to have construction objects in your model. Tekla Structures creates the shape of the lofted part according to the geometry of the used construction objects.
 
You can connect the following construction objects as a lofted plate or a lofted slab:

Two construction linesA construction line and
a construction arc
Two construction arcsTwo construction circlesA construction object
and a point
Image
2019-08-23_10-01-58.png
Image
2019-08-23_10-03-04.png
Image
2019-08-23_10-04-08.png
Image
2019-08-23_10-05-18.png
Image
2019-08-23_10-06-49.png

Create a lofted plate or a lofted slab

1. Create the needed construction objects in the model. The shape of the lofted part is based on the construction object shape.
 
2. Depending on whether you are creating a lofted plate or a lofted slab:
  • On the Steel tab, click Plate > Create lofted plate
    Image
    2019-08-23_12-08-22.png
    .
  • On the Concrete tab, click Slab Create lofted slab
    Image
    2019-08-23_12-10-54.png
    .

3. On the toolbar that appears
Image
2019-08-23_12-14-54.png
, click a button to specify whether to create the part by using two construction objects, or by using a construction object and a point.
  • If you selected Using two construction objects
    Image
    2019-08-23_12-14-54 - kopie.png
    :
a. Select the first construction object: line, arc, or circle. For example, if you are using two construction circles to create a lofted plate:

Image
2019-08-23_12-24-34.png


b. Select the second construction object:

Image
2019-08-23_12-29-00.png


Tekla Structures creates the lofted plate between the selected construction objects.

Image
2019-08-23_13-08-28.png
  • If you selected Using one construction object and a point 
    Image
    2019-08-23_13-16-46.png
    :
a. Select the first construction object: line, arc or circle. For example a construction line and a point. Tekla Structures shows a preview of the part geometry. Use the preview to set the direction and the height of the lofted part:

Image
2019-08-23_13-40-55.png


b. Pick a point:

Image
2019-08-23_13-47-36.png


Tekla Structures creates the lofted slab based on the preview.

Image
2019-08-23_13-48-26.png


 
4. If you want to modify the shape of the lofted part, use the direct modification dimension handles and dimension values. For example:
Image
2019-08-23_13-28-54.png

 
If needed, you can split lofted parts. You cannot split closed cylindrical or conical lofted parts. Use the Split command on the Edit tab.

Limitations

In some cases when you try to create a lofted plate or a lofted slab by using construction lines, arcs, or circles, the geometry of the part would become self-intersecting:

Image
2019-08-23_13-54-34.png


In these situations, the part is not created and Tekla Structures displays the following status bar message: The resulting surface would be self intersecting. With construction lines or arcs you can try to resolve the situation by changing the modeling direction of the construction lines or arcs. Select the construction line or arc, and on the contextual toolbar click Swap ends
Image
2019-08-23_13-57-20.png
. With construction circles you can try to resolve the situation by moving either of the circles.

Filtering lofted plates

You can now use the new template attribute IS_LOFTED_PART in filtering lofted plates, for example to check whether the part is a lofted part.

Image
2019-09-19_09-52-04.png


Click here and here for instruction videos about over lofted plates.

Toolbar Model search

Tekla Structures 2019 already included the toolbar Model search to quickly search for objects in the entire model:

Image
2019-02-05_09-03-30.png


Tekla Structures searches for name, material, part position number or assembly position number of model objects: matching model objects are automatically selected in the model view. You can also use wildcards for searching.

In Tekla Structures 2019i (but also from Service Pack 1 for Tekla Structures 2019 on) you can also search within the selected model objects:

Image
2019-07-16_14-24-13.png


Click here for more information.

Click here for an instruction video.

Clash check for welds

When you run a clash check using Tekla Structures 2019i, you can check the model for duplicate and overlapping welds and for clashes that occur between welds and other objects such as parts and bolts. To set this functionality before checking the model, go to File menu > Settings > Options to open the Options dialog box. Set the option Exact solid weld clash check to Yes:

Image
2019-09-18_13-32-29.png


If necessary, adjust the other clash check settings and next run the clash check:

Image
2019-08-30_10-06-40.png

View angle functionality for model views, assemblies and components in the contextual toolbar

Tekla Structures already included the view angle functionality in the contextual toolbar for many parts (such as columns, beams, plates, walls, slabs, footings, etc.):

Image
2019-09-23_09-16-31.png


Starting from Tekla Structures 2019i, you can now show model views, assemblies, system components (not for system components Detail types) and custom components (not for custom components Detail and Seam types) in different view angles.

TIP: When you use the view angle functionality for assemblies, for example, it might be handy to predefine that only the selected assembly is shown (via right mouse button and select Show Only Selected). If you next use the view angle functionality, only the concerned assembly is shown.

Click here for more information about showing and hiding objects.



Model views:

Image
2019-07-16_11-05-05.png


Image
2019-07-16_11-06-15.png


Assemblies and components:

Image
2019-09-02_15-10-02_0.png


Click here for more detailed information about the usage of the view angle functionality.

 

System components

Tube gusset (20) and Tube crossing (22)

System components Tube gusset (20) and Tube crossing (22) now include a new option on tab Brace conn to define the position of the end plate in the middle:

Image
2019-09-17_13-21-34.png


 

Railings (S77)

You can now define separate top- and bottom rail settings for positioning in system component Railings (S77) on tab Rails:

Image
2019-09-17_13-30-17.png


and for middle rails on tab Middle Rails:

Image
2019-09-17_13-31-44.png


 

Rectangular area reinforcement (94)

Tekla Structures 2019i now includes a new system component Rectangular area reinforcement (94) to reinforce rectangular areas:

Image
2019-09-17_13-34-32.png


Image
2019-09-02_13-23-45.png


 

Concrete console (110) and Concrete console (111)

You can now enter 79 characters in the field Comment for Tube bottom on tab Connection (system component Concrete console (110)) and tab Anchor (system component Concrete console (111)) . You could only enter 19 characters in earlier Tekla Structures versions:

Image
2019-09-17_13-36-52.png


Please check the settings for these system components that you have made in earlier Tekla Structures versions. The content of these settings may be incorrect as a result of this change in the mentioned fields. Our advice is to check and update the settings for Tekla Structures 2019i.
 

Corner welded plate (114)

Tekla Structures now includes the new system component Corner welded plate (114) for modeling a (specific) corner welded plate:

Image
2019-09-26_13-56-39.png

 

Welded gusset (115)

Tekla Structures now includes the new system component Welded gusset (115) for modeling a (specific) welded gusset:

Image
2019-09-26_13-58-27.png

 

Footplate (29) and Footplate (1029)

Since Tekla Structures 2018 you have an option on tab Anchor rods to add parts (created as a custom component Part) as a subassembly:

Image
2019-09-17_14-01-40.png


Caps for the anchors for example are used to keep the anchor free from concrete while casting:

Image
2018-03-13_11-15-42_0.png


You can set the option Add as assembly as follows:

NoTo cast plateTo foot plate
Image
2018-03-13_11-48-21_4.png
Image
2018-03-13_11-51-57_4.png
Image
2018-03-13_11-56-41_1.png

The position of these custom component parts was not always correct. This is now fixed:

Image
2019-09-17_14-27-50.png


...to position these correct:

Image
2019-09-03_11-54-07.png


 

Custom components

Availability of cast-in embeds

Tekla Structures 2019 included the folder
 
C:\TeklaStructures\2019.0\Environments\construsofteuropean\Precast\ComponentsSketches\CustomComponentParts
 
in which many cast-in embeds from several suppliers (such as Demu, Halfen, etc.) were stored as so-called cucopa's (custom component parts). You could use these to model cast-in embeds:

Image
2019-09-17_14-39-14.png


(In earlier Tekla Structures versions: C:\TeklaStructures\<version>\Environments\netherlands_enu\components_sketches\concrete\CustomComponentParts).
 
In Tekla Structures 2019i the folder no longer exists because suppliers now offer their own products on Tekla Warehouse:

Image
2019-09-04_16-46-32.png


The suppliers now maintain their own assortment, the main advantage is that only available cast-in embed are used in Tekla Structures from now on. The suppliers are (of course) responsible for their own products.
 

Drawings

Improvements in Document manager

Document manager includes several improvements in Tekla Structures 2019i.

New button Show all documents

A new button Show all documents has been added to Document manager:

Image
2019-09-20_15-07-15.png


This button resets the document list so that all documents are visible, and all searches and filtering are cleared. Excluded categories remain excluded. This new feature also provides a convenient way to restore the document list to a default state when recording macros.
 

New category association options

Since Tekla Structures 2018i you can use categories for drawings, files and documents in the Document manager. You can add new categories by using a search string (filter):

Image
2019-09-23_10-05-18.png


and select drawings, files and documents and categorize these manually, for example drawings because of additional work:

Image
2019-05-10_15-48-26.png


This option is handy for documents that would be difficult to categorize or in case there is no category available. You can categorize manually or by search.

In Tekla Structures 2019i, the Edit category and New category dialog boxes in Document manager now have a new setting Association type, which defines if a category is search based, manual, or both:

Image
2019-09-23_10-24-57.png


If the category is of type Search only or Manual and search, you need to define a Search string in the dialog box:

Image
2019-09-23_10-27-05.png


If you create a category by first selecting documents from the documents list, the association type is Manual only by default. If you create a category from the category list, the association type is Search only by default.

You can change the association type later. If you change the type from Search only to Manual only, a message is displayed telling that the search string for that particular category will be cleared. If you change the type from Manual only to Search only or Manual and search, you need to define a Search string.
 


Click here for more detailed information about Document manager.

Click here for a video about Document manager.
 

Speed improvements in drawings

Tekla Structures 2019i includes several improvements regarding to the speed in drawings.
 
Opening drawing that include many drawing objects (such as GA drawings), zooming in drawings, panning and dragging drawing views works much faster and smoother.
 

Drawing view frames hidden

The drawing view frames are now hidden until you move the cursor over the view. If you select a view, the drawing view frame stays visible:
 
Tekla Structures 2019 and earlier:

Image
2019-09-23_10-54-47.png


Tekla Structures 2019i:

Image
2019-09-23_11-00-34.png


To show drawing view frames in printed and exported drawings, set XS_PLOT_VIEW_FRAMES to TRUE (via File menu > Settings > Advanced options category Printing). FALSE is the default value. This advanced option is model specific and the setting is saved in the options database.
 

Printing to multiple printers and other printing improvements

Starting from Tekla Structures 2019i, you can print to more than one printer in one go based on the paper size of each selected drawing. When printing to multiple printers you typically have different printers for handling different paper sizes. Tekla Structures automatically selects the appropriate printer for each drawing.
 
Print drawings to multiple printers in one go
 
The Print Drawings dialog box now has a new control for printing to multiple printers: Use multiple printers. When you want to print to a single printer or define single printer settings to be used in multiple printing, select Use one printer.

Image
2019-09-23_11-13-17.png


Create single printing settings
 
To print to multiple printers, you first need to create single printing settings for each of the printers you want to print to:
 
1. Select Use one printer and define the printing properties as desired. Select the output type and printer and define the paper size that this printer will handle in the Use multiple printers mode. Then give the settings a unique name and click Save. Repeat this for each of the desired paper sizes. Do not use the size option Auto.
 
For example, you can create the following single printer settings files with the output type set to PDF file:
 
A0: Paper size set to A0, file prefix set to A0_
A1: Paper size set to A1, file prefix set to A1_
A2: Paper size set to A2, file prefix set to A2_
A3: Paper size set to A3, file prefix set to A3_
A4: Paper size set to A4, file prefix set to A4_
 
2. When printing a set of drawings in the multiple printers mode using the above single printer settings files, all A4 drawings will generate .pdf files with prefix A4_, all A3 drawings will have prefix A3_, and all A2 drawing will generate .pdf files with prefix A2_.
 
3. If you want to print more than one sheet size to the same printer in the Use multiple printers mode, create a single printer settings file for each paper size, and specify the same printer in all of these files.

Image
2019-09-23_11-23-40.png


Print to multiple printers
 
Change to the Use multiple printers mode and in the Selected single printer settings files list, select the settings files to use in printing. You can select all or just some of the single printer settings files.

Image
2019-09-23_11-27-47.png


The output type (printer, plot file, PDF file) is defined by each selected single printer settings file. Typically you would select settings files with the same output type. Output types lists the output types that are specified in the selected single printer settings files.

Image
2019-09-23_11-42-29.png


Change other necessary settings. When the output type of the selected settings files is Plot file or PDF file, you can change the following properties. These settings cannot be changed if the output type is Printer:
 
- File location: Where to create the output files. If the selected settings files specify a subfolder, then the output path is the combination of the main path and the subfolder path, which allows each settings file to specify a different subfolder. You can also specify an absolute path in each selected settings file, which will override the main path.

Example:

Main path: .\Plotfiles

Settings file 1 subfolder path: A4

Output result for settings file 1: .\Plotfiles\A4\

- Include revision mark to file name

- File prefix

- File suffix

- Fit to paper

- Scale


- Center drawing on paper

- Print on multiple sheets

- Orientation

- Number of copies

- Collate

Note that you cannot change the paper size, it is already included in the selected settings files. You can see the selected paper sizes listed in the dialog box.

You can also save the multiple printing settings to a settings file for future use. Note that the multiple printing settings files are saved in the same location as the single printer settings files (<model>\attributes) but with a different file name suffix PdfMultiPrintOptions. For single printer settings, the suffix is PdfPrintOptions. This ensures that the settings are kept separate from the single printer settings.
 

New leader line options for reinforcement group marks

Tekla Structures 2019i includes two new leader line options for reinforcement group marks. It is now possible to create marks with perpendicular leader lines to reinforcement group plane, to all rebars in a group, and to the first and last rebar in a group:

Image
2019-09-23_12-09-02.png


The new options are available in cast unit and general arrangement drawings.

You can control the length of the perpendicular leader line with the new advanced option XS_MARK_LEADER_LINE_LENGTH_FOR_PERPENDICULAR (File menu > Settings > Advanced options > Marking: General). The default value is 0 mm.

Note that rebar mark leader lines created with the new options are always placed horizontally or vertically in a drawing, even in tapered rebar groups.

Earlier Tekla Structures versions:

Image
2019-08-22_13-50-12.png


Tekla Structures 2019i:

Image
2019-08-22_13-50-24.png


You can select to apply the new leader line options in the following locations:

- Before you create a cast unit drawing, in the cast unit drawing properties for each view separately: Select the view in cast unit drawing properties, click View Properties and click Reinforcement mark or Neighbor reinforcement mark from the options tree.
- Before you create a GA drawing, in the drawing properties of the GA drawing: Click Reinforcement marks... or Neighbor reinforcement marks... in the GA drawing properties.
- In the view properties of an existing drawing: Double-click the view frame and click Reinforcement mark or Neighbor reinforcement mark in the options tree.
- In reinforcement mark properties in an open drawing: Go to Drawing > Properties > Reinforcement mark.
- In reinforcement mark properties for an individual reinforcement group mark: In an open drawing, double-click an individual reinforcement group mark. To select and modify the properties for several reinforcement group marks, use Drawing content manager or select the reinforcement group marks using appropriate selection filters.
 

New settings for section views

In single part, assembly and cast unit drawings on the Attributes tab of the Section view properties, there is a new Size check box for the new Fit by parts setting and the existing settings Section depth and Distance for combining cuts:
 
Tekla Structures 2019i:

Image
2019-09-23_12-26-46.png


Tekla Structures 2019:

Image
2019-09-23_13-04-50.png


Now you can set Fit by parts for all section views in drawing properties before creating a drawing. Earlier, you had to open each drawing and manually readjust view depth for each section view in the opened drawing .
The Fit by parts setting works as an alternative to Section depth and Distance for combining cuts and it shows the whole part in the sections. If you select this setting in Section view or End view properties in an existing drawing, it overrules the drawing level setting.
 

Tools/plugins

CS ML012 - Saw Report

Tool CS ML012 - Saw Report is moved to Tekla Warehouse and therefore no longer available in Tekla Structures by default.

Image
2019-09-23_13-54-58.png


You can use the tool CS ML012 - Saw Report for generating a saw report. The report contains profile dimensions and pictures of cross sections and main views. You can open the report in Microsoft Excel.

TIP: Don't forget to set an alert in Tekla Warehouse for the tool to get informed automatically in case the content changes or if a new version is available.
 

Part to part fitting (j003)

For many versions, Tekla Structures includes plugin Part to part fitting (j003):

Image
2019-09-23_13-59-43.png


You can use the plugin for fitting and/or cutting parts (wooden beams or walls, steel plates or beams) connecting to each other. You can fit the profiles in several ways and also use a mitre. You can also define a seam and you can connect parts (cast unit, sub-assembly, welding).

Plugin Part to part fitting (j003) has been extended in Tekla Structures 2019i. Because of this, several settings for system component Crancked beam (41) are no longer available when you start Tekla Structures with the role Timber Detailer. System component Crancked beam (41) now only includes some default settings.
 

Wood wall on panel (m082)

Tool Wood wall on panel (m082) is moved to Tekla Warehouse and therefore no longer available in Tekla Structures by default.

Image
2019-09-23_14-15-51.png


You can use the tool to position a wooden frame on the outer contour of a solid-(concrete) shape:

Image
2019-07-15_10-54-23.png


Suppose that you know the final full contours (both externally and internally) of wooden elements to be generated because they were generated in the engineering phase as a simple solid (concrete) form, for example. In other cases, this form has already been determined in other software and imported an IFC-file as a reference model in Tekla Structures. In that case, these volumes can be quickly converted to actual timber frame elements by using the Wood wall on panel (m082) tool.
 
When the tool Wood wall on panel (m082) is applied, the contour of the solid shape is automatically scanned and the wooden frame is positioned on it. For this, system component Wood wall (57) and the associated settings are used:

Image
2019-09-24_09-04-56.png


System component Wood wall (57) is included in the Construsoft developments. You must therefore ensure that they are installed so that system component Wood wall (57) can be used. If the Construsoft developments are not installed, the following message appears:

Image
2019-09-06_11-40-43.png


For more detailed information about the tools, see the corresponding Help.
 

Electra sockets (m083)

Tool Electra sockets (m083) is moved to Tekla Warehouse and therefore no longer available in Tekla Structures by default:

Image
2019-09-23_16-24-29.png


Image
2019-09-05_15-07-56_0.png


You can use the tool Electra sockets (m083) to model electra sockets (boxes and tubes) in a wooden element. The position of the box and the tubes on the wall was not correct in some case. This is now fixed.
 

CS Timber Operation Marking (m116)

You can now use the new tool CS Timber Operation Marking (m116) in Tekla Structures 2019i:

Image
2019-09-20_16-20-54.png


The tool is available in Tekla Warehouse and you use the tool for marking the position of the secondary parts. The tool is compatible with the export to Hundegger, H&M and BTL machines.

Image
2019-09-20_16-25-32.png


You can define the part type to be used for marking in tool CS Timber Operation Marking (m116):

Image
2019-09-24_10-24-54.png


When you use the option As reinforcement, this has a positive effect on the speed compared to the option As beams. In addition, reinforcement is not included in the number of parts in the model. This is advantageous if you work with a Primary license (where the number of parts in the model is limited).
 

CS TO Tenon And Mortise (j150)

You can now use the new tool CS TO Tenon And Mortise (j150) in Tekla Structures 2019i:

Image
2019-09-20_16-09-55.png


The tool is available in Tekla Warehouse and you use the tool for modelling tenon and mortise connections between two beams, regardless of whether they are at an angle or in line with each other. The tool is compatible with the export to Hundegger and BTL machines.

Image
2019-09-20_16-13-09.png


Image
2019-09-20_16-13-45.png

 

CS TO Dovetail Tenon And Mortise (j151)

You can now use the new tool HCS TO Dovetail Tenon And Mortise (j151) in Tekla Structures 2019i:

Image
2019-09-20_15-59-44.png


The tool is available in Tekla Warehouse and you use the tool for modelling dovetail connections between two beams, regardless of whether they are at an angle or in line with each other. There are many parameters available to adjust the shape of the dovetail, depending on the tools that can be used on your machine. The tool is compatible with the export to Hundegger and BTL machines.

Image
2019-09-20_15-58-28.png


Image
2019-09-20_15-59-05.png


 

Was this helpful?