I have a Validation > Model > General > "Member intersection" error. How do I resolve it?

Tekla Structural Designer
Not version-specific
Tekla Structural Designer
Validation-Model-General
validation
Member Intersection
Environment
Australia
British Standard
Eurocode
India
USA
Not environment-specific

A Member intersection is a model validation error that can occur if two members have crossing centrelines.

A member could be a beam, column or brace. In the example below we are looking at a beam, however, the resolution is the same regardless of the member type.

In the screenshot below, the Status window is reporting two members with an intersection issue. SB 1/~15-1/1/'29 : SB 1/A/2-1/B/2

Double clicking this branch highlights both members in the active Scene view.

 

Image
image.png


Double clicking the individual members listed under this branch highlights each in turn. This perhaps provides a little more detail on the issue. Since "members intersect", one member must extend beyond the other and hence they cross each other.

 
Image
image.png


 
Image
image.png


To understand the issue further we need to look at the location where the two members meet.

We can see in the screenshot below (rotated view), that the highlighted member passes through the other. This secondary member should be supported on the primary member. Hence, to resolve the issue, we need to relocate the end of this secomdary member so that the end support is at the intersection with the primary member.

 
Image
image.png


Note that the view above displays the physical shape, it may be easier to use Scene Content and turn off Geometry to display only the centre wire.

 
Image
image.png


 
Image
image.png














To resolve the Member intersection validation error you need to click on the end node to pick it up and then click on the intersection point with the primary beam.
The example below also moves the adjacent beam to the correct support location.

 
Image
Movenode.gif


Once the member is removed from the model, if you run the Validate command again the issue will be resolved and no longer be flagged.

Was this helpful?