Contact Tekla support via the Support tool

Tekla Structural Designer
Tekla Tedds
Tekla Tedds for Word
2021
Tekla Structural Designer
2020
Tekla Tedds Tekla Tedds for Word
2020
Tekla Structural Designer
2019
Tekla Tedds Tekla Tedds for Word
2019i
Tekla Structural Designer
2019
Tekla Structural Designer
2022
Tekla Structural Designer
2022
Tekla Tedds Tekla Tedds for Word
Support tool
help

The Support tool allows you to contact Tekla support directly. With this tool you can collect the Tekla Structural Designer model, related files, and other necessary information or the active Tekla Tedds file in one support request, and safely upload your request to Tekla support.

The Support tool:

  • Automatically identifies the open active document and attaches it to your request.
  • Automatically gathers application and system information.
  • Uploads the problem description, attached file, and all other gathered information to Tekla support.

 

NOTE:

Confidentiality information
All files you upload are treated as confidential. Only the recipient can access the files.

Tekla Structural Designer: Create a support request

  1. The Support tool can be accessed via Tekla Structural Designer
    • From File menu, click Help menu > Contact Support
     
    Image
    image.png
  1. Log in using your Trimble Identity.
    • The Support tool opens and automatically fills in user, application and Tekla Structural Designer version information. Support tool reads your name, email address, company name and support email address from your Trimble Identity profile.
    • You can switch to another account by clicking Switch user.
  2. Select a category from the list of predefined categories that most closely describes the type or area where you are having the issue.

 

Image
image.png
  1. Enter the problem description.
  2. Click Next.
  3. Select what you want to attach. The file name, file group, file size, and file location are mentioned for each file.
    • Select the All check box, or select specific files from the Select the files list.
    • If you want to send some attachments other than shown in the Select the files list, click the Add extra files button and browse for the files.

 

Image
image.png


 

  1. Click Next.
    • The Support tool creates the package and shows the total attachment size. You can also check application information and operating system information before finalising the support case creation.

 

Image
image.png

 

  1. Click Create case to upload your case to Tekla support.

When the upload is complete, you will receive a notification to your email address. After a successful upload, an automatic confirmation message will be sent to you, and then Tekla support will start solving your case.

Tekla Tedds: Create a support request

  1. The Support tool can be accessed via Tekla Tedds and Tekla Tedds for Word
    • From Tekla Tedds, click Help menu > Contact Support
    Image
    support-tool-tekla-tedds.png
     
    • From Tekla Tedds for Word, Click Tedds menu > Help > Support 
    Image
    support-tool-tekla-tedds-for-word.png
     
    • Please note, the Support button on the left hand side of the Tedds calculation interface does not use the Support tool.
  1. Log in using your Trimble Identity.
    • The Support tool opens and automatically fills in user, application and Tekla Tedds version information. Support tool reads your name, email address, company name and support email address from your Trimble Identity profile.
    • You can switch to another account by clicking Switch user.
  2. Select a category from the list of predefined categories that most closely describes the type or area where you are having the issue.
Image
support-tool-01.png

 

  1. Enter the problem description.
  2. Click Next.
  3. Select what you want to attach. The file name, file group, file size, and file location are mentioned for each file.
    • Select the All check box, or select specific files from the Select the files list.
    • If you want to send some attachments other than shown in the Select the files list, click the Add extra files button and browse for the files.
Image
support-tool-02.png

 

  1. Click Next.
    • The Support tool creates the package and shows the total attachment size. You can also check application information and operating system information before finalising the support case creation.
Image
support-tool-03.png

 

  1. Click Create case to upload your case to Tekla support.

When the upload is complete, you will receive a notification to your email address. After a successful upload, an automatic confirmation message will be sent to you, and then Tekla support will start solving your case.

Was this helpful?