Connection problems with Multi-User server
Question:
We are having problems connecting to the multi-user server. In the session log, we can see errors like this: “Fatal error: dbm_connect (…), tcpip: …) failed (error 9)”. What does this mean and what should we do?
Answer:
The dbm_connect error is related to connecting to the database, in this case the multi-user server and the multi-user models. The error 9 means "duplicate client" and it is displayed because the server still thinks that the first connection is alive. Please check if there are users having several connections open to the same model.
The warning/error can be safely ignored (as long as there is less than 9 users with same username - which is usually the case).
What causes duplicate users?
It is possible to get duplicates in at least these ways:
1. Duplicate users are most likely caused by connection breaks.
This can happen if there are too short timeout settings on the firewall or router. The timeout should be "long enough" or infinite, if possible.
2. Someone else is already using the server with the same username or as "Administrator" (or something similar)
It is possible to kick out those users from the Active Multi-user list.
3. The error 5 and error 125 can also result in duplicate users
error 5= connection broken (for example a longer network break or firewall cutting the connection in case of long inactivity)error 125= connection badly broken, reconnect needed.