3. ProNest Initial Setup

Tekla EPM
Not version-specific
Tekla EPM Tekla EPM GO

ProNest Integration Setup

These tasks must be performed before using the ProNest Integration.

Verify that ProNest and DataSync are working

If you're not sure that they're working, refer to the Pre-Setup requirements task list.

Enable ProNest Integration

  • On the Tekla EPM Maintenance Menu, select Integration Settings, then ProNest
Image
3_1.png
  • Check Enable ProNest for Plate Nesting. This adds the option to send the inventory to ProNest, and adds ProNest as a choice of nesting software for a combining run.
Image
3_2.png
 

Nesting Request File Format

A nesting request can be sent either using the Work Order service, or the PNL/SNL file exchange.
Image
3_3.png
  • The Work Order format allows sending of the parts list in a single click - It will automatically import to the Parts List in ProNest and be available for nesting.
  • The PNL/SNL format allows sending of both the parts list and the available inventory. It will create a set of two files with the same name (one having a .pnl extension, and the other a .snl). Opening the PNL file with ProNest will import the parts, select them for nesting, and set the "Plate List" (available inventory for this nest) to the plates contained in the SNL file.

Database Connection Tab

In order to keep Inventory in Sync, EPM reads the ProNest database. On this tab, we create and test a connection to the ProNest database.
Image
3_4.png
  • IP address is MachineName\PRONEST by default. The machine name must be the machine with ProNest on it (this is not necessarily the machine with EPM). From within ProNest, File->Help use the contents of the Database: field.
  • Click "Test Connection". If it does not successfully connect, check ProNest to see if the database is Networked, or double-check the machine name.
Image
3_5.png

Inventory Sync Tab

Image
3_6.png
Image
3_7.png

  • The "Inventory Sync Folder" must be readable (and writable) by both EPM and ProNest, so if they are on different computers, it must be a shared folder.
  • "Data Sync Command Path" is the path to the DataSyncCmd.exe that you added to the EPM workstation (or perhaps the server) in the Pre-setup tasks.
  • "Inventory Sync Timeout" is the amount of time that FabSuite will wait for a non-responding Data Sync. 3-5 minutes is usually sufficient. (Just enter a number, the "minutes" will be automatically filled in)
  • Material Display Format: must match ProNest Regional Preferences
  • "Last Inventory Sync" shows the date and time of the last successful inventory sync.
  • "Last Inventory Sync Error:" shows the error that Inventory Sync encountered (if any).
  • "Show File Location Errors for Cut Lists:" shows errors related to the location of the machine file that ProNest produces.
  • "Import Cut List before Inventory Sync:" Check this to receive updates on what is cut before running inventory sync (checked is recommended).
  • "Sync Material On Order:" Uncheck this to avoid sending material that is not yet received.
Come back to this after you're satisfied with the setup and field mapping:
  • Enable Automatic syncing by checking the "Enable Automatic Inventory Sync:" check box.
  • Select an interval for running the Inventory Sync task. This interval should be frequent enough to keep your Inventory in sync, but not be constantly running. 10-60 minutes is probably ideal. (Just enter a number, the minutes will be automatically filled in).
  • They can also do this with an automated event, and the Automated event is the preferred workflow.

Transfer Settings Tab

Image
3_8.png

Five fields in EPM are mappable to fields in ProNest. They are:
  • Remnant ID: This is a unique ID that EPM assigns to each remnant. It will not change once assigned, and can be made visible in both EPM and ProNest by mapping this field to a ProNest field.
  • Heat Serial Number Field: The Heat Number of an inventory item automatically maps across to ProNest. If you also use the Heat Serial Number field, map it here.
  • PO Number Field: This allows you to see what PO an inventory item is on from ProNest.
  • Bill of Lading Field: If you use this field in EPM, you may also want to see it's contents in ProNest.
  • Secondary Location Field: The Location of an inventory item automatically maps across to ProNest. If you also use Secondary Location, map it here.

Set ProNest Grade and Size Designations

Sending nesting requests from EPM to ProNest requires that the two software packages agree on the name and thickness of each type of plate included. In EPM, most plate is labeled "PL". In ProNest, plates can be "MS", "AL" or "SS" (or some others), depending on the grade. In order to accommodate this difference, EPM includes a "ProNest Designation" for each grade.
  • Open Shapes/Grades/Sizes from the maintenance Menu.
Image
3_9.png
  • Select "Plate" on the left, and "Grades" on the top middle.
For each Grade:
  • Click "Edit Grade"
  • Under "ProNest Shape Designation" enter "MS" for any grade that is Steel (MS = Mild Steel), "SS" for any grade of Stainless Steel, and "AL" for any grade of Aluminum. If you regularly use plate that does not fall into these three categories, contact your ProNest representative for the appropriate abbreviations.
Image
3_10.png


There also exist some materials where ProNest and EPM disagree on the thickness. (This generally occurs with gauge plate). If/when this happens, edit the dimension of the plate in question in shapes/grades/sizes (select "Dimensions" and click "Edit Dimension"). You can enter in the thickness that ProNest wants in the field "ProNest Design".
Image
3_11.png

If your instance of ProNest is new, then there's a possibility that there are no materials (or very few materials, and no grades) in your ProNest materials database.  If this is the case, we need to export materials from EPM to ProNest after we put in all the "ProNest Shape Designations"s in Shapes/Grades/Sizes.
To do this, from the Shapes/Grades/Sizes menu, we choose Export->Export to ProNest.
In ProNest, we open the Materials Database (Data tab, materials), then choose file->Import, and import the file EPM created.
Then we have materials, with grades, that are useful.

Inventory Display Fields

Tekla EPM offers several fields in Inventory that prove useful to this Integration. Remnant ID shows the EPM ID of any Remnant. This is a static number, and will not change. ProNest ID shows the PlateID of the plate in ProNest Inventory. Remnant Name shows the name of the remnant (Description Field) in ProNest, and Remnant Type shows whether the remnant is a skeleton or a remnant. You can choose to display it in your Inventory Display Fields (Maintenance->Inventory->Inventory Display Fields).

Setting ProNest as the Default Plate Nesting Software

If desired, set ProNest as the default Nesting Software.
  • Go the the Maintenance menu, Combining then Company Standards.
Image
3_12.png

Click the "Combining Optimizations" button, select the "Plate Nesting Settings" tab, then select "ProNest" from the dropdown. This choice will become the default for every Nesting run.
Image
3_13.png
Image
3_14.png

Setup in ProNest

ProNest Settings

In the File menu of ProNest, select Preferences:
Image
3_15.png

In General, under Options → CNC Output, check every box, then click OK:
Image
3_16.png

Setup for Reporting back to Tekla EPM

To get information about a nest back to EPM, use the "ProNest to FabSuite Nest Summary" report.
  • Place the file "ProNest to FabSuite Nest Summary.fr3" in the ProNest custom Reports directory. By default this is C:\ProgramData\Hypertherm CAM\ProNest (year)\Reports (FastReport)\Custom Reports.
  • Open the Report Manager by choosing “Reports” on the “Home” tab.
Image
3_17.png
  • The ProNest to FabSuite Nest Summary should appear in the Custom Reports List.
Image
3_18.png
  • If desired (for use in ProNest's One Click), add a Batch containing this report. (To add a batch, click "File", then "New", the "Batch").
  • Make sure an HTML destination is included in the Destinations. If it isn't, add it by clicking "File", then "New", then "Destination" on the Report Manager window.
Image
3_19.png
  • Select "HTML" to see the properties of the destination. Make sure that Pictures is set to "JPEG".
Image
3_20.png
  • Run the report by selecting the Reports dropdown, Export to FabSuite and Send to HTML:
Image
3_21.png



RETURN     NEXT
Was this helpful?